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General Information
Introduction
Welcome to ResSched™
ResSched makes it easier and more effective for businesses, health and educational
institutions, or other organizations to schedule their resources. If your organization schedules
equipment, space, people or other resources by the hour, fraction of an hour, or day,
ResSched can help. Spend less effort scheduling, while getting better use of your
organization's resources.
ResSched is offered in three editions, Standard, and Corporate.
ResSched Standard Edition is a versatile and effective scheduling tool for smaller
organizations (maximum of 5 update access users 162 using a local area network). It provides
all the functionality needed to make, view and print schedules.
The Corporate Edition has all the versatility of the Standard Edition with several additional
features 6 that allow them to integrate with other business processes and systems in your
organization. The Corporate Edition is suitable for local or wide area networks and direct
access through the Internet Corporate Edition licensees can also license the ResSched Web
Module which lets users and, if desired, the public access ResSched through their browsers.

-------------Features
Among ResSched's many features are:

Advanced Repeat Scheduling
ResSched offers a wide variety of options for scheduling repeat bookings
handles bookings that are repeated irregularly.

159 .

It even

Conflict Checking
ResSched checks every booking for conflicts with other bookings for any of the involved
resources 161 . You can also set ResSched to check for bookings on that are weekends,
outside regular work times, on any holidays and other special periods 162 you have
designated, or that cause double booking of clients. System Administrators can set
ResSched to disallow all conflicts, or accept conflicts if confirmed by the user
Resource Groups 161
Resources can be grouped together for easy scheduling and monitoring. You can group
resources as teams (different types of resources required for a booking), as classes (all
resources of the same type), and any other way you want. You can also create meta
groups 160 to filter your schedules by multiple criteria.

Graphical and Text Schedules
ResSched offers a wide variety of graphical schedule formats so you can see at a glance
what is booked when, and what is available. Text schedule lets you include detailed
booking information on screen, on paper, or in a pdf. Day, week, month, quarter, year,
and user defined periods are all available.
Pooled Resources

161
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ResSched can schedule several units of an inventoried resource, instead of having to
identify each unit individually.

Scheduled and Actual Times
You have the option of recording actual 159 booking time, as well as scheduled times.

Use Your Own Terms
Use your own terms as labels for resources, bookings, clients, and categories.

Resource Administration
You have complete flexibility to determine which users can book or view which resources.
ResSched also lets you give selected users the authority to administer access to
resources without giving them the more powerful access of a system administrator 162 .

Additional Corporate Edition features include:

Schedules on Web Site
Post schedules to your web site automatically.

ODBC Connectivity
Use your own reporting and analysis tools like Crystal Reports ® and Microsoft Excel® or
Access ®

Utilization Analysis
View and print utilization statistics by resource, resource group or client.

Invoicing
Issue invoices to your clients for resources used.

MS Word-based Text Schedules and Reports
Use editable Microsoft Word templates to print text schedules and reports.

Data Import
Import client and resource data from your other systems into ResSched.

Large Number of Users
Starts with a base license of 5 update access users and any number of additional users
can be added. There is also an unlimited view only users option.

Corporate Edition licensees have the option of adding the ResSched Web module that allows
ResSched users to make and view bookings. Public users can view schedules for authorized
resources if desired, and with the Extended Web module even make bookings. For more
information go to our ResSched Web Module page.
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----------First Use
ResSched initially creates a user name of 'FIRST USER' with a password of 'FIRST PASS' . This
user name has the highest level of access (System Administrator). Use it create the first users
- particularly the System Administrators - for ResSched. You should delete the 'FIRST USER' ID
before ResSched is released for general use, but not before at least one other System
Administrator ID has been entered and tested.

-------------------------Most Recent Version
The most recent version of ResSched is always available from our Web site at:
www.madrigalsoft.com

---------Support
For assistance installing or using ResSched, please call or e-mail.
Voice
E-mail

1.250.733.2570
Support@madrigalsoft.com

Madrigal Soft Tools
1027 Pandora Ave
Victoria, B.C.
Canada, V8V 3P6
-------------------------------------------------------------Window s and Microsoft Word are registered trademarks of Microsoft Corporation.
ResSched is a trademark of Madrigal Soft Tools Inc.

4

1.2

ResSched 9.9

License Agreement
IMPORTANT - READ CAREFULLY: This License agreement is a legal agreement between you
(either an individual or an organization) and Madrigal Soft Tools Inc. for use of ResSched. By
using ResSched, you agree to be bound by the terms of this agreement. If you do not agree to
the terms of this License agreement you must remove (uninstall) all copies of ResSched from
your workstations and network servers.
MADRIGAL SOFT TOOLS INC.
("MADRIGAL")
SOFTWARE LICENSE AGREEMENT
1.

Limited Use License.

MADRIGAL, the licenser, grants to you, the end user organization, a non-exclusive license to
use the copy of the software program(s) provided to you (the "MADRIGAL Software") for your
own internal corporate purposes in accordance with the following terms and conditions.
If your organization is using the Trial version of the MADRIGAL Software, the license period is
limited to 30 days from the first use of the MADRIGAL software unless otherwise agreed to by
MADRIGAL, Your organization may use the MADRIGAL software without limitation of the number
and type of users during this period.
If your organization has purchased a new or updated license from MADRIGAL or from an
authorized reseller, and received a branded system license file from MADRIGAL, the license is
perpetual for any releases of the MADRIGAL Software available up to one year from the
purchase date. Also, every end-user within your organization that uses the MADRIGAL
Software to create or edit (read/write) data must have their own unique user name and the
number of user names with such update access shall not exceed the number of update access
end-users specified at the time the license was purchased. The number of individual end-users
within your organization entitled to use the MADRIGAL Software to only view (read-only) data
shall not exceed the number of view only end-users specified at the time the license was
purchased.
2.

Title.

This License is not a sale of the MADRIGAL Software or a sale of a copy of the MADRIGAL
Software. MADRIGAL retains title and ownership of the Madrigal Software delivered by
electronic medium or recorded on the original disk delivered to you and all copies made
regardless of the form or media on or in which the original or any copy may exist. MADRIGAL is
selling to you the physical media, if any, on which the MADRIGAL Software is delivered and
licensing you to use for limited purposes the MADRIGAL Software. MADRIGAL retains all other
rights in the MADRIGAL Software and associated documentation delivered, in paper or
electronic form, with the MADRIGAL Software (the "Documentation")..
3.

Copying.

The MADRIGAL Software and the Documentation are subject to copyright protection. MADRIGAL
hereby permits the Licensee to make copies of the MADRIGAL Software and the Documentation
for its own internal, archival purposes only provided that such copies of the MADRIGAL
Software and/or Documentation remain within the possession and control of the Licensee,
MADRIGAL copyright notices are replicated or remain affixed or embedded in the Software and/
or Documentation, and you do not take credit for or re-sell the MADRIGAL Software and/or
Documentation.
4.

Express Restrictions on Use and Transfer.

You, or anyone working on your behalf, may not:
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modify, reverse engineer, decompile, create other works from, or disassemble the MADRIGAL
Software;
distribute the MADRIGAL Software other than the Trial version to any third party; or
post or upload the MADRIGAL Software other than the Trial Version to any web site, electronic
bulletin board, on-line service or other electronic network accessible by third parties.
You are authorized to distribute the Trial Version to third parties provided that you make the
third party aware it is a trial version only and is subject to these licensing terms.
If you wish to transfer the MADRIGAL Software other than the Trial Version to a third party, you
must first notify MADRIGAL, destroy all back-up or archival copies of the MADRIGAL Software
and then have the transferee provide MADRIGAL with an acknowledgment that the terms of
this License Agreement apply to them.
5.

Term.

This License is effective until terminated. You can terminate the license at any time by
removing or deleting the MADRIGAL Software from all computers into which the MADRIGAL
Software has been installed or transferred, destroying or returning to MADRIGAL all copies of
the Software on disc or other media and, if requested by MADRIGAL, providing MADRIGAL with
an officer's certificate attesting to the foregoing. This License will be terminated by MADRIGAL
immediately and without notice in the event that you fail to comply with any term or condition
hereof. Upon any termination, you will return to MADRIGAL, at your expense, the Software and
Documentation and any copies thereof whether or not the copying was authorized hereunder
and remove or delete the MADRIGAL Software from the memory of the computer into which the
MADRIGAL Software has been transferred.
6.

Limited Warranty and Disclaimer of Liability.

The Software is licensed "as is". However, in the event that you have received the MADRIGAL
Software from Madrigal on a physical media, MADRIGAL warrants the media on which the
Software resides to be free from defective materials or workmanship in normal use for one (1)
year from the date of original purchase. If a defect appears during the warranty period, return
the original media to MADRIGAL, for free replacement. No dealer, company or person is
authorized to expand or alter any portion of these warranties or this Agreement, and such
representation will not bind MADRIGAL.
APART FROM THE FOREGOING, THERE ARE NO OTHER OR FURTHER REPRESENTATIONS,
WARRANTIES, PROMISES OR GUARANTEES. ANY IMPLIED WARRANTIES COVERING THE
DOCUMENTATION, THE PHYSICAL MEDIA OR THE MADRIGAL SOFTWARE, INCLUDING
BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE, TO THE EXTENT PERMITTED BY LAW, HEREBY WAIVED
BY THE END-USER. IN NO EVENT SHALL MADRIGAL BE LIABLE TO YOU FOR ANY
CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES INCLUDING LOSS OF PROFIT OR
DAMAGES FOR BUSINESS INTERUPTION. The maximum liability of MADRIGAL in the event
that any of the above limitations are held unenforceable shall not exceed the license fee
paid by you, regardless of the form of any claim.
7.

Miscellaneous.

The validity and performance of this License Agreement shall be governed by British Columbia
law. This License Agreement is deemed entered into at Victoria, British Columbia. This License
Agreement shall enure to the benefit of MADRIGAL and its successors and assigns.
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Standard & Corporate Versions
ResSched is available in two versions, Standard and Corporate.
ResSched Standard Edition is a versatile and effective scheduling tool for smaller organizations
(maximum of 5 update access users 162 using a local area network). It provides all the
functionality needed to make, view and print a wide variety of schedules. License fees for the
Standard Edition are:
Base license (1 update access user)

$290 USD

Additional update access users (max. 4)

$45 each

Unlimited view only users

$190

The Corporate Edition have all the great scheduling features of the Standard Edition and adds
several functions that help integrate ResSched with clients' other systems and business
processes.
These features include:
resource utilization analysis;
client utilization and invoicing;
resource and client data import;
reporting using MS Word®;
single user ODBC

9

driver, so you can use your own reporting and analysis tools;

automatic schedule generation for web sites.
can add any number of users to the license.

License fees for the Corporate Edition are:
Base license (includes 5 update access users)

$990

Additional update access users

$75 each

Unlimited view only users

$390

General Information
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Ordering ResSched
----------General
Details for ordering ResSched Standard and Corporate Editions
purchase order are shown below.

6

by credit card, check, or

You are invited to try ResSched for 30 days without cost or obligation. After 30 days, you must
license ResSched or remove it from your system. While ResSched will continue to work past 30
days, your users' access to it will be increasingly delayed. When you order your license, you
get:
1.

A downloadable archive that contains, your system license file that converts the evaluation
version to the fully licensed version, the latest release of ResSched, and a pdf of the
ResSched manual. Corporate Edition users also receive the ODBC driver that lets you pull
ResSched data into other programs.

2.

Free updates and technical support for one year. After one year, you may purchase
another year of support and updates for just 20% of the regular license fee.

Both the Standard and Corporate Editions license fees are based on the number of users and
their type of access. Update access users are those that can change information in ResSched.
View only users can only see what is there. You can limit an update access user to view-only
access if you wish.
All are prices in USD.

Standard Edition License
Base license (includes one update access user)
Additional update access users (optional, maximum 4)
Unlimited view only users (optional)

$290
$49 each
$190

Corporate Edition License
Base license (includes 5 update access users)
Additional update access users (optional)
Unlimited view only users(optional)

$990
$75 each
$390

-------------------------Ordering Methods
If you encounter a problem while using any of the methods for ordering ResSched listed below,
please call Madrigal Soft Tools at 1.888.291.2911 or 1.250.733.2570.

----------------------------------------1. On-line with Credit Card

Our web site, www.madrigalsoft.com, has links for ordering on-line.

---------------------------2. By Phone with Credit Card
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We can accept VISA or Mastercard by phone at 1.888.291.2911 (U.S, and Canada), or
1.250.733.2570 (International)

---------------------------3. Purchase Order
We accept corporate and government purchase orders by fax or e-mail. Our fax number is 1
(604) 677 7553. E-mailed purchase orders or numbers must have your organization's
registered domain as part of your e-mail address (no Gmail, or other web mail addresses). Email puchase orders to sales@madrigalsoft.com

--------------------------------------3. Check or Money Order
You can order by money order or check payable in US funds to Madrigal Soft Tools Inc. To order,
print out and fill in the Standard Edition or Corporate Edition order form. Mail the order form
with payment to:
Madrigal Soft Tools Inc.
1027 Pandora Ave.
Victoria, B.C., V8V 3P6
Canada

For more information on ordering ResSched, please call us at 1.888.291.2911 (U.S. and
Canada) or 1.250.733.2570 (International)
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ODBC (Open Data Base Connectivity)
ResSched supports Open Data Base Connectivity (ODBC). ODBC allows customers to use their
own database managers, spreadsheets, and other applications to generate reports and
analysis using ResSched data. To access ResSched data from other applications, you must
have the 32 bit ODBC driver for TopSpeed data files. ResSched Corporate Edition licensees
received a single-user, read-only ODBC driver as part of their download archive.
To install the ODBC driver on a workstation:
1.

Run TS-ODBC-RO-505.exe that was sent in the download archive. The name of this file
may change from time to time but it will always include ODBC.

2.

Enter your name, your organization's name, and the serial number provided your in the
license e-mail sent with your download link.

3.

Click the Next button until you are finished the installation.

To configure the ResSched data file as an ODBC data source:
1.

From the Start button, go to Control Panel and select Administrative Tools.
If you are using 64 bit versions of Windows 7 or Vista, instead of going through Control
Panel/Administrative Tools, you must run odbcad32.exe located in the SysWOW64 folder
in your Windows folder from the Command prompt (e.g., C:\>)

2.

Select Data Sources (ODBC) and then click Add.

.
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4.

Enter your choice for name and description (the ones shown here are suggested). Use
the TopSpeed Super File button to enter the full path of the resdata.tps file in your
ResSched data folder, then click OK.

5.

Click OK.

Some ODBC applications require special configuration of the data source. The installation
program has installed a Help file for the Soft Velocity ODBC driver on your work station.
The ODBC driver provided is a read only driver. There is a read/write driver available as well,
but because using this driver can corrupt your ResSched data, we only provide the read/write
driver and its key on request.
If you need to use the ODBC driver on more than one workstation, you must purchase
additional licenses from Madrigal Soft Tools or, if you need four or more workstation licenses,
from SoftVelocity Corporation. If you order from SoftVelocity, make sure to use only the 32 bit
read-only driver. Using the read/write driver risks making your data files unusable.
SoftVelocity Corporation
1-800-354-5444
1-954-785-4555

http://www.softvelocity.com
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Trouble Shooting
'Cannot Connect to Server' Message
The ResSched client program cannot access the data files on the server. The most likely
causes of this problem are:
1. The server's firewall will not permit the client workstation to access the designated port
(default 2339). Remedy: Change firewall settings.
2.

The client program is trying to connect to the wrong IP address or port for the server.
Remedy: Double check that the IP address and port are right using the IP Server
Administrator program in the ResSched server program group. If the client user has
set the ResSched client to connect without confirming the IP address and port, use the
ChangeIP address program on the client to change the address and port.

3.

The Soft Velocity Data Server service is not running on the server. Remedy: Run the IP
Server Administrator as Administrator and start or, if necessary, install the service.

4.

You have not installed the server components of ResSched on the server yet.
Remedy: Install the server components.

'Action Cancelled' page shown when calling Help in ResSched
A security fix by Microsoft initially disallows compiled Help files (.chm) from running when the file
is located a different machine from the one being used. If you are using shortcuts to access
ResSched from another machine you may have this problem. Chm files can be called from a
remote machine by adding a Registry entry for a specified chm file from a specified location.
The ResSched installation program does this for you, but if you are creating the ResSched
shortcuts manually, or change the Start in property of the ResSched shortcut after you have
installed, you will have edit the entry manually using Regedit.
The Registry key to change is
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
Create or change the string value UrlAllowList
to
\\hostname\sharename\ressched.chm;
file://;
where hostname and sharename refer to the machine and path to the folder with ressched.
chm.
If you do not understand the information above, seek help. Changing Registry entries can
affect how ResSched and other software runs

Some Bookings Are Not Visible for Some Users
View, reserve and general users do not automatically have rights to view bookings for all resources.
System Administrators 162 can give these users the rights to view all or specific resources using the
Add/Update Users 134 window. Or, System Administrators and Resource Administrators 161 can make
individual resources available to some or all users using the Add/Update Resource 88 window.
*** 134
Date Format Isn't Right
Dates don't fit properly in some functions.
ResSched uses your Windows settings for date formats. For browsing or other situations
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where space is tight, the Windows short format is used. Where space is available, such as in
displaying entry fields, the Windows long format is used. Select your date format from the
Windows Control Panel.

Authorizing General or Reserve Users To Book Specific Resources
General 160 or Reserve 161 Users have been added to ResSched, but each time they try to book a
resource they are informed that they are not authorized to make that booking.
Before a general or reserve user can book a resource, he or she must be authorized by a
System Administrator or Resource Administrator to do so. You can authorize users for
resources from either the user properties or the resource properties.
From the user properties:
1.

Open the user entry with Add/Update Users 134 window, accessed from
File>Users>Add/Edit Users. Only a System Administrator can change user properties.

2.

If the user is to be allowed to book all resources, click the Authorize for All Resources
check box.

3.

If the general user is to be allowed to book only some resources, click the Book
Resources tab and click the Add button to select resources with the Browse Resources
Multiple Select 138 window

From the resource properties
1. Open the resource record with the Add/Update Resource 88 window, accessed from
Resources>Browse Resources. Click the Who Can Book tab, then click the Add button
to call the Browse Users - Multiple Select 138 window to select the General or Reserve
users.

Schedules called with the Toolbar Buttons have the Wrong Orientation - Vertical/Calendar or
Timeline
The toolbar buttons that call schedules use default vertical or time line orientation for the
graphic display of schedules. To change the default orientation, select the schedule you want
from the menu instead. If you choose an orientation that is different from the current default
orientation, ResSched ask you if you would like to make the new orientation the default.
Changes to Client or Resource Entries are not Showing up
Resource or Systen Administrators make changes to resource or client records but users don't see
the changes.
When Cache Resources on Start up or Cache Clients on Start up are turned on in System
Settings 141 , the resource and client information used is only updated when the user restarts
ResSched.

'OLE Automation Error xxxxx.dot cannot be found' error message
The user sees this message when they are trying to print a report using MS Word.
ResSched can't find the Word template file (.dot) or stylesheet (ResSchedStyle.rtf usually).
Remedy: Go to File>Word Setup>Document Templates. For each report you want to run,

General Information
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click the
beside the relevant template and style sheet entry and pick the approprate Word
template and style sheet .rtf file. This will fill in the complete path to the files in the entries so
ResSched can find them.
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Getting Started
Installing ResSched
ResSched requires you to install server program files with your data files on your server and
separate client programs on each workstation that uses ResSched. The ResSched requires
Windows 2000 or greater on your server. Ordinary workstation PC's can act as servers for
testing and moderate volume operational installations. If you are installing from an earlier
version into the same server folder, please make a backup copy of your *.tps files first. If
ResSched will only be used on one machine, choose the Server setup type.

Server
What you do

What the setup program does

Choose the 'Server' setup type.
Accept or modify the default folder
locations.

Installs both the server and workstation
program files on the machine acting as your
server. The default server folder is C:
\ClarionDataServer and the default folder for
the workstation programs is C:\Program
Files\Madrigal\ResSched.

Accept or modify the name and location
of program group.

Creates a program group of shortcuts in
Programs and a single shortcut on your
desktop.

Make sure any firewall on your server
permits the client workstations to
access the designated port.

Installs and starts the Soft Velocity IP Data
Driver as a Windows service using port 2339.
You can change the port after installation using
the IP Server Administrator 18 . For Vista and
Windows 7 machines use Run as Administrator.

If you are updating from an earlier
version, copy all the .tps files to the
server folder. If you updating from a
version before 9.2, convert your data
21 .

If you are updating the licensed
version of ResSched, remember to
copy your syslic.tps file into data
folder.

Client Workstation
What you do

What the setup program does

Choose the 'Workstation Only' setup
type.

Installs the required program files on the
workstation. The default program files folder is
C:\Program Files\Madrigal\ResSched.

Accept or modify the location of the
program files.

Getting Started
Accept or modify the name and location
of the program group.
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Creates a program group of shortcuts in
Programs and a single shortcut on your
desktop.

or
Choose the 'Shortcuts Only' setup
type.
Select the location of the ResSched
program files on the other machine.

Creates just a program group of shortcuts in
Programs and a single shortcut on your
desktop. The Workstation programs must
have already been installed on another
machine on the same local network.

Assistance
If you have any difficulty installing or using any version of ResSched, e-mail us at
support@madrigalsoft.com. Or call us at 1.888.291.2911 (U.S. and Canada) or 1.250.733.2570
(International)

Uninstall
If you decide not to license ResSched, you can remove all ResSched files from your system by
using the Add/Remove programs feature of Windows Control Panel. You must delete your
ResSched data folder manually.
Please let us know why you chose not to license ResSched. Your comments will help us develop
products and services that better meet the needs of clients like you.
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First Use
Host Address and Port
When you start ResSched for the first time, you will get this screen asking for the host address
and port number. If you are using the machine that is to hold your data, simply accept
localhost and port 2339 by clicking OK or pressing Enter.

Leave the Connect without confirming... check box turned off until you are certain
that ResSched is working properly.

Connection Failed Message
If you get the Connection Failed message it means the client program did not get a
response from the server program. The most likely causes are:
1.

The SoftVelocity IP Data Server service is not running on the server. The setup
program installed this service and tried to start it, but it may have been
unsuccessful. On the server, use Control Panel>Administrative Tools>Services, to
start the service.

2.

Your firewall is blocking connection. Create an exception either for ipreq.exe
located in your data folder (by default, C:\ClarionDataServer).

FIRST USER
ResSched uses 'FIRST USER' as the initial user ID with a password of 'FIRST PASS'. Use this
user id to create other user ID's to start. Be sure at least one other System Administrator user
ID has been set up and tested before deleting the 'FIRST USER' ID.

Registry Key
ResSched saves connection entries in the Registry key
HKEY_CURRENT_USER\Software\Madrigal\ResSched\IPDriver. Terminal Server applications
like Citrix may stop remote workstations from changing Registry keys.
The key can be
edited manually on the server. The key entries and default values are:

Getting Started

hostname
port
SkipConfirmAddress

localhost
2339
0

Assistance
If you have any difficulty installing or using any version of ResSched, e-mail us at
support@madrigalsoft.com. Or call us 1.888.291.2911 (U.S. and Canada) or at
1.250.733.2570 (International).
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Change Server Settings
For System Administrators

162

only.

The setup program will normally establish all the settings you need to run ResSched normally.
However, you may have special requirements such as SSL encryption, or need to change
some of the connection and access settings such as the port used by the server. There are
two utilities installed in the ResSched Corporate program group on the server :
1) The IP Server Manager lets you control and configure the Soft Velocity IP Data Server
service, including the port it uses. The Service Status must show 'running' to use ResSched or
the Remote Access Administrator. 'Server Connection Failed' errors are most often caused by
the service not running.
For Vista, Windows7, and Windows 8 users only, the IP Server Manager must be run as
administrator. To do that, right click the IP Server Manager shortcut and select Properties.
Click the Shortcut tab and then the Advanced button. Turn on 'Run as administrator'.

2) The Remote Access Administrator lets you modify your connection settings and authorize
access to your data files. With the possible exception of changing the server time out settings,
there is usually little need to use this utility. To use the Remote Access Administrator, you
must have the Java Development Kit or Java run time engine 1.4 or greater already installed on
your server. If you don't, you can download the JDK or run time engine from http://java.sun.

com/downloads/index.html.
When you run the Remote Access Administrator, choose Connection>Connect to IP Server.
Enter Administrator as the user name without a password. If you have changed the port, enter
the hostname and new port separated by a : as shown for the default entry for the Server
field. Click Connect. Under Data Managers, you should see IP_ResSched.dll as shown here.

Getting Started

19

If you want to view or change the inactivity timeout setting, click Tools.
Registering the IP_ResSched.dll
Should the IP_ResSched.dll Data Manager be missing, right click on Data Managers and
select Register Data Managers. Select IP_ResSched.dll and click Register. Click the + beside
Data Managers to expand the section and select IP_ResSched.dll under Data Managers. A
list of tables should appear. Right click on any of the tables and select Table Permissions.
You should see two ID's, Administrator and Guest, both with all boxes checked. Click Apply to
All Tables and then OK.

SSL Encryption
ResSched lets you use Secure Socket Layer (SSL) encryption. Simply choose the SSL port (by
default 2340) when you log in.
SSL works with key pair files. The ResSched installation program places one key pair file,
server.pem, in the server data folder and the other, client.pem, in your workstation ResSched
program folder. These key pair files work but they are not unique to your organization, so
another organization using these same key files could unencrypted data you send over the
Internet.
To generate your own unique keys, you must use the OpenSSL tookit. Openssl.exe program
is a command line tool for using the various cryptography functions of OpenSSL's crypto library.
You can obtain the OpenSSL utilities from various Internet download sites. OpenSSL is
available for download in source format from http://www.openssl.org. There are also pre-built
binary versions available for download, one source for a Win32 binary version is the Win32
OpenSSL Installation Project available from: http://www.slproweb.com/products/
Win32OpenSSL.html. ResSched uses the PEM (Privacy Enhanced Mail) format and your keys
should be named server.pem and client.pem.
LEGAL NOTICE: This product includes software developed by the OpenSSL Project for use in
the OpenSSL Toolkit. (http://www.openssl.org/). The OpenSSL toolkit is licensed under an
Apache-style license, which basically means that you are free to get and use it for commercial
and non-commercial purposes subject to some simple license conditions. For details of the
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license please refer to http://www.openssl.org/source/license.html.
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Converting Old Data
If you are using a version of ResSched earlier than 9.2, you must convert your existing data
files (*.tps) to use this release. The default data folder is C:\ClarionDataServer on your
server. The data folder is shown as the 'Path to executable' property of the SoftVelocity IP
Data Server service on your server. If you were using a Standard Edition release before 9.7,
your old data folder is shown as the Start In property in your old ResSched shortcut.
1.

Backup your *.tps files. VERY IMPORTANT!

For Standard Edition system administrators , copy your old tps files to the newly created data
folder (C:\ClarionDataServer by default).
2.

Run convold.exe from within your data folder.

3.

When the Convert Data window appears, enter the location of the data files you are
converting and from which version you are converting. Then click Convert

If you get an error message at any point of the conversion, try again. Still a problem? Contact
us at 1.888.291.2911 (U.S. or Canada) or 1.250.733.4676 (International) or
support@madrigalsoft.com.
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The Basics
ResSched is used to schedule resources. At the most basic level there three basic data
components: resources, bookings, and clients. There are also three basic functions: adding/
updating the information, viewing the schedules in text or graphic formats, and printing.
A resource is anything that you want to schedule. It can be a piece of equipment, a meeting
room or even a person. Before you can do any scheduling, you must add resources to
ResSched. (See: Resource, Add 60 ).
If you are scheduling resources for a person or organization, you must add them as clients. (
See: Client, Add 58 ).
Once you have added resources to the program, you can begin to make bookings that involve
those resources. A booking is an event or activity that will occur. It can be a single occurrence
or repeating event. (See: Booking, Add/Update 49 ).
You can view your schedules either as lists of text called Browse (See: Bookings, Browse 52 ),
or as one of many graphical representations called Schedules (See: Bookings, Browse 52 ). In
general, Browse provides more information about the bookings but the Schedules let you see
availability at glance.
Both the Browse and Schedule screen displays can be reproduced on paper or as a pdf by a
Print button
And that's all there is to it.
To let you get started quickly, the key concepts, windows and instructions have been grouped
together. Going through the topics listed below will give you enough information to start using
ResSched right away. While these core functions will give you benefits immediately, you will
gain more by knowing the many other ResSched functions. There are also a set of tutorials
installed with ResSched.
Menu and Toolbar 25
Add a User 74
Add a Resource 60
Add a Booking 49
Add a Client 58
View Booking Schedules as Text (Browse)
View Booking Schedules Graphically 53
Print Calendars 44
Set System Settings 69

79
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Quick Start
After installing ResSched, a system administrator 162 can get ResSched ready for operation by
general 160 , reserve 161 and view only 163 users.
Setting users' access to resources and resource groups
The system administrator you can add resources and users and establish which users get book
and view which resources. ResSched lets you establish user access to resources when you
are creating or editing a resource entry , or when creating or modifying a user record. You can
also specify which users can use which resource groups 161 . The user's right to use a resource
group does not affect their right to book or view a particular resource in the group.
When creating or modifying a resource entry, can specify that the resource can be booked by
all general or resserve users, or viewed by all general, reserve, and view only users. You can
also select which general or reserve users can book and which general, reserve and view only
users can view the resource.
When creating or modifying a user entry, you can specify that a general or reserve user is able
to book all resources or select the resources the user can book. The same applies to general,
reserve view only users' rights to view the resource. You can also select which resource
groups you the user can use.
Whether you choose to create your resources and then create your users or vice versa is up to
you. In general, if you plan to extensively limit users' rights to book or view resources, it is
probably more efficient to create the users and any user groups 163 you need before creating
the resources.

System wide settings
There a few system settings that should be determined before you start operations. See
System Settings, Set 69 . One of the most important is determining whether your booking
occurrences cross midnight 159 .
You will want to set the work day times to reflect your organization's hours of operation.
These settings are on the User settings tab.
You should also decide whether to let general users create new clients when they are making
a booking.
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Users
ResSched lets you give different access rights for different ResSched functions to individual
users. Access levels are grouped by user function, rather than rights to specific files or records.
There are five categories of user: System Administrator 162 , Resource Administrator 161 ,
General User 160 , Reserve 161 , and View-Only 163 . All users types except View-Only are
considered update access users for the purposes of your license.

-----------------------------------------------------------System Administrators (Access level 4)
Having the highest level of access rights, System Administrators can add and change user
information, including access rights, passwords, and access suspension. Also, they can change
any of the program-wide restrictions, defaults and settings for entering and displaying
information. System Administrators can also set up user groups. These are lists of general,
reserve, or view only users that can be used to give or remove booking authority for specific
resources. System Administrators have all the rights of other users. Because System
Administrators have the "keys to the kingdom", you should keep the number of users with
System Administrator rights to a minimum.

--------------------------------------------------------------Resource Administrators (Access level 3)
Resource Administrators are a special class of user who control access to resources 161 . They
add, change and delete resources from ResSched. Their most important job is determining
which general users can book specific resources. Also, they can override booking locks 160 , and
create and edit resource groups 161 of resources. Each Resource Administrator has access to all
resources entered in ResSched, so some care should be taken in giving users this level of
access.

---------------------------------------------General User (Access level 2)
General Users can book or view a resource if they have been approved by a Resource or
System Administrator for that resource. General Users can also create or change client entries,
if the System Settings have been set to allow it.

---------------------------------------------Reserve User (Access level 1)
Reserve Users are like general users, but with more limitations. They can only use one status
type, so you can see at a glance which bookings are by reserve uses and which are by other
user types. They cannot change the details of their bookings after that booking has been
modified (confirmed) by a Resource Administrator, but they can delete the booking. They can be
prohibited from seeing the details of any other bookings but their own (see System Settings 141
).

-------------------------------------------------View only user (Access level 0)
As the name implies, these users are only allowed to view booking and resource information of
the resources for which they have been approved.
When ResSched is started for the first time, it creates a user with a name of 'FIRST USER' and a
password of 'FIRST PASS'. This user ID has System Administrator level access. Use this user
name and password to enter at least one other System Administrator user and then delete the
'FIRST USER' user after testing the new ID.
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Menu and Toolbar
Menu
The main window for ResSched has the familiar Windows-type menu and toolbar. All
ResSched functions operate from this menu. The toolbar below the main menu contains
shortcut buttons for some of the more frequently used functions.
Please note: If your system administrator has changed any of the labels for bookings 159 ,
resources 161 , clients 159 , and categories 159 , the new labels will be used in the menus and
toolbar buttons.

File Menu
System Settings

Allows System Administrators 162 to set default values, display settings,
conflict checking 54 options and other features

Users

Accessible only to System Administrators.

Add/Edit
Users

Add users to ResSched, change the access rights of users
user access after too many login failures

User Groups

Create or change user groups

Print Setup

24

, and reset

163 .

Standard printer setup window.

User Preferences Lets users change default values and display settings according to their
needs. Not available to view only users
Change
Password

Lets users change their passwords.

Word Setup

Users may use Microsoft Word to generate ResSched reports. Use this
feature to implement or change the settings. Corporate Edition 6 only.

Import Data

Allows system administrators to import data 42 from outside ResSched.
The data must be a csv file in prescibed format. Corporate Edition only

Client

Select name of source file with client 159 data

Resource

Select name of source file with resource 161 data.

Exit

Exit ResSched.

Booking Menu
Add Booking

Add a new booking 159 entry. Not available to view only users

Browse
Bookings

Browse through all bookings in a specified period, using tabs to sort and
filter the bookings.

Browse Alphabetically

Browse through all bookings in a specified period, listed in alphabetical
order of bookings
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Purge Old
Bookings

Delete all bookings that occurred before a specified date in the past.
Available only to System Administrators.

Resource Menu
Add Resource

Add a new resource to ResSched. Available only to System and Resource
administrators.

Browse
Resources

Browse the resources listed in ResSched.

Resource Groups

Add, change or delete resource groups

Rebuild ALL
group

Rebuild the resource group that has all the resources in it (ALL).
Available only to System and Resource administrators.

Utilization

Display utilization by resource group or just one resource. Available only
to System and Resource administrators. Corporate Edition only.

161 .

Client Menu
Add Client

Add the name and related information of a new client to
ResSched. Available only to System and Resource administrators,
and to General Users if the 'Allow general users to add clients'
check box has been checked in the Update System Settings
window.

Browse Clients

Browse the clients.

Delete Multiple
Clients

System and Resource administrators may delete several clients at
once.

Utilization by
Client

Displays the resource usage by a client for given periods.
Available only to System and Resource administrators. Corporate
Edition only.

Invoice Clients

Used to generate a paper bill for billing purposes. Available only
to System and Resource administrators. Corporate Edition only.

Categories
Add Category

Create a new category 159 .

Browse
Categories

Browse the categories.

Schedules Menu
Many of the schedules provide you with the option of a timeline layout (resources displayed
down the left of the window; days and time displayed across the top). The alternative is a
vertical layout (time running down the left of the window), or a standard calendar layout.
When you choose between the timeline layout and the vertical or calendar layout, your last
selection is used as the layout for the corresponding toolbar button and is marked with a
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check mark.
Single Resource
Week

View the bookings of a single resource for a week with time displayed
down the screen while the day of the booking is displayed across.
Corresponds to the Week Resource button.

Month

View the bookings of a single resource for a month in a standard monthly
calendar format. Corresponds to the Month Resource button.

Pooled
Resource

Display how much of a pooled resource has been booked in all the time
slots for a week.

Resource group
Day

View the bookings of all resources in a resource group for a day. Choose
between timeline layout and vertical layout. Corresponds to Day
Resource Group button.

Week

View the bookings of all resources in a resource group for a week.
Choose between timeline layout and vertical layout Corresponds to the
Week Resource Group button

Month

View the bookings of all resources in a resource group for a month.

Choose between timeline and standard calendar layouts. Corresponds
to the Month Resource Group button.
Quarter

View the bookings of all resources in a resource group for a calendar
quarter. Available only in timeline layout.

Year

View the bookings of all resources in a resource group for a calendar
year. Available only in timeline layout.

Flexible
Period

View the bookings of all resources in a resource group for user specified
period. Available only in timeline layout. This view cannot be printed.

Client
Day

View the bookings of a single client for a day in timeline layout.

Week

View the bookings of a single client for a week. Choose between timeline
and vertical layouts. Corresponds to Week Client button.

Month

View the bookings of a single client for a month. Choose between
timeline and calendar layout. Corresponds to Month Client button

Category

Text Calendars

Category schedules are all timeline. Corresponds to Category button.

To print calendars with booking information. Calls the Print Text Calendars
window to select period, resources to include, and format of calendar to
print.

Help Menu

Contents

Display a list of main Help topics from which you can m ake a selection.

Search for Help

Do keyword search for Help on specific topic.
o
n
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.
How to Use Help

How to use this Help facility.

ResSched Terms

If a System Administrator has changed the labels for the standard terms
used by ResSched, this displays the new labels with their ResSched
equivalents.

Licensing

Provides information on obtaining a license for ResSched.
R
e
s
S
c
h
e
d

About ResSched

Display version number and name of license holder for this installation of
ResSched.

Toolbar
The toolbar buttons are one-touch buttons that let you carry out tasks that would require
multiple menu selections or other input. The toolbar buttons cover some of the most commonly
used ResSched functions. From left to right, the toolbar buttons are:
Add a new booking to ResSched.

Browse bookings (text schedules).

Display the bookings of a resource group for a day in a graphical schedule
using the last layout you selected using Schedules>Resource
Group>Day in the menu
Display the bookings of a resource group for a week in a graphical
schedule using the last layout you selected using Schedules>Resource
Group>Week in the menu

Display the bookings of a resource group for a month in a graphical
schedule using the last layout you selected using Schedules>Resource
Group>Month in the menu
Display the bookings of one resource for a week in a graphical schedule
using a vertical layout. Corresponds to Schedules>Single
Resource>Week
Display the bookings of one resource for a month using a standard
calendar layout. Corresponds to Schedules>Client>Month in the menu
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Display the bookings of a client for a week in a graphical schedule using
the last layout you selected using Schedules>Client>Week in the menu

Display the bookings of a client for a month in a graphical schedule using
the last layout you selected using Schedules>Client>Month in the menu

Display the bookings of a category in a timeline schedule. Corresponds to
Schedules>Category in the menu
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Examples of Use in Different Organizations
The narratives below demonstrate how different types of organizations can use ResSched to
meet their business goals. These examples are just some of the many ways ResSched can
help.

---------------------------------------------------------------

College Audio-Visual Department
Phil is the manager of the Audio-Visual Department at a small college on the East Coast. Owing
to successive budget cuts, he lost the person who manually kept track of equipment loans to
other departments. As a result, Phil's daily activities are mostly concerned with providing audiovisual equipment to various other departments on campus and servicing equipment before it is
sent out. To help him in this task, Phil uses ResSched to keep track of all the equipment in his
department.
One of the first things Phil did when he obtained ResSched was change the generic labels that
are standard on ResSched. He opened System Settings 141 (File>System Settings) and clicked
the Labels tab. He then changed the ResSched Booking term to "Location," the ResSched
Resource term to "Equipment," and the ResSched Client term to "Department." This allows him
to deliver specific equipment to the exact room in a specific department.
But getting the equipment to and from each room on time is a continuing challenge for Phil.
Being short staffed, Phil lends out equipment with the understanding that his staff will deliver it
but instructors must return it when their lectures are over. Over the years, however, Phil has
observed that many instructors fail to return borrowed equipment on time. Consequently, Phil
never assumes that the booked times for a piece of equipment correspond to the actual times
it is out. By tracking the booked times against the actual times, he is able to charge those
departments a late fee. ResSched allows him to continue this practice. In System Settings (
File>System Settings), Phil clicks the 'Enable actual times' check box on the General tab.
When he creates a new booking, he enters the start and end times on the General tab, but he
also records the Actual start and end times on the Actual Times tab.
Another feature of ResSched that Phil uses is pooled resources, or in his case, pooled
equipment. For example, he has 10 DVD players that are in constant use. He's not concerned
about identifying which unit is assigned to which location, as all the DVD players are the same
make and model. Nonetheless, Phil must carefully track the whereabouts of these machines
because the demand for them is so high. A quick way for him to do this is to view the
availability of pooled equipment (Schedule>Availability>Pooled Equipment). By entering the
name of the pooled equipment and any date in a week, he can see when and how many DVD
players have been booked.

-----------------------------------------

Physiotherapy Center
Mary Ellen is the Administrative Assistant at the Stay Well Physiotherapy Center. She uses
ResSched to track all the appointments for individual therapists.
As soon she installed ResSched, she changed the generic labels to ones that are more suitable
for her needs. She opened System Settings 141 (File>System Settings) and clicked the Labels
tab. She then changed the ResSched Booking term to "Procedure," the ResSched Resource
term to "Therapist," and the ResSched Client term to "Patient."
When a new patient reports to the clinic, Mary Ellen opens a new patient window (
Patient>Add Patient) and fills in all the information about that person, paying particular
attention to the name of a contact person, and using the Misc. field at the bottom of the
window to enter the patient's medical plan name and number.
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Since she has a database program installed on her computer, and she is comfortable using it,
Mary Ellen ordered and installed the appropriate Open Data Base Connectivity driver that
allows her database program to generate custom reports from ResSched.

-------------------------------------------------------

Heavy Equipment Contractor
Ted is the office manager at Double D Contractors, a family-owned company that specializes in
earth moving, road building and other categories involving heavy equipment.
To accommodate his requirements, Ted changed some of the generic labels in ResSched. In
System Settings 141 (File>System Settings), he clicked the Labels tab and then changed the
ResSched Booking term to "Location," he left the Resource label as is (where the term means
both equipment and an operator), and he also left the Client term as is.
Since most projects needing heavy equipment require days or weeks to complete, Ted has
bookings that end on a different day than when they start. To accommodate them, he opens
System Settings, turned on 'Locations cross midnight' and then set 90 days as the maximum
length of a booking occurrence. Then, when he makes a booking (Location>Add Location) he
is able to enter both the Start Date and End Date for each commitment of resources in the
Add/Update Location 76 window.
Ted has entered each piece of equipment in ResSched using the Add/Update Resource 88
window. To see all his equipment bookings displayed on a single window, Ted used the Add/
Update Resource Groups 97 window to create a Resource Group for equipment and called it
'EQUIPMENT'.
Ted also knows that for each piece of heavy equipment in his inventory, several operators are
trained to use it. Consequently, he used the Add/Update Resource window to create a list of
all personnel. Then, he created Resource Group names corresponding to each type of
equipment (e.g., D9 Operators) and used the Add/Update Resource Groups window to add
the names of qualified operators to each group. Since many of the operators are qualified to
operate more than one piece of equipment, Ted has placed them in more than one Resource
Group.
Before Ted makes a booking, he uses the Resource Goup Timeline Schedule 113 window with
the time scale set to month to see at a glance which equipment is available when. He enters
the month he wants to view, the EQUIPMENT group, and clicks GO. If he has equipment
available, he also does the same for the operator group for that equipment.
When Ted makes a booking, he uses the Add/Update Location 76 window to enter the place
and time of the booking. Then he goes to the Resource section on the window and clicks the
Add button. He selects the piece of equipment he wants and it is added to the booking. He
clicks the Add button again, but then clicks on the Resource Group tab to limit the list of
resources to just those of the 'Operator' group he wants. He selects the operator from that
list, and the operator is added to the list of resources for the booking.

----------------------------

Office Manager
Krista is the office manager of a company, and she needs a better way to schedule the
meetings and appointments of managers and staff. Krista is already using ResSched to
schedule meeting rooms and equipment, so she has decided to use it for people as well. For
scheduling people, Krista has to let people make confidential personal and business
appointments for themselves and limit which users can schedule which people.
The first thing Krista does is turn on 'Allow private bookings' in System Settings 141 (
File>System Settings). Then she makes a resource entry for each person who is to be
scheduled. She knows that user and resource are not the same thing even though they might
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have the same name.
Krista opens the Add/Update Resource 88 window (Resource>Add Resource) and begins
adding the names of the people to the resource list. They are: Bill Smith, IT Manager; Don
Smothers, HR Manager; Gayle Wurler, Lab Manager; Joe Rogers, Sales Manager; Joyce Tanner,
New Products Manager; and Tina O'Brien, Senior Secretary. Krista makes sure when adding
these names to the resource list that she does not check the 'All general users can book'
check box on the Authorized Users tab of the Add/Update Resources window. Instead, she
adds just the User names of the person, their secretary and their boss to the list of users
authorized to book that person.
Now, when people make appointments for themselves that they wish to keep confidential, they
simply check the 'Private' box in the Add/Update Booking 76 window. Then, only the person
making the booking will be able to see the booking name, client and notes when the schedules
are displayed or printed.
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Backup Your Data
Hard disks fail, files can be corrupted. It is an unfortunate fact of life. To avoid losing
ResSched data, you should include the data files (*.tps) in your regular backup routine.
Your backup routine should be no less than once a day, include files for at least the last
three days. Store your backup data on different machine or media than the machine
holding your operational data. We recommend using a cloud backup service that
automatically backs up your data off site.
Don't forget to test your backup routine from time to time.
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How Do I?
Order ResSched
----------General
Details for ordering ResSched Standard and Corporate Editions
purchase order are shown below.

6

by credit card, check, or

You are invited to try ResSched for 30 days without cost or obligation. After 30 days, you must
license ResSched or remove it from your system. While ResSched will continue to work past 30
days, your users' access to it will be increasingly delayed. When you order your license, you
get:
1.

A downloadable archive that contains, your system license file that converts the evaluation
version to the fully licensed version, the latest release of ResSched, and a pdf of the
ResSched manual. Corporate Edition users also receive the ODBC driver that lets you pull
ResSched data into other programs.

2.

Free updates and technical support for one year. After one year, you may purchase
another year of support and updates for just 20% of the regular license fee.

Both the Standard and Corporate Editions license fees are based on the number of users and
their type of access. Update access users are those that can change information in ResSched.
View only users can only see what is there. You can limit an update access user to view-only
access if you wish.
All are prices in USD.

Standard Edition License
Base license (includes one update access user)
Additional update access users (optional, maximum 4)
Unlimited view only users (optional)

$290
$49 each
$190

Corporate Edition License
Base license (includes 5 update access users)
Additional update access users (optional)
Unlimited view only users(optional)

$990
$75 each
$390

-------------------------Ordering Methods
If you encounter a problem while using any of the methods for ordering ResSched listed below,
please call Madrigal Soft Tools at 1.888.291.2911 or 1.250.733.2570.

----------------------------------------1. On-line with Credit Card

Our web site, www.madrigalsoft.com, has links for ordering on-line.

----------------------------
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2. By Phone with Credit Card
We can accept VISA or Mastercard by phone at 1.888.291.2911 (U.S, and Canada), or
1.250.733.2570 (International)

---------------------------3. Purchase Order
We accept corporate and government purchase orders by fax or e-mail. Our fax number is 1
(604) 677 7553. E-mailed purchase orders or numbers must have your organization's
registered domain as part of your e-mail address (no Gmail, or other web mail addresses). Email puchase orders to sales@madrigalsoft.com

--------------------------------------3. Check or Money Order
You can order by money order or check payable in US funds to Madrigal Soft Tools Inc. To order,
print out and fill in the Standard Edition or Corporate Edition order form. Mail the order form
with payment to:
Madrigal Soft Tools Inc.
1027 Pandora Ave.
Victoria, B.C., V8V 3P6
Canada

For more information on ordering ResSched, please call us at 1.888.291.2911 (U.S. and
Canada) or 1.250.733.2570 (International)
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Log In - Start ResSched
Click on the ResSched shortcut, either on your desktop or throught the Windows Start button.
Enter the IP address and port number of your server. Your system administrator can tell you
these. If your workstation is also your server, by default the IP address is localhost and the
port number is 2339. The address and port are saved between sessions. Once users have
confirmed that the connection works, they can opt to connect without entering the address
and port.
All update access users must have unique user names. User names and initial passwords are
created by the System Administrator 162 .
Enter your user name and password in the log-in window and click OK.
The initial user ID shipped with ResSched is 'FIRST USER' with a password of 'FIRST PASS'.
After creating and testing a new system administrator ID (access level 4), the FIRST USER ID
should be removed.
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Change IP Address of Server
The ResSched workstation program needs the IP address and port of the server to connect to
your data files. By default, you confirm the address and port each time you log in. However,
you can choose to skip this step if you are confident the IP address and port are correct and
unlikely to change. If you turn on skip address confirmation setting, you must use the Change
IP Address program (installed in ResSched program group) each time you want change or
even view the address and port settings. Technically sophisticated users can also change the
IP address manually by editing the HostName and Port entries of the [IPDriver] section of
HKEY_CURRENT_USER\Software\Madrigal\ResSched\IPDriver in the Registry.
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Use Multiple Data Sets
Corporate 6 Edition licensees can support multiple data sets from the same server. Each
data set has its own resources, clients, bookings, and users independent of all the other
data sets.
For each data set you want to support:
1. Make a new folder under the main data folder on your server (C:\ClarionDataServer
by default).
2. Copy the IP_ResSched.dll and syslic.tps to each new folder. You can copy the
users.tps file as well, if you want to give some or all of those users access to the
other data set.
3. Register the IP_ResSched.dll in the new folder, as described in Changing Server
Settings 18 .
4. Start ResSched normally but when asked for the Host address and port number,
enter the name of the new folder (just the name, not the path) as the Sub
Directory. Note: Existing users may have turned on the Connect without
confirming host address and port option. If so, they must use the Change IP
Address program in the ResSched program group change the address, port or
subdirectory.
5. If you have not copied the users.tps file, you will have to use the "FIRST USER" id
and "FIRST PASS" password to create a new system administrator id for yourself
so you can create ids for the other users.
6. Instruct the users of the new data set to put the name of the new folder in the
Sub Directory field when they go to use the new data set for the first time. You
can include the subdirectory in the command line of a ResSched shortcut. Set the
target property to:
"C:\ResSched Corporate\resschm.exe" subdirectory=yoursubdirectory .

Under your license every individual who your organization permits to update ResSched
must have their own unique user ID and the total number of unique update access user
id's for all data sets must not exceed the number covered in your license.
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Network Login, Use to Access ResSched Directly
System administrators 162 can set ResSched to accept users' network login instead requiring
users to enter a user name and password
1.

Select File>System Settings. The Update System Settings 141 window appears.

2.

Click the Security and Maintenance tab.

3.

Check the Use Network User Name check box. ResSched will enter the user's network
name as the user name when the program starts up. The Skip Password check box
will be enabled.

4.

If the Skip Password box is turned on, the network users will go directly to ResSched
main menu when they start ResSched.

Note: System administrators must use the network user name of as the ResSched user name
for all ResSched users.
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Change Layout Used by Schedule Buttons in Tool Bar
The schedule buttons on the main tool bar 25 use the last layout chosen for the schedule with
the Schedules menu (shown with a
). To change the layouts used by the buttons from
timeline to vertical or calendar 113 , simply choose the schedule and desired layout using the
Schedules menu.
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Use ResSched Data in Other Programs
See Open Data Base Connectivity
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Import Data
Corporate Edition Only
ResSched allows you to import data about clients and resources from outside the program.
Only system administrators 162 can access this function using File>Import Data. Your source
files must be named IMPORTCLIENT.CSV and IMPORTRESOURCE.CSV, and be located in
your server folder, (C:\ClarionDataServer by default).
The import function loops through the source file adding the information for each record where
the client or resource is not already in ResSched. If a client or resource already exists by that
unique name, the import function replaces the existing ResSched record with the one in the
source file. The import function does not delete records. You can delete resource or client
records ResSched using the appropriate ResSched functions.
Strict conditions apply to importing data:
There must be no other users using ResSched at the time.
You should do a backup before importing data.
The source file is comma delimited ASCII and can be either .txt or .csv.
Empty fields must still have a comma to mark their place if any of the fields that come
afterwards contain data. If not, they can be left off altogether.
If a field's content has a comma in it, the entire field must be placed within double
quotes.
Each record in the source file must be on one line.
Carriage returns and line feeds can not be included in any field
The fields in the source records must follow a precise order.
The order and attributes of the fields for the Client record are:
FIELD

ATTRIBUTES

Client

Up to 50 characters. A required field. Name must be unique.

Contact

Up to 30 characters.

Phone

Up to 20 characters.

Other

Up to 20 characters.

E-mail

Up to 50 characters.

Mobile

Up to 20 characters.

Misc

Up to 30 characters.

Address

Up to 200 characters, but without carriage return/line feed.

Notes

Up to 2,000 characters, but without carriage return/line feed.

For the Resource records:
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Resource

Up to 30 characters. A required field. Name must be unique.

Units

Numeric. Defaults to 1 if no number is present.

Authorize All Book

Numeric. 1 - lets all general and reserve users book this resource; 0 general and reserve users must be specified. Defaults to 0.

Authorize All View

Numeric. 1- let all general, reserve, and view only users view this
resource;0 - general, reserve, and view only users must be specified.
Defaults to 0. If Authorize Book All is 1, all general and reserve users
can view this resource regardless of Authorize View All.

Rate

Numeric with two decimal places. For minute, quarter hour, half hour,
hourly and daily rate.

Rate Period

Numeric. 0 - hourly; 1 - daily; 2- by minute; 3 - by quarter hour; 4 - by
half hour. Defaults to 0.

Notes

Up to 1000 characters, but without carriage return/line feed.

Misc

Up to 20 characters.

Here are some examples of correct and incorrect import source records:
Correct client source records
ABC Company,"Smith,Bill",(123) 456 7890,(123) 456 0987,Bill.Smith@ABCco.com
ABC Company,Bill Smith,(123) 456 7890,,Bill.Smith@ABCco.com
ABC Company,,,,Bill.Smith@ABCco.com

Incorrect client source records
ABC Company,Smith,Bill,(123) 456 7890
Reason: Contact field has comma but field not in quotes
ABC Company,"Smith,Bill",(123) 456 7890,Bill.Smith@ABCco.com
Reason: Missing Other field between phone and e-mail

Correct resource source records
S CEDAR RM,,,,50.00,0
This is an individual resource that is charged out at $50.00 per hour
FOLDING TABLES,10,1
A pooled resource of 10 folding tables that any general user can book

Incorrect resource source records
,FOLDING TABLES,10,1
Reason: First comma has displaced all the fields
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Schedules, Print
To print the graphical schedules, simply call the schedule window you want and click the Print
button. You can also print the information shown in the Browse Bookings window 79 by
clicking Print.
There are also several other detailed text schedules that provide additional information or
show the information in a different format. To print these other text schedules:

1.

Select Text Calendars from the main menu. The Print Text Calendars 156 window will
appear.

2.

Select which period to cover:

3.

Day

Covers the date entered in the Start Date field.

Day by
Resources

Each resource's bookings on the date selected are grouped
together and then listed from earliest to latest.

Week

The week shown includes the date entered in the Start Date field.
Bookings are listed down the page in date/time order.

Week in Day
Columns

The days of the week are shown in columns with the bookings for
each day listed in chronological order below them.

Flexible Period

Any period you wish, beginning with the date entered in the Start
Date field and ending on the date entered in the End Date field
(only visible when Flexible Period selected). Notes are not included.

Select the bookings that should be included:
All Resources

Bookings for all resources entered in ResSched will be included.

One Resource

Print calendar for a single resource. Upon choosing this option, the
Browse Resources 90 window will appear for you to select the
desired resource.

Resource Group

Include all the bookings that involve at least one resource on the
group you select. Upon choosing this option, the Browse Resource
Groups 99 window will appear for you to select the desired group.

Client

Include all bookings for a specific client. Upon choosing this option,
the Browse Clients 105 window will appear for you to select the
desired client.

Category

Include all bookings for a specific category. upon choosing this
option, the Browse Categories 111 window will appear for you to
select the desired category.

4.

Enter the start date for the calendar. (If you have chosen Flexible Period, also enter the
end date.

5.

Choose whether to include booking notes, client detail, and the category by checking
the appropriate boxes.

6.

Click the Preview check box if you wish to view the report before it is printed.

7.

Click the Print button. If the Preview check box has been checked, you may choose
options for the pages to be printed, the number of copies, page configuration and the
degree of magnification of the information in preview mode.
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If no bookings match the options you have selected, no calendar will be printed.
You can also print bookings according to date by clicking the Print button of the Browse
Bookings 79 window. You will be asked for the end date of the period you want to print and
whether to include booking notes.
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Use MS Word® with ResSched
If your organization has licensed the Corporate Edition of ResSched you may use Microsoft
Word® to generate many of the ResSched reports, but this can be done only if Microsoft
Word® is already installed on the same workstation.
Before using Word® to generate ResSched reports, the following files must be installed in the
system folder (C:Windows\System32) of the work station:
ArcoIntf.Ocx (VB Ocx)
Msvbvm50.dll (VB Runtime DLL)
If ResSched was installed using its own installation program, these files were copied to the
system folder if they were not already present.

Overview
The Word® feature works by calling a Word template and then substituting the relevant
words, values and tables at predefined locations. Each report or schedule has its own template
with the standard .dot extension. Each location to be replaced by a word, value or table is
marked by a word token preceded and followed by the @ symbol. Users can edit the layout of
the schedule as they would any other template. Except for tables, changes to the font or
format of the word tokens will be reflected in the words or values they represent.
The actual data for the schedules and reports is displayed using Word® tables. The layout and
format of the tables is controlled by style sheets, which can be edited by the user. The style
sheets are originally in the file ResSchedStyle.rtf. Each style sheet consists of one-row tables
preceded by @STILx (x is a number). Each major section of a table (e.g., table header, body)
has its own style sheet. Unlike the templates, all the style sheets can be kept - and are kept
by default - in one file. The style sheets also use word tokens, which are replaced by words or
values. In this case, the @ symbol only precedes the word. Style sheets are kept in Rich Text
Format files.

The Advantages of Using MS Word® to Print ResSched Reports
1. Users can edit the layout and format of their reports. This includes eliminating
unwanted data elements. They can edit the template itself to obtain the same changes
all the time, or by editing a single document.

The Disadvantages of Using MS Word® to Print ResSched Reports
1. Requires additional time to set up on each workstation.
2. Takes longer to print a report than using the default ResSched printing process.
3. Cannot print graphic output such as graphic schedules calendars.

Choosing Settings for Using MS Word®
Users must set some general conditions for the way Word works with ResSched. These
settings are established under File>>Word Setup.

Global Settings
1. Users must select whether or not to use MS Word® to generate text-based schedules
and reports. When a user choose MS Word® to print documents, it will be called
whenever the user is printing a text-based document from ResSched.
2. The ResSched setup program will attempt to register the ResSched/Word ocx file when
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you install ResSched. However, if that attempt failes you may need to register the ocx
manually. Simply click the Register OCX button. If the ArcoIntf.ocx file is not already in
the system folder, users will be asked to locate and select it. Users will be notified if the
registration is successful. This process has to be done only once for each workstation.
VISTA\Windows 7 users must turn User Access Controls off to register the ocx
manually.
3. Users must specify which language the wish to use, what the file format they wish to
store the finished documents in, and how Word is to open when work is being done on
reports.
4. Other questions to be answered include: Should table grid lines be displayed when the
document is displayed in Word®? Should the document be shown at all? Should the
document be printed automatically (that is, printed without being shown)? Should
documents be deleted automatically?
5. Users must specify where the document files should be held. This is especially
important if a user has chosen to not delete the documents after printing.

Document Template Tab
For each text-based schedule or report, a user must specify a ResSched WORD template file
and a style sheet file. These templates and stylesheet files should be stored in the singe
folder shown at the top. A look-up button beside each entry can be used to select the
appropriate file if you want make changes.
While there are only 11 basic schedules and reports, most may cover more than one type of
entity or period. Before Word® is called to generate the schedule or report, a user will have
already used the relevant window to specify the entity and period to be covered.

Booking

Detailed information on one booking.

Browse bookings

The equivalent to the main table displayed in the Browse Bookings 79
window. Actual coverage and period are determined by the user's prior
selections in the Browse Bookings window.

Day schedule

Detailed bookings for one day in chronological order. Actual coverage
and day are determined by the user's prior selections in the Print Text
Calendars 156 window.

Week schedule

Same as Day Schedule, but covering the period of one week.

Flexible period

Summary booking information for a period determined by user.
Coverage and period are determined in the Print Text Calendars
window.

Day by resource

Detailed bookings for one day grouped by resource. Covers either all
resources or those of a group. Coverage and day are determined by
the user's prior selections in the Print Text Calendars window.

Resource list

A detailed list of all resources or only those in a resource group.
Coverage is determined by the user's selection in the Browse
Resources 90 window.

Client list

A detailed list of clients. Called from the Browse Clients 105 window.

Resource utilization

Resource use for a period and a resource specified in the Resource
Utilization 94 window.
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Group utilization

Resource group use for a period and a resource group specified in the
Resource Group Utilization 102 window.

Client Invoice

Invoice for a client

After settings are entered, ResSched will call Word® whenever a user selects a text-based
report or schedule to be printed.

Editing Templates and Style Sheets
On installation on a workstation, ResSched installs an original set of templates in a sub
folder of the program files folder selected by the user. The default program files folder
cannot be written to by programs, so a second set are copied to a user specified folder.
It is this second set that can be modified by the user. When upgrading ResSched,
existing templates and stylesheet files in this second folder are not replaced with new
original ResSched files.
Users are very strongly advised to make a backup copy of the complete set of templates and
ResSchedStyle.rtf before editing or replacing them. The word tokens in both the templates and
style sheets must have exactly the same characters for the replacement template or style
sheet to work.
The best way to determine what a word token represents in a template is to generate the
schedule or report and then compare it against the template and the style sheet.
With style sheets, each section of the table has its own style and is referenced by a number.
The number is converted into a token by adding @STIL before the number. The style number
token must be at the beginning of the line immediately above the one-row table that contains
the layout, format and word tokens that comprise the style sheet for that section of the table.
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Working with Bookings

3.11.1 Booking, Add/Update
1.

Select Booking>Add Booking from the main menu, or from the toolbar. The Add/Update
Booking 76 window will appear.

2.

Enter up to 50 characters in the Booking field or select a routine booking
drop-down list.

3.

Select Start Time. Enter the desired start time for the booking or select from the dropdown list of likely times. The list of likely times is created from the Schedule settings
information entered in User Preferences 147 .

161

from the

The Default Duration time set in User Preferences will be automatically added to the
Start Time to give you an End Time. If the End Time is not correct, select a new End
Time from the drop-down list. You can change the Default Duration in User Preferences
147 . The Duration is not visible if 'Bookings can cross midnight' has been selected in
System Settings 141
4.

Select Start Date. Enter the date of the booking or use the look-up calendar by clicking
the Calendar button.

5.

If System Settings 141 have been set to permit bookings to cross midnight, enter an End
Date.

6.

If this booking is repeated, click the Repeat tab. See: Booking, Add Repeat
select your repeat pattern or dates.

7.

Click the Add button from the Resources list box. Select the resource(s) 161 you want
from the Browse Resources - Multiple Select 92 window that appears. If you have
already entered the dates and times for the booking, you will have the option of
choosing from just those resources available at those times. You can choose to select
available resources from all the resources in ResSched you are authorized to book or
just those of a specific resource group. Please note: using the available resource options
when you have many occurrences and many resources to examine can take a long time
and consume considerable network resources.
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and

If you select a pooled resource 161 , ResSched will ask you how many units you wish to
book.
OR
Click the Add Group button. Select a resource group 161 from the Browse Resource
Groups 99 window that appears. All the resources in the resource group will be
included for the booking.
8.

Select the Client field. Enter the name of a client 159 or click the Down Arrow button to
select an existing client from the Browse Clients 105 window that appears.

9.

Select the status of the booking.

10.

If this booking is part of an existing category 159 , select the category name.

11.

The Lock 160 check box prevents other general users from changing this booking.
System Administrators and Resource Administrators can be override a booking lock.

12.

The Private 161 check box stops other users else from seeing the contents of the
booking. Private bookings are automatically locked. System and Resource

50

ResSched 9.9
administrators can override a locked, private booking. The Private check box is only
available if a System Administrator has enabled private bookings in System Settings.

13.

The Inactive 160 check box prevents the booking from showing in browses, printed
reports or any of the utilization or invoicing functions. Inactive marks a resource as
unavailable for a specified period.

14.

If you want to add notes for the booking, click the Notes tab.

15.

You can e-mail the booking information to the client by clicking the E-mail button. Your
e-mail program will be called, and the client's e-mail address along with the booking
information will be automatically added to the message.

16.

Click the OK button.

If any occurrences of the new booking fall on a Special Day 162 or conflict with another booking,
a conflict window will appear. See: Conflicts, Deal With 54 for options on conflicts. A conflict
window will also appear if you try to schedule a booking for a weekend and you have selected
weekends under 'Notify me when booking....' in User Preferences 147 .

3.11.2 Booking, Send by E-mail
To send booking information to a client:

1.

Open or create a new booking with the Add/Update Booking

2.

Click the E-mail button.

76

window.

ResSched calls e-mail program with the booking information in the message body. By default,
the client's 159 e-mail address is the default recipient.

3.11.3 Bookings, Change
1.

Select the booking you want from the Browse Bookings
graphical schedules.

2.

Change the booking information.

3.

Click the OK button.

79

window or one of the

If the changes result in conflicts with other bookings or special days, the Booking Conflicts
window will appear to let you deal with the conflicts.
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If you are changing a repeated 161 booking, the Change Repeated Booking window will appear
for you to select how broadly to apply these changes. You must choose whether the changes
apply to just the occurrence you originally selected, all occurrences of the booking, or the
occurrence you selected and all those that come after it.

3.11.4 Booking, Add or Change Repeats
To specify how often a booking is to be repeated:
1.

While in the Add/Update Booking
Repeating tab.

2.

Select the desired Repeat option.

76

window, to add or change a booking, select the
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Fill in the dates, times, weekday, frequency, or end date required by your option.

4.

Click OK.
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If you are changing the repeats 161 of an existing booking, all the occurrences of the booking
scheduled after the occurrence you originally selected will also be changed. ResSched will
prompt you to confirm that you wish to go ahead with these changes. If you are scheduling a
large number of repeats, it may take several seconds to store all the information.

3.11.5 Booking, Change Repeated
When you make changes to a repeat 161 booking, you must specify how the changes apply to
the other occurrences of the booking. The Change Repeated Booking 51 window will appear
offering three options for applying the changes to the booking occurrences:
Just This

The changes apply only to booking occurrence you originally selected. When
Oyou select this option, ResSched will treat this occurrence as a separate
n booking from now on. To reduce confusion, ResSched puts an '*' at the end
e of the name of the new booking to distinguish it from the others.

All

The changes apply to all occurrences of this booking.

This One and
Future

The changes apply to this occurrence of the booking and all occurrences that
come after it. When you select this option, ResSched will treat this occurrence
and future occurrences as a separate booking from now on. To reduce
confusion, ResSched puts an '*' at the end of the name of the new booking
to distinguish it from the others.

3.11.6 Booking, Delete
To delete a single booking:
1.

Select Booking>Browse Bookings from the main menu to call the Browse Bookings
window.

2.

Highlight the booking you want to delete and click the Delete button.

3.

When asked, confirm the deletion by clicking Yes.

4.

If this is a repeated booking, ResSched will be ask if you wish to delete all occurrences
of the booking, just the occurrence you originally highlighted, or the originally
highlighted occurrence and all that occurrences of the booking that come after it.
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You can delete a booking from a Schedule window by double clicking on the booking to call the
Add/Update Booking 76 window and then clicking the Delete button.
System Administrators can delete all bookings before a specified date in the past.
1.

Select Booking>Purge Old Bookings from the main menu to call the Purge Old
Bookings 83 window.

2.

Enter the last date of the bookings to be deleted. This date must be before the current
date.

3.

Click the OK button.
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4.

Confirm the deletion when prompted.

If a booking is 'locked 160 ', only System 162 and Resource administrators
created the booking can delete it.

161

or the user who

3.11.7 Booking, Print Single
To print the information for a single booking:
1.

Select the booking you want from the Browse Bookings
on a booking in one of the schedules.

2.

Click the booking you want to call the Add/Update Booking

3.

Click the Print button.

79

window or by double clicking

window.

76

3.11.8 Files or URLs, Add to Booking
You can add document files or URL's a booking. In the case of files, access to these files
is controlled by Windows or the application that created them, not by ResSched.
However, only those users with the rights to change the booking can add or remove files/
URL's to the booking.
To add a file to a booking:
1.

Open or create a booking

2.

Click the Add button to call the Add Document window

3.

Enter the URL or use the Browse button to select the file you want to associate
with the booking. The description is optional.

4.

Click OK to associate the file/URL with the booking.
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as you would normally, and click the Documents tab.
84

.

3.11.9 Bookings, Browse
Browse bookings

159

(view text schedules) by selecting Booking>Browse Bookings from the

main menu or clicking
to call the Browse Bookings 79 window. Enter the period you
want to cover. The tabs let you furhter limit the bookings shown to specific resources 161 ,
clients 159 , resource group 161 , or category 159 . The bookings are always listed in date/time
order. Click the Display button to generate the display.
By Date

All bookings the user is entitled to view

By Resource

All bookings for a selected resource

By Client

All bookings of selected client

By Resource Group

All bookings of each resource in a selected resource group.

By Category

All bookings of a selected category

If you wish to browse bookings by the name of the booking, use the Browse Bookings
Alphabetically window 81 . Remember that the booking name is not a unique entry, so you may
have several completely different bookings with the same name (e.g., 'Staff meeting')
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The large list box displays the booking name, client, date and times and the primary resource
161 of each booking. If the Show Other Resources check box is checked, the list box below it
displays all resources associated with the selected booking except the primary resource.
You can include inactive bookings 160 by checking the Include Inactive check box.
Turning on the Use Colors check box will display any colors associated with the different parts
of the booking. If Use Color Blocks is also turned on, the background and font are exactly the
same as the colors in graphic schedules. Turned off, the schedule background color is used as
the font color. The colors for the booking status will be used for the date and times of the
booking. If the booking name was created using a system wide routine booking 161 with
associated colors, the booking name is shown with those colors. If colors have been
associated with clients or resources, these colors will be used for the client and primary
resource entries

Clicking

will print all the bookings shown. You must specify an end date for the report to

avoid unintended long print jobs. Use

to print just a single selected booking.

Also, you may e-mail the booking information by clicking
. It will call your e-mail
program with the booking information in the message and the client's e-address as the default
recipient.

3.11.10 Bookings, View Graphical Schedules
The Schedule 162 functions display bookings graphically using position, size, color and text to
convey information about the date, time, and other aspects of the booking
Bookings are shown as boxes with user selected text and colors. Except for the monthly
calendar format, the location and size of the box represents the booking start time and length.
The vertical format schedules have resources running across the top of the display with date/
time running down the display. Timeline displays have the date/time running across the top
with the resources running down the left side of the display
For the monthly calendar format, all bookings are listed in time order for each day of the
calendar with the start time shown in the text. If the number of bookings exceed the number
of time slots the user has specified for a day, the last time slot simply says 'MORE'.
After selecting the general type of schedule you want from the menu or toolbar buttons, you
must enter a few criteria to define the schedule. The Help topic for each window details the
criteria. Many schedules take initial values from User Preferences 147 , but any changes you
make will be saved for the next time you use this schedule. Once you have made entered your
selections, you must click they Display button to generate the display
You can use drag and drop to move bookings around in many schedule windows. You can also
add a new booking by double clicking on an empty time slot. To make this feature more
accurate, ResSched displays the exact time the cursor represents below the cursor as it moves
Single Resource (Week) Display all bookings for one resource for a week with the days
running across the top and the time running down the window. Resource Week Schedule
window 122 .
Single Resource (Month) Display bookings of one resource for a month in monthly calendar
format. Resource Month Schedule window 124 .
Pooled Resource Availability

Displays the usage level of a pooled resource for a week. The
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percentage of the pooled resource's units that are already booked is displayed. When 1 to 50
% of the units are booked, the time block is shown in blue. Yellow is used when 50-99% of the
units are booked. If all the units are booked or over booked, the time block is shown in red.
Availability of Pooled Resource window 126
Resource Group (Day, Week, Month - Timeline Format) Display all bookings for all the
resources in a resource group for a day, week, month in the horizontal format. If 'Bookings
can cross midnight' has been turned on in System Settings 141 , quarter or year views are also
available. Resource Group Timeline Schedule window 113
Resource Group (Day, Week - Vertical Format) Display all the bookings of a resource group
in the vertical format. Resource Group Day Schedulel window 114 and Resource Group Week
Schedule window 117
Resource Group (Month Calendar Format) Display bookings of a resource group for a month
in standard calendar layout. The Resource Group Month Schedule window 119 is only suitable
for small groups that have resources with only a few bookings per day
Client (Day Week, Month Timeline Format) Display all bookings for all the resources used by
a client for a day, week, month in horizontal format. If System Settings have been set for '
Bookings to cross midnight', you can also display a quarter or year. Client Timeline window
131

Client (Week Vertical Format) Display all bookings for one client for a week in the vertical
format. Client Week Schedule window 127 .
Client (Month Calendar Format) Display bookings of one client for a month in the monthly
calendar format. Client Month Schedule window 129
Category (Day, Week Month Horizontal) Display all bookings for one category for a specified
period in the horizontal format. Category Timeline Schedule window 133

WARNING: Please be aware of the following limitations when using Schedules that use the
Vertical format:
1.

If bookings 159 overlap, the text in the boxes may be jumbled. When you click the
overlapped area, only the booking details of the earliest booking for that area will be
available.

2.

When two overlapping bookings both end or begin at the same time slot, they appear
to be two non-overlapping bookings. Overlapping occurs when bookings conflict or
when a booking ends and another starts within the same time slot, but do not actually
conflict (e.g., one ends at 10:05 and another starts at 10:10 within a 10:00 to 10:15
time slot).

When you need precise information on bookings, use the Browse Bookings
timeline format.

79

window or the

3.11.11 Bookings, Stop Other Users from Changing
When users make a booking, they can lock the booking so other general users cannot change
or delete it. Both Resource 161 and System administrators 162 can override a booking lock.
System administrators can set ResSched to lock bookings automatically, by turning on 'Lock
bookings' in System Settings 141 .

3.11.12 Scheduling Conflicts, Deal With
As you schedule bookings 159 , you will often encounter scheduling conflicts. There are several
types of potential conflicts:
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1.

overbooking a resource;

2.

booking on special days 162 ;

3.

overbooking a client (if turned on in System Settings) 141 ;

4.

booking on a weekend or outside normal work hours, if turned on in User Preferences
147 .

ResSched alerts you to these conflicts by displaying the Booking Conflicts 86 window. You can
accept any of the conflicts by selecting them and then clicking OK. Unselected conflicts will not
be scheduled.
If System Settings have been set to disallow conflicts, general 160 and reserve 161 users will not
be able to accept any conflicts involving resources 161 . System 162 and Resource administrators
161 can still book conflicts but they must confirm their decision to over ride the System Settings.

3.11.13 Downtime, Schedule
To schedule downtime such as for maintenance or vacation, use the Inactive check box on the
Add/Update Booking window:
1.

Select Booking>Add Booking. The Add/Update Booking

2.

Fill in the information in the normal manner.

3.

Click the Inactive check box.

4.

You may also create and use a status
scheduled.

5.

Click the OK button.

162

76

window appears.

with an associated color for any downtime

The booking will appear in Schedule windows and schedules. It will only appear in the Browse
Bookings 79 window if you select Include Inactive. ResSched does not count Inactive
bookings any utilization views or reports.

3.11.14 Private Bookings, Make
If System Settings 141 allow private bookings
booking that other users cannot see.
1.

161 ,

any general or reserve user can make a

Follow the same procedure as in making a normal booking
check box to make a private booking.

49

, except check the Private

Note: System and Resource administrators can override a locked, private booking.

3.11.15 Routine Bookings, Add
Only System Administrators 162 can create routine bookings 161 that are system wide. However,
all users except view only users can add their own personal routine bookings to the list for
their use (see information at bottom of this topic).
For system wide routine bookings:
1.

Select File>System Settings>User Settings tab.

2.

Click the Routine Bookings button to call the Browse Routine Bookings

83

window.
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4.

Click the Add button to call the Add/Update Routine Bookings

5.

Enter the name of the new routine booking.

6.

If desired, use the
booking.

7.

Click the OK button on the Add/Update Routine Bookings window.

8.

Click the Close button on the Browse Routine Bookings window.

9.

Click the OK button on the Update System Settings

83

window.

button to assign color for bookings made with the routine

141

window.

Individual users (except view only users) can add their own routine bookings to the list for
their own use:
1.

Select File>User Preferences >Update User Preferences 147 .

2.

Click the Routine Bookings button to call the Browse Routine Bookings

3.

Click the Add button to call the Add/Update Routine Bookings

4.

Enter the name of the new routine booking.

5.

Click the OK button on the Add/Update Routine Bookings window.

6.

Click the Close button on the Browse Routine Bookings window.

7.

Click the OK button on the Update User Preferences window.

83

83

window.

window.
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Working with Categories

3.12.1 Category, Add
1.

Select Categories>Add Category from the main menu to call the Add/Update Category
111 window.

2.

Type the name of a new category 159 .

3.

Click the OK button.

3.12.2 Categories, Browse
1.

Select Categories>Browse Categories from the main menu to call the Browse
Categories 111 window.

2.

Click the name of the category in the list box or use the Locator to find a category from
among a list of many.

3.

You can then delete a category, or open the Add/Update Category 111 window to
change the name of a category.

3.12.3 Categories, Delete
To delete a single client, several clients, or all clients:
1.

Choose Category>Browse Categores from the main menu to call the Browse
Categories 111 window.

2.

Select the category want to delete and click the Delete button.

3.

You must confirm the deletion and choose what you want to do with the bookings for
the deleted category. You can keep the bookings, delete them all or delete just those
that will occur in the future.

Please note: If you delete a category, you will not be able to obtain any views or reports for
that category. If you might want to view or print the bookings for the category in the future,
consider making the category inactive 59 instead of deleting it.
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Working with Clients

3.13.1 Client, Add
1.

Select Client>Add Client from the main menu to call the Add/Update Client 104 window.

2.

The only required information is a unique name for the client, but you may prefer to fill
in the other data fields for on line reference and reports.

3.

Click the Notes tab to add any text information.

4.

You can associate color with the client by clicking the

5.

Click the OK button to save.

button.

3.13.2 Client, Change
1.

Select Client>Browse Client from the main menu to call the Browse Clients
window.

2.

Click the name of a client in the list box and then click the Open button to call the Add/
Update Client 104 window.

3.

The only required information is a name for the client, but you may prefer to fill in the
other data fields.

4.

Click the Notes tab to add any text information.

5.

You can associate color with the client by clicking the

6.

Click the OK button to save.

105

button.

3.13.3 Client, Check for Conflicts
By default 160 , ResSched does not check bookings for client conflicts. System
Administrators can turn on client conflict checking in System Settings 141 . Client conflict
checking is a great feature when your clients are individuals but additional conflict
checking slows down how fast bookings are saved, particularly if there are many
occurrences of the bookings. Leave client conflict checking turned off if you don't need
it.

3.13.4 Client, Create Invoice
To create invoices to be sent to clients, click Client>Invoice Clients to call the Invoice Clients
107 window.
1.

Click the Calendar button beside the From data field to open the Calendar window and
then select a date. Repeat for the To data field.

2.

Type in the Name and Address of the payee, as well as the Starting Invoice#, Tax Rate
and Currency.

3.

Click the Include Detail check box if you want the bill to include the details about booked
resources.

4.

Click the Print Preview check box if you want to preview the bill before it is printed.

5.

Select one or more Clients. Use the Tag All button if all clients are to pay the same payee.
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(Use the Clear All button if previously tagged clients are to be untagged.)
6.

Click the Print button.

Note: Many organizations have unique or complicated invoicing requirements. If your
organization does, you may wish to use the ODBC driver 9 that is issued with the ResSched
Corporate license to generate invoices using ResSched data in other applications.

3.13.5 Client, Delete
To delete a single client, several clients, or all clients:
1.

Choose Client>Delete Multiple Clients from the main menu to call the Delete Multiple
Clients 109 window.

2.

Select the clients you want to delete and then click the Delete button.

3.

You must confirm the deletion and choose what you want to do with the bookings for
the deleted clients. You can keep the bookings, delete them all or delete just those that
will occur in the future.

Please note: If you delete a client, you will not be able to obtain any views or reports for this
client. If you might want to view or print the bookings for this client in the future, consider
making the client inactive 59 instead of deleting it.

3.13.6 Client, Make Inactive
To make a client temporarily unavailable:
1.

Select the client using the Browse Clients
window.

2.

Turn on the Inactive check box.

3.

Click OK.

105

window to call the Add/Update Client 104

3.13.7 Client, View Utilization
For Resource 161 and System administrators 162 of Corporate Edition licensees only.
To view the usage of resources by a particular client:
1.

Click Client>Utilization by Client to call the Utilization by Client 106 window.

2.

On the Summary Tab, click the

3.

Click the
To field.

4.

Click the
Calculate button. ResSched will display the booked resources for
the selected client and period in summary form on the Summary Tab, and in more
detail on the Detail tab.

button of the Client field to select a client

button beside the From field to select the start date. Repeat for the
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Working with Resources

3.14.1 Resource, Add
Only Resource Administrators

161

and System Administrators 162 can use this function.

1.

Select Resource>Add Resource from the main menu to call the Add/Update Resource
88 window.

2.

Enter a unique name for the resource you want to add.

3.

If this is a pooled resource 161 , check the Pooled box and enter the number of units of
the resource available for booking.

4.

If you charge for the use of the resource, choose a rate and a usage period.

5.

Specify who can book and who can view bookings for the resource. All resource and
system administrator are automatically authorized to book the resource. Also, some
general 160 , reserve 161 , and view only 163 users may have been given the right to book
or view all resources with their user ID.
If you wish to let general or reserve users book this resource, click the Who Can Book
tab. Click the 'All general users can book' check box if this is applicable, click the Add
User button to call Browse Users - Multiple Select 138 window to select the desired
general users.
To give view only users, general and reserve users the right view the booking of the
resource, click the Who Can View tab and do the same. All general users who have
the right to book a resource also have the right to view its bookings
You can authorize all the general, reserve or view only users in a user group 163 to book
or view a resource by clicking the Add Group button and selecting the user group from
the Browse User Groups 140 window that appears.

6.

You can associate colors with the resource by clicking the

button.

7.

To add this resource to existing resource groups 161 , Select the Resource Groups tab.
The Add button calls the Browse Groups - Multiple Select 100 window to select the
groups you want the resource to be part of.

8.

Click the OK button to save the resource information.

3.14.2 Resource, Add to a Resource Group
System 162 and Resource administrators 161 can make a resource part of a resource group when
they create or change the resource or when they create or change a resource group.
To add a resource to a resource group when creating/editing the resource entry:
1.

Select Resource>Add Resource from the main menu bar to call the Add/Update
Resource 88 window.

2.

On the General Tab, enter the name of the new resource and any other appropriate
information (if this is a new resource).

3.

Click the Resource Groups tab.

4.

Click the Add button and select any of the existing resource groups to which the
resource is to be added.
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Click the OK button to save the resource record.

To add a resource to group when editing the resource group record, see Resource Group, Add
a Resource 64

3.14.3 Resources, Browse
Select Resource>Browse Resources from the main menu. The Browse Resources
will appear with all the resources listed.

90

window

3.14.4 Resource, Change
Only System 162 or Resource Administrators

161

can use this function.

1.

Select Resource>Browse Resources from the main menu. The Browse Resources
window will appear.

2.

Highlight the resource entry you want to change and click the Open button (or double
click the entry). The Add/Update Resource 88 window will appear.

3.

Change the name, units of the resource, the rate and the rate period.

4.

To give or remove the rights to book or view the resource to general 160 , reserve 161
and view only 163 users, click the Who Can Book and Who Can View tabs. Use the Add
User button to add new users to the lists of authorized users, or highlight existing
users and click Delete User to remove their authorization. Be aware that general,
reserve, and view only users may have the right to book or view all resources
associated with their user ID.

5.

You can associate color with the resource by clicking the

6.

Click the OK button to save.

90

button.

3.14.5 Resource, Delete
Only System 162 or Resource Administrators

161

can use this function.

1.

Select Resource>Browse Resources from the main menu. The Browse Resources
window will appear.

2.

Highlight the resource you want to delete and click the Delete button.

3.

Confirm the deletion when prompted.

90

3.14.6 Resources, Filter by Criteria
To view schedules or reports of resources that meet specified criteria, you use resource
groups 161 and combination groups 160 . You create a resource group 64 for each criteria
and when you need to filter by multiple criteria you create a combination group 66 that
selects just the resources that fit the criteria you have selected.

3.14.7 Resource, Make Unavailable Temporarily
To make a resource temporarily unavailable:
1.

Select Resource>Browse Resources and then select the resource. The Add/Update
Resource 88 window appears.

2.

On the General tab, click the Inactive check box.
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3.

Click OK.

3.14.8 Resource, Restrict Who Can Book or View
You can limit which general 160 and reserve 161 users can book a resource, and which general,
reserve, and view only 163 users can view the bookings of the resource two ways. These two
methods are mirrors: if you change resource/user rights using one method, the results will be
reflected in the other method.
1.

When creating or changing the user's ID, you can specify which resources the user can
permitted to book or view. See Add/Update User window 134

3.

When you are creating or changing the resource information, you can add or delete
users that can book or view the resource. See Add/Update Resource window 88

Note: General, reserve, and view only users who have been authorized to book or view all
resources in the Add/Update Users window have the right to book the resource regardless of
whether or not they are on the list for the resource, as do System 162 and Resource
administrators 161 ,

3.14.9 Resource, Set a charge rate
If you charge for the use of resources, you can set a default rental, usage, or other
charge out rate for a resource:
1.

Select Resource>Browse Resources and then select the resource. The Add/Update
Resource 88 window appears.

2.

On the General tab, enter the rate you wish to charge and the period the rate covers.

3.

Click OK.

To change the charge rate used for a specific booking:
1.

Open the booking or create a new one using Add/Update Booking window

2.

Select the resource with the rate that needs changing and click the Change rate
button. Repeat as required for any other resources.

3.

Click OK to save the booking.

General users
Settings 141 .

160

76

can only change the rate actually used for a booking if allowed in System

3.14.10 Resources, Display several at time
To display the schedules of several resources at a time, you must either use a resource
group 161 that has been created by a resource 161 or system administrator 162 , or create a
combination group 100 made up of the resources you select.

3.14.11 Pooled Resources, Create
If a resource is inventoried and more than one unit of the resource can be booked at the same
time, you should make it a pooled resource 161 . A pooled resource will only give you a conflict
warning if you try to book more than the total number of units available at any time.
1.

Open an existing resource record, or add a new one using the Add/Update Resource
window.

88
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2.

Click the Pooled check box and then select how many units of the resource are
available for booking.

3.

Click OK.

Only system 162 and resource administrators 161 can add or change a resource record.
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Working with Resource Groups

3.15.1 Resource Group, Add
Only Resource Administrators

161

and System Administrators 162 can use this function.

1.

Select Resource>Resource Groups from the main menu. The Browse Resource Groups
99 window will appear.

2.

Click the Add button. The Add/Update Resource Group

3.

Enter a name for the new resource group (up to 30 characters) in the Resource Group
Name field.

4.

Click the Add button to call the Browse Resources - Multiple Select

5.

Select the resources you want for the resource group. If you are adding a pooled
resource, you will have to specify how many units of the resource you want to include in
the group

6.

Click the OK Button.

97

window will appear.

92

window.

3.15.2 Resource Group, Add Resource to a Group
System 162 and Resource administrators 161 can make a resource 161 part of a resource group
161 when they create or change the resource or when they create or change a resource group.
To add a resource when creating/changing a resource group:
1.

Click Add or Open in Browse Resource Groups
or change an existing one.

2.

Click the Add button in the Add/Update Resource Group 97 window to call the Browse
Resources - Multiple Select 92 window to select resources.

3.

After selecting the resources, click OK to save the resource group record.

99

window to create a new resource group

To add a resource to group when editing a resource record, see Resource, Add to a Resource
Group

3.15.3 Resource Group, Analyze Utilization
Only Resource Administrators 161 and System Administrators 162 can use this function. Resource
utilization is only available with the Corporate Edition
1.

Select Resource>Utilization>Resource Group from the main menu to call the Resource
Group Utilization 102 window.

2.

If Actual Times 159 has been enabled in System Settings 141 , select whether to use
actual or scheduled times.

3.

Select the resource group you wish to analyze.

4.

Select whether bookings on weekends or special days 162 should be included in the
analysis.

5.

Enter the start and end dates of the period you want to analyze.

6.

Click the Calculate button to display the results.
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To view summary usage statistics for each resource in the resource group, click the
Detail tab.

3.15.4 Resource Group, Change
Only Resource Administrators

161

and System Administrators 162 can use this function.

1.

Select Resource>Resource Groups from the menu in the main window to call the
Browse Resource Groups 99 window.

2.

Double click the resource group you want to change, or highlight the resource group
and click the Open button. The Add/Update Resource Group 97 window will appear.

3.

Change the name (if desired) in the Resource Group Name field.

4.

To add new resources to the list, click the Add button. The Browse Resources - Multiple
Select 92 window will appear. Select the new resources you want by using the
standard Windows procedure for selecting multiple items.

5.

To delete a resource from the resource group, highlight the resource in the list box and
click the Delete button.

6.

Turn on 'Allow all users to use this resource group' if desired. Otherwise, click the
Users tab to select which users will be allowed to use this group. Click the Add button
to call the Browse Users - Multiple Select 138 window to select the users. Note: Giving
users the right to use a resource group does not affect their rights to book or view the
resources in that group.

7.

Click OK

3.15.5 Resource Group, Delete
Only Resource Administrators

161

and System Administrators 162 can use this function.

1.

Select Resource>Resource Groups from the main menu to call the Browse Resource
Groups 99 window.

2.

Highlight the resource group you want to delete and click the Delete button.

3.

Confirm the deletion when prompted.

3.15.6 Resource Group, Limit to Specific Users
You can specify which General 160 , Reserve 161 , or View only 163 users can use a resource group
161 . Giving users the right to use a resource group does not affect their rights to book or view
the resources in the group. So, if a user displays a schedule for a resource group they will only
see the bookings of those resources they are authorized to view.
All resource groups are initially set to allow all users to use them, so you must first turn off
Allow all users to use this resource group in the Add/Update Resource Group window 97 .
After you have done that, you can add existing users to the list of authorized users on the
Users tab. You can also authorize a user to use the group by adding the resource group to
the list of groups found on the Resource Groups tab of the Add/Update User window 134
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3.15.7 Resource Group, Use Combination Groups
Wherever you see the
button, you can use a combination group 160 to view
schedules or reports of resources that are filtered using different resource groups 161 as
criteria, include all the resources of different groups, or selected individually to be shown
as a temporary group.
1.

Click the combo button to call the Create Combination Group 100 window.

2.

Enter a name for the combination group.

3.

To create a combination group composed of resources from other resource groups,
choose the Groups Tab. There two lists of resource groups: for resources that
must be in ALL the resource groups listed; and for resources that must be in at
least ONE of the resource groups listed.

4.

Click Add button to call the Browse Resource Groups Multiple Select
select the resource groups that will be added to each list.

5.

To create a combination group out of individually selected resources, choose the
Resources Tab.

6.

Click the Add button to select the resources using the Browse Resources Multiple
Select 92

7.

Click OK.

100

window

Combination groups are temporary. They only last long enough to produce the desired
schedule or report. If users are continually creating the same combination group, consider
creating a normal resource group with the combination group's resources.
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Working with Reports and Schedules

3.16.1 Schedules and Reports, Generate using Word®
To use Microsoft Word® to generate ResSched reports and schedules, select File>Word Setup
to call the Setup for Using MS Word 153 window.
1.

Click the Use Microsoft Word for documents check box.

2.

The Click the Register OCX button. You only need to do This process has to be done
only once for each workstation.

3.

Click the User Global Settings tab.

4.

Choose all the appropriate options on this tab.

5.

Click the Document Templates tab.

6.

Choose all the appropriate options on this tab.

7.

Click the OK button.

Only Corporate license 6 holders can use the Word interface. See: Using MS Word with
ResSched 46 for more information.

3.16.2 Schedules and Reports, Save as pdf
You can convert any printed report or schedule into a pdf document.
Select File>Save as pdf from the Report Preview 158 window (or the Save as pdf button on the
toolbar). Enter a filename for the pdf when prompted.

3.16.3 Schedules and Reports, E-mail
You can e-mail any printed schedule or report as a pdf document.
From any Report Preview 158 window, select File>E-mail pdf (or the E-mail button) and enter a
name for the pdf file.
ResSched uses your system's default e-mail program. You can attach the pdf to any message. (
Note: To ensure compatibility with the widest number of potential e-mail programs, the pdf
document is not automatically attached to your message.)

3.16.4 Schedules and Reports, Post on Web
ResSched lets you save schedules and reports as pdf's (see: Schedules and Reports, Save as
pdf 67 ) which you can upload to your Web site.
The Corporate Edition 6 allows system administrators 162 to automatically generate pdf
schedules for specified resources, clients, resource groups, and categories and post them to
your web server. To use the Automated PDF Schedule Generator (APSG):
1.

Use File>Auto PDF Generator from the main menu to call the Automated PDF
Generator 151 window.

2.

Enter the folder on your web server where the PDF schedules will be located.

3.

Enter how frequently the schedules should be refreshed.

4.

Click the Add button to call the PDF Schedule Specification
you want generated.

152

window to set a schedule
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5.

Click OK to begin generating the schedules.

6.

Minimize the APSG program, but do not close it.
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Working with Settings and Preferences

3.17.1 Password, Change
View only users can change their password only if System administrators have allowed it
through a feature on the Update System Settings 141 window.
1.

Select File>Change Password

2.

Enter the new password twice in the Change User Password window.

3.

Click the OK button.

3.17.2 System Settings, Set
To change System Settings, you must have System Administrator 162 access.
1.

Select File>System Setting from the main menu to call the Update System Settings
window.

2.

Make the desired changes.

3.

Click the OK button.

141

3.17.3 User Preferences, Change
1.

Select File>User Preferences from the main menu to call the Update User Preferences
147 window.

2.

Make the desired changes to the default entries or schedule settings, etc.

3.

Click the OK button.

3.17.4 Labels, Change
You can change labels for resources, bookings, clients, and categories to show your
organization's terms. ResSched will use these new terms in its menus, windows, and reports.
To do so, System Administrators 162 :
1.

Go to File>System Settings>Labels.

2.

Replace the standard ResSched terms with the terms you want to use. Click OK to save.

While your new terms will appear in the menus and windows, the standard ResSched terms
are still used in this Help file and in all other user documentation. You should use these
standard terms if you need to contact us for technical support. Users can always find the
corresponding terms by going to Help>ResSched terms.

3.17.5 Color, Print Schedules In
To use color when printing graphic schedules, turn on Print in Color in the Update User
Preferences 147 window.

3.17.6 Alerts, Set
ResSched can automatically alert users to upcoming bookings. To set alerts, a System
Administrator 162 would:
1.

Select File>System Settings from the main menu to call the Update System Settings 141
window.
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2.

Under the General tab, pick from the three choices of who should be alerted. By
selecting All from the radio buttons, all users will be alerted to any forthcoming
bookings. User Only will alert the user only if bookings he /she made are coming up.
Selecting None disables the alert function.

3.

If you selected All or User Only, enter the lead time between the alert and the booking
in minutes.

Alerts query the database on behalf of each user at intervals of one-sixth the lead time. For
example, if the lead time is set for 20 minutes, the database will be queried for upcoming
bookings by each logged-on user every 3.33 minutes. If any bookings are found during the
query, the Booking Alerts window appears, allowing the user to select and view the
forthcoming booking.

3.17.7 Entries, Set Default
System Administrators 162 can create system wide default 160 entries that users can use when
creating bookings. These entries include: start time, duration, client 159 , resource 161 , booking
159 name, and category 159 . Except for view only users, all users can create their own set of
default entries for their personal use.
For a System Administrator 162 to set system-wide default entries:
1.

Select File>System Settings to call the Update System Settings

2.

On the User Settings tab, enter any changes in the Default Entries section.

3.

141

window.

Click the Apply to Existing Users button to replace the default start times of all users
with this one.

Except for view only users, individual users may create their own personal default Start Time
for bookings as follows:
1.

Select File>User Preferences from the main menu to call the Update User Preferences
147 window.

2.

On the Default Entries tab, enter any changes.

3.

Click the OK button.

3.17.8 Routine Durations and Bookings, Create Lists of
If your organizations has many bookings with the same name (e.g. 'Meeting'), you can create
list of these routine bookings that users can pick from a drop list when they are making
bookings. ResSched generates an initial list of routine durations, but you can want modify
that list to meet your needs.
System Administrators 162 can create system wide lists of
routine bookings and durations, and users can add their own routine bookings and durations
to that list for their own use.
To create the system wide lists, the System Administrator uses the Update System Settings 141
window.
1.

Click the User Settings tab.

2.

Click the Routine Durations or Routine Bookings buttons to call their respective
Browse Routine window.

3.

Click the Add button to call the Add/Update Routine .... window.
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4.

Enter the new duration or booking name and click the OK button.

5.

Close the Browse Routine window.

6.

Click the Apply to existing users button to replace the routine durations of all users
with this set of durations..

Individual users may create their own personal list of routine durations and bookings:

1.

Select File>User Preferences from the main menu to call the Update User Preferences
147 window that appears

2.

On the Default and Routine Entries tab, click the Routine Durations or Routine
Bookings buttons to call their respective Browse Routine window.

3.

Click the Add button to call the Add/Update Routine .... window.

4.

Enter the new duration or booking name and click the OK button.

5.

Close the Browse Routine window.

6.

Click the OK button on the Update User Preferences window.

3.17.9 Work Day Times, Change
If you are a System Administrator 162 , you may change the start and end times for a normal
work day and apply those times to the entire system.
To change start and end times:
1.

Select File>System Settings from the main menu to call the Update System Settings
window.

2.

Click the User Settings tab.

3.

In the box, change the times under the Begin work day and End work day fields.

4.

Click the Apply to existing users button to replace those settings for all users.

Individual users may change their own start and end times for normal work days as follows:
1.

Select File>User Preferences from the main menu. The Update User Preferences
window appears.

2.

Click the Schedule Settings tab.

3.

Make the required changes to the Begin work day and End work day fields.

4.

Click the OK button.

147

141
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3.17.10 Special Days, Set
To add, change or delete special day periods 162 :
1.

Select File>System Settings from the main menu to call the Update System Settings
141 window. Click the Special Days tab

2.

To add a special days period, click the Add button to call the Add/Update Special Day
Period 149 window. Enter the description of the period, its start date and its end date,
and then click the OK button.

Use the Change button to modify the selected special day period and the Delete button to
delete the selected special day period.
Madrigal Soft Tools offers files five years of public holidays for some countries. To add these
holidays as special days, place the file in the same directory where you have your ResSched
data and click the Add File button. Review your new special days to ensure they include the
public holidays of your specific location and to remove any duplicates for special days you may
have entered previously.
You can obtain these files from our Web site at: http://www.madrigalsoft.com

3.17.11 Schedule Options, Set
The Schedule settings can be adjusted to meet the user's preferences for the displayed time
slots, the width of columns, the height of rows and the text in boxes that mark bookings.
ResSched also uses some of these settings to generate drop-down lists from which users may
make selections.
System Settings 141 contains a default schedule settings that are used for every new user
created.
When viewing an individual schedule for the first time, initial settings are taken from your User
Preferences 147 . You can change these settings in the Schedule window and these changes
will be saved between sessions.
1.

Select File>User Preferences from the main menu to call the Update User Preferences
147 window. Click the Schedule tab.

2.

Select and adjust the setting you wish to change.

Begin work day

Enter the normal start time of the work day. Bookings 159 made before
this time will all be in a time slot labeled 'Before' and this time.

End work Day

Enter the normal end time of the work day. Bookings made after this
time will all be in a time slot labeled 'After' and this time.

Interval

Enter how much time should be covered with each time slot of a
schedule.

Width

How wide the columns are for some of the Schedules. The wider the
column, the greater the amount of booking information that can be
included in the time slot box, but the fewer the resources that can be
viewed at the same time or printed on one page. Width is measured in
'Dialog units' that are roughly equal to 4 dialog units per character.

Height

Height is for the time slot rows shown in Schedules. The lower the
height, the more time slots that can be accommodated in a window, but
the harder it is to read them.
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Text is the text information that will be displayed in the time slot box of
a Schedule. Select between booking name, client, or mixing both (the
first six characters of the booking followed by the client), or no text at
all.
Click the OK button.

3.17.12 Timeline or Vertical Layout for Schedule Buttons, Change
The schedule buttons on the main tool bar 25 use the last layout chosen for the schedule with
the Schedules menu (shown with a
). To change the layouts used by the buttons from
timeline to vertical or calendar 113 , simply choose the schedule and desired layout using the
Schedules menu.
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Working with Users and User Groups

3.18.1 Users, Add
You must have System Administrator 162 access rights to add a user.
1.

Select File>Users>Add/Edit Users from the main menu. The Browse Users
appears

2.

Click the Add button. The Add/Update User 134 window appears.

3.

Use up to 79 characters to enter a unique user name.

4.

Enter optional user information (last name, first name, department).

5.

Enter a password having at least five characters and meeting the password
requirements set in System Settings 141 . Do this twice.

6.

Select the access level for the user.

7.

If this is a general user 160 or view only user 163 , set which resources they can view or
book.

8.

Click the OK button.

138

window

3.18.2 User Details, Change
You must have System Administrator access rights to change user properties (access level,
password, etc.).
1.

Select File>Users>Add/Edit Users from the main menu. The Browse Users
appears.

2.

Highlight the user you want to change. Click the Open button. The Add/Update Users
134 window appears

3.

Make the desired changes

4.

Click the OK button.

138

window

3.18.3 User Groups, Change
Only System Administrators

162

can create or change user groups 163 .

1.

Select File>Users>User Groups from the main menu to call the Browse User Groups 140
window.

2.

Highlight the user group you want to change and click the Open button to call the Add/
Update User Group 139 window.

3.

Change the name of the user group, if desired.

4.

To add users to the user group, click the Add button to call the Browse Users - Multiple
Select 138 window to let you select the users. Select each of the users you want to
add to the user group and then click the OK button.

5.

To delete a user from the user group, highlight the user and click the Delete button.

6.

Click the Close button.
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Note: Because System Administrators and Resource Administrators 161 already have full
authority to book all resources, they do not need to belong to any User Group.

3.18.4 User Groups, Create
Only System Administrators

162

can create user groups 163 .

1.

Select File>Users>User Groups from the main menu to call the Browse User Groups 140
window.

2.

Click the Add button to call the Add/Update User Group 139 window.

3.

Enter a name for the user group (up to 15 characters) .

4.

Click the Add button. The Browse Users - Multiple Select
select users for the group

5.

Click the OK button.

138

window appears to let you
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4.1

Display, Update, and Control Windows
Booking windows

4.1.1

Add/Update Booking Window

4

The Add/Update Booking window is used to enter a new booking 159 or change an existing
booking. For new bookings, some fields have default values taken from User Preferences 147

The
Print button will print the booking detail including any notes. The
E-mail button
calls your e-mail program with the e-mail address of the client and the booking information in
the body of the message. The
Delete button deletes the booking.
GENERAL TAB
Booking

You can use up to 50 characters to identify the booking. Clicking the
Down Arrow button will reveal a list of several routine bookings entered
in the Update User Preferences 147 window from which you can make a
selection.

Client

The name of the person or organization for whom the resource is being
booked. Clicking the

button to select an existing client or, if

Display, Update, and Control Windows
authorized, create a new client record with the Browse Clients
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105

window. The
button shows the detailed information of the client
entered for the booking.
Start Date/End
Dates

ResSched displays dates in your Windows short and long date formats,
but you can use any of the standard date formats to enter the booking
dates. You can click the
from a look-up calendar.

button beside the Date fields, to pick dates

Note: End Date is available only if 'Bookings can cross midnight' has
been enabled in System Settings.
Start Time/End
Time/Duration

Start and end times of the booking can be entered directly from the
keyboard, through the

buttons, or by selecting from the drop down list with

button. The times shown in the drop lists are set from the Schedule
settings in User Preferences.
the

Duration is only visible if the 'Bookings can cross midnight' option is
turned off in System Settings. Entering a value for Duration will adjust
the End Time automatically and vice versa.
Repeat settings

This box shows the type, frequency and end date for any repeats that
apply to this booking. If there are no repeats, the message shown is
"Single booking."

Status

Select the status 162 of the booking. Reserve
status

Category

Select the name of the category 159 that this booking is part of.

Color

Displays the color that will shown for this booking when Booking is used
as the color source for schedules. If the booking name has picked from a
system wide routine booking 161 with a color, that color will be used.
Otherwise, the 'normal' status 162 level (0) color is used.

Private

Other users will not be able to see the name, client or notes of this
booking.

Lock

Keeps other general users 160 from changing this booking. Resource
Administrators 161 or System Administrators 162 can override locks.

Inactive

The booking is excluded from browse booking, reports and utilization
analysis.

161

users cannot select a

Resources
You must specify one or more resources for every booking. The resource list shows the name
of the resource, the number of units 161 of the resource committed, and the charge rate 159 for
the resource. One of the resources must be defined as the primary resource for the booking.
Add

Adds resources to the list by calling the Browse Resources 92 window to
let you select resources. If you have already entered dates and times for
the booking, you will be able to select from just those resources available
at those times. If a selected resource is a pooled resource 161 , the Units
of Pooled Resource 96 window will appear and ask you how many units of
the resource you wish to book.

Add group

Adds all the resources of a selected resource group 161 to the list by
calling the Browse Resource Groups 99 window for you to select the
resource group.

Delete

Deletes the highlighted resource from the list.

Delete group

Deletes all the resources from a selected resource group from the list.
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Calls Browse Resource Groups window to select the resource group.
Make primary

Makes the currently highlighted resource the primary resource for the
booking

Change rate

Changes the charge rate of the highlighted resource for this booking.

REPEATING TAB
The controls on the Repeating Tab let you specify how the booking is to repeat. Repeat
Options is a drop down list with the repeat options available.
No Repeats

This booking occurs only once. Selecting this option cancels any
previously set repeat dates. Only the date entered in the Date field of
the Add/Update Booking window will remain.

Irregular Repeats This option lets you enter dates and times for the booking that occurs
irregularly. When this option is selected, a list box with all the dates for
this booking is displayed. To add a date to this list, click the Add button.
The Irregular Date Entry window will appear for you to enter the start
and end dates and times of the new occurrence. Clicking the Calendar
button

brings up a look-up calendar.

Fixed Days

This option will schedule the booking to repeat every set number of days,
starting on the date entered in the Date field of the Add/Update
Booking window and continuing until reaching a date you set. On
selecting this option, data fields will appear for you to specify the number
of days between repeats and a date to end the scheduling of booking
repeats.

Fixed Weeks

The same as for Fixed Days, but you must specify the period between
repeats in weeks.

Fixed Months

Bookings will be scheduled to repeat on the same date of the month
every set number of months. On selection, data fields will appear for
specifying the number of months between repeats and the date to stop
repeating the booking. Warning: If date of the month is after the 28th,
the booking will not be scheduled in months that do not have enough
days.

Set Days Each
Week

Bookings will be scheduled to repeat on all the days you specify every
week. On selection, a group of check boxes and an End Date data field
will appear for you to select the days you want and the date to stop
repeating the bookings.

Specific Weekday This option lets you schedule repeats for specific weekdays of every
of the Month
month (e.g., the 2nd Tuesday of the month). Selecting this option causes
several radio buttons to be displayed that let you select the weekday
and which occurrence in the month you want. You must also specify the
date to stop repeating the booking.

NOTES TAB
You can enter a note to your booking having up to 2,000 characters.

ACTUAL TIMES TAB
If using actual times has been enabled in System Settings, you can use these fields to enter
when the event actually started and ended.

COLORS TAB

Display, Update, and Control Windows
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If this booking is a system wide routine booking 161 , there may be colors associated with it.
The colors are shown here.

DOCUMENTS TAB
Document files, such as spreadsheets, that are created by other applications can be
associated with a booking. Access to these files is controlled by the application and the user's
rights to the computer, drive, and folder under Windows. However, only those users with
rights to create or change the booking can add or remove files from the list for the booking.

4.1.2

Browse Bookings Window

The Browse Bookings window is called by clicking Booking>Browse Bookings from the main
menu or the
Browse button in the toolbar. The Browse Bookings window displays all the
bookings 159 in ResSched for a specified period. You can filter these bookings by clicking tabs at
the top of the window. Once you have made entered your selections, you must click the
Display button to generate the display
Note: If 'Bookings can cross midnight' has been checked in System Settings
second line for each booking with the end date and time for the booking.

Display from

141 ,

there will be a

Start date of the display period. The current date is the default

160 .

Use
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the

buttons to call a look-up calendar for selecting the dates.

To

The end date of the display period. ResSched uses the Browse Period
setting in User Preferences 147 to determine the default end date.

Display
Automatically

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must
use the

Display button to show the schedule.

Include Inactive

If you want to include inactive bookings 160 in the display and printed
output, turn this option on.

Use Color

Display any colors are associated with the booking name, client, primary
resource or category. Start and end date/times show colors associated
with the booking's status 162 .

Show Color Block

Use the same background and font colors as the graphical schedules,
otherwise use the background color of schedules as the font color. Only
applies if Use Color is on.

Show Other
Resources

If turned on, when a booking is selected all the resources except the
primary resource are shown in the Other Resources list.

LIST BOXES
Booking
Information

Large list box with the weekday, date, time, booking, client 159 , primary
resource 161 and units. To make the window easier to view, the day and
date are shown for only the first booking of the day. If you have
established colors for the booking, client, or resource, those colors will be
shown for those entries. Status colors are shown in start and end times
of the booking.

Other Resources

Small list box that displays the name and number of units of all the other
resources 161 involved with the highlighted booking that are not the
primary resource.

TABS
By Date

All bookings are displayed in date/time order.

By Resource

All bookings for a specified resource are displayed in date/time order.
Select a resource by clicking

By Client

.

All bookings of a user-specified client listed in date/time order. Enter the
name of the client or select a client by clicking

By Resource
Group

All bookings of each resource in a selected resource group or combination
group 160 are displayed in date/time order. Select a resource group by
clicking

By Category

, or click

to create a combination group

All bookings of an administrator defined category listed in date/time
order. Select the category by clicking

By Status

.

.

All bookings with the specified status listed in date/time order

Display, Update, and Control Windows
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BUTTONS

Open

View or change the details of a booking. Clicking this button calls the
Add/Update Booking 76 window having the details for the highlighted
booking.

Add

Add a new booking. Clicking this button calls a blank Add/Update Booking
76 window.

Delete

Deletes the highlighted booking. You must confirm this action.
You can print a report of the listed bookings.

Print
1. Click the Print button.
2. The Select End of Schedule window opens. Accept or change the end
date for the report period and choose whether to print in landscape,
include booking notes, and preview the report before printing
3. Click the OK button on the Select End of Schedule window. If you
have chosen to use Microsoft Word® 46 (only available with the
Corporate Edition) to print reports, your documents will be generated
using Word®. If you selected Preview, the Report Preview window
appears. If not the report is sent straight to the printer.
Prints the information about the highlighted booking
Print 1

E-mail 1

Calls your e-mail program with the information about the highlighted
booking in the message.
Refresh the display based on the tab, dates, and filter selected.

Display

4.1.3

Browse Bookings Alphabetically Window

The Browse Bookings Alphabetically window lists all bookings 159 in alphabetical order by
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booking name. The Browse Bookings Alphabetically window is accessed by clicking
Booking>Browse alphabetically from the main menu. Unlike all the other Browse functions,
you cannot change any of the booking information using Browse Alphabetically.
Booking

List box that displays the names of all bookings in alphabetical order.

Client

The client for whom the booking has been made

Primary
Resource

The resource that has been booked.

Date, Start and
End Time

List boxes that display each date plus the start and end times for the
highlighted booking.

Other Resources List box that displays any other resources that are involved with the
highlighted booking that are not the primary resource

4.1.4

Browse Conflicts Window

Available to Resource 161 and System Administrators 162 of the Corporate Edition 6 , shows all
the resource scheduling conflicts that have been accepted by users for the resources of a
specified resource group 161 for a specified period. The conflicts are list by resource in
chronological order. Click the

Display button to show the conflicts. The

button prints

the list of conflicts shown.

Resource Group

The resource group with the resources that may have conflicts to be
shown. Select a resource group by clicking

Display from

Start date of the display period. The current date is the default
the

To

160 .

Use

buttons to call a look-up calendar for selecting the dates.

The end date of the display period. ResSched uses the Browse Period
setting in User Preferences 147 to determine the default end date.

LIST BOX
Start / End

The start and end date times of the bookings that have conflicts.

Resource

The resource that has the conflicts.

Booking

The booking name.

Display, Update, and Control Windows
Client
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The client for whom the booking has been made

Purge Old Bookings Window
This window is available only to System Administrators

162 .

The Purge Old Bookings window deletes all past bookings 159 that were scheduled to occur
before a date you specify. Purge cannot be used to delete bookings scheduled for the future.
The window is accessed by clicking Booking>Purge Old Bookings from the main menu.

4.1.6

Browse Routine Bookings Window
The Browse Routine Bookings window lists those bookings names that are used frequently,
either system wide or by a particular user.

4.1.7

Add

Used to add a new item to the list.

Open

Used to review the foreground and background color settings for a selected
item.

Delete

Used to delete a selected item.

Use color

Show color associated with the routine booking

Show color
block

Use the same background and font colors as used in graphical schehules

Add/Update Routine Bookings Window
The Add/Update Routine Bookings window is used to add a new item to the list of routine
bookings 161 or to change the display colors assigned to a system wide routine booking.

84

4.1.8

ResSched 9.9

Booking

Used for entering the name of the booking.

Color

If this is a system wide routine booking, use
to select a color for it.
If no color is selected, the color associated with the 'normal' booking
status 162 (status level 0) is used whenever a schedule Color Source is
Booking. The No Color button removes any previously selected color.
How the colors are displayed in browse bookings and schedules are
shown.

Add Document Window

The Add Document Window is just a means of associating a URL or a document file, such
as a spreadsheet, with a booking. It is called from the Add/Update Booking Window. 76
Use the
Browse button to select the file/URL and then add a description of document.
Click OK to confirm your entry.
When adding a document file to a booking, always remember that access to the document
is controlled by the application that created it, and the rights the user has for the
computer, drive, and folder where the file is stored. The rights of users to edit or view a
specific document are not affected by their rights to view or book resources in ResSched.

Display, Update, and Control Windows
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View Booking Log Window

The View Booking Log window lets system administrators 162 view transactions that involve
the creating, modifying, and deleting of bookings 159 for a specified period. The View
Booking Log function is only available with the Corporate Edition 6 . It is called from
File>Booking Log>View Log.
The list box displays from left to right:
1. Date and time of the transaction
2. Booking number
3. Primary resource 161 of the booking
4. Client 159 of the booking
5. The date and time of the occurrence of the booking selected
6. The name of the users doing the transaction
7. The action taken by the user that affect the booking

Types of Action
Created

Booking is first created.

Occurrence
Changed

The user changed one occurrence of a repeat booking.

Future Changed The user changed all occurrences of a repeat booking that occurred
after the selected date.
All Changed

The user changed all occurrences of a repeat booking, or the only
occurrence of non-repeated booking.
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Occurrence
Deleted

The user deleted one occurrence of a repeat booking.

Future Deleted

The user deleted all occurrences of a repeat booking that occurred
after the selected date.

All Deleted

The user deleted all occurrences of a repeat booking, or the only
occurrence of non-repeated booking.

Irregular
Changed

The user added, deleted or changed the dates and times of at least
once occurrence of an irregularly repeated booking.

Resource
Deleted

The user deleted the resource and chose to delete any bookings
associated with only that resource.

Client Deleted
All

The user deleted a client and chose to delete all the bookings of the
client.

Client Deleted
Future

The user deleted a client and chose to delete the bookings of the
client that occurred after the transaction date.

Purged
Bookings

The user purged all bookings before a specified date.

When a system or resource administrator deletes a resource or client, the log does not
show the individual bookings involved, only the name of the resource or client.
When a user changes some but not all occurrences of a repeat booking, they are actually
doing two transactions; changing the original booking to reflect just the unchanged
occurrences, and making a new booking for the changed occurrences. So the log will
show two transactions at essentially the same time.

4.1.10 Booking Conflicts Window
The Booking Conflicts Window is called when a user is trying to make a booking that would:

over book a resource 161 ;
over book a client (if turned on in System Settings 141 );
occur on a special day 162 ;
occur on a weekend or outside a normal workday (if turned on in User Preferences
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)
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For each occurrence of the proposed booking that has conflicts, the list box shows the date
and time of the proposed occurrence, and the conflicts it has. The conflict information includes
the resource, client or booking name (set in User Preferences 147 ). When the conflict involves
an individual (i.e., not pooled 161 ) resource, the time of the conflicting booking is also shown.
Booking occurrences that have conflicts will not be scheduled, unless the user accepts the
conflict. Click on each conflict you want to accept, and click OK. To select or deselect all the
conflicts, click Select All or Clear All.
Please note: If System Settings 141 have been set to disallow conflicts, general 160 and reserve
161 users will not be able to accept any conflicts that involve a resource. System 162 and
Resource 161 Administrators can accept these conflicts, but they must confirm they want to over
ride each one.

4.1.11 Purge Log Window
This window is available only to System Administrators

162 .

The purge log window deletes all booking log entries that occurred before a specified
date. It does not affect the bookings 159 themselves. The administrator simply enters the
date and clicks OK. Purging the log is not reversible. The window is accessed by clicking
File>Bookings Log>Purge Log from the main menu.
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4.2

Resource Windows

4.2.1

Add/Update Resource Window
The Add/Update Resource window lets you add or change an entry for a resource in
ResSched. You accessed it by choosing Resource>Add Resource from the main menu, or from
the Browse Resources 90 window. This window is available only to Resource 161 and System
administrators 162 .
The Add button lets you add several resources without having to reopen the window for each
one. Simply enter the new resource and click the Add button. Then repeat the process for each
new resource.

GENERAL TAB

Resource

A unique name, up to 30 characters, which ResSched uses to identify each listed
resource.

Rate

The rate charged for using the resources holders of a Corporate ResSched
license can use this information to issue invoices directly with ResSched or import
it into their accounting system using the ODBC driver.

Rate
Period

The period for which the rate applies.

Inactive

When this box is checked, the resource is no longer available for bookings.

Pooled

The resource has more several indistinguishable units, e.g., stacking chairs.
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Units

Total number of units of the pooled resources available. Disabled if Pooled is
unchecked.

Color

Use
to select a color for this resource. If no color is selected, the color
associated with the 'normal' booking status 162 (status level 0) is used
whenever a schedule Color Source is resource. The No Color button
removes any previously selected color. How the colors are displayed in
browse bookings and schedules are shown.

WHO CAN BOOK TAB
This tab is used to give general 160 and reserve 161 users authority to book the resource. When
the 'All general and reserve users can book' check box is checked, any general or reserve
user is allowed to book the resource. When the check box is unchecked, you must specify
which general and reserve users can book the resource. System administrators, resource
administrators, and general or reserve users that have been given authority to book any
resource with their user ID do not have to be added to the list.

Click this button to add a General or Reserve Users to the list.
Add users
Delete
user

Click to delete a highlighted user.
Click to add all the users of selected user group

163

to the list.

Add user
group
Click to delete all the users of a selected user group from the list.
Delete
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WHO CAN VIEW TAB
This tab is essentially the same as the Who Can Book tab, but it is used to give general,
reserve, and view only 163 users authority to view the resource. Users on the Who Can Book list
automatically have the right to view the resource.

RESOURCE GROUPS TAB

This tab lets you add the resource to resource groups. For pooled resources, the number of
units of the resource allocated to each resource group is shown.

Add

Calls the Browse Group - Multiple Select 92 window, so you can select which
groups the resource is to be part of. If the resource is pooled, you will be asked
how many units should be allocated to each group.

Delete

Deletes the resource from the selected resource group.

NOTES TAB
Include up to 2,000 characters of optional free-form text for each resource. If Notes are
present, the label of the Notes tab turns red.

4.2.2

Browse Resources - Single Select Window
The Browse Resources - Single Select window is used by several ResSched functions to
select a single resource 161 . You can also use this window to add a new resource to ResSched
or change or delete an existing resource entry. Access the Browse Resources - Single Select
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window by clicking Resource>Browse Resources from the main menu or through the different
functions that use it to select resources. The list of resources presented may vary depending
on the funtion calling the window and the users rights to use the resources.
When called to add resources to a booking or to a resource group, Browse Resources is in
multiple-select mode so you can pick several resources to be added at once. When called by
other functions, it is in single-select mode, letting you select only one resource at a time.

TAB - All
Resources

Lets you select from any of the resources that have been entered into
ResSched that the user has rights to.

TAB - Group
Resources

Lets you select from just the resources of a specified resource group.

Locator

Use Locator to quickly find a specific resource. Simply type in the first few

Click the

button beside the Group drop-down list and select a group.

characters of the name and press the Enter key or the
button.
The more characters entered, the more accurate Locator will be.

LIST BOX
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Resource

A unique name up to 30 characters that ResSched uses to identify each
listed resource.

Units

Number of available units of each resource.

BUTTONS
Select the highlighted resource.
Select

Add a new resource. Calls the Add/Update Resource
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window.

Add
Open
Delete

View or change the resource details. Calls the Add/Update Resource
window with the details of the highlighted resource.
Deletes the highlighted resource
Print the information about the highlighted resource

Print

4.2.3

Browse Resources - Multiple Select Window
Use the Browse Resources - Multiple Select window to select one or more resources for a
booking 159 or a resource group 161 . Select resources 161 for the booking or resource group by
clicking each resource and then click the OK to add the selected resources to the resource
group or booking.
When used to for a booking, only those resources you have authority to book are shown. If
you have already entered the time and dates of a booking, you may select from just those
resources that are available at those times. Note however, that when there are many resources
and many occurrences of the booking, this can take considerable network resources and time. One
way to reduce this time would be to check for available resources that are part of a resource group
rather than all resources.
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TABS
All Resources

Lets you select from any of the resources that have been entered into
ResSched.

Group Resources

Lets you select only from the resources of a specified resource group.
Click the

button beside the Group drop-down list and select a group.

All Resources
Available

Lets you select just from resources that are available for all of the
booking occurrences you have specifed.

Group Resources
Available

Lets you select from the resources of a single resource group available for
all of booking occurrences you have specified. A normal, complete conflict
check is performed.

Locator

Use Locator to quickly find a specific resource. Simply type in the first few
characters of the name and press the Enter key or the
button.
The more characters entered, the more accurate Locator will be.
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Use color

Display the color associated with this resource.

Show color
block

Use the same background and font colors as the graphical schedules,
otherwise use the background color of schedules as the font color. Only
applies if Use Color is on.

LIST BOX
Resource

A unique name, up to 30 characters, which ResSched uses to identify each
listed resource.

Units

Number of available units of the resource.

BUTTONS
Selects all the resources shown.
Select All
Deselects all the resources.
Clear All
OK

4.2.4

Transfers all the selected resources to booking or group list that called
this window.

Resource Utilization Window
The Resource Utilization window is available only to Resource Administrators 161 and System
Administrators 162 holding a corporate license. It displays usage statistics for a specified
resource 161 .

Display, Update, and Control Windows

95

ENTRY FIELDS AND CHECK BOXES
Resource
Start Date

The resource
resource.

161

you want to analyze. Click the

button to select the

The first day of the period to be analyzed. Use the Calendar button
select a date.

End Date

The end day of the period to be analyzed. Use the Calendar button to
select a date.

Include
weekends

Include any bookings on weekends in the calculations.

Include special
days

Include any bookings on special days

162

to

in the calculations.

Use actual times If Actual Times 159 has been enabled in System Settings, you can check
this box to use the actual times, instead of the scheduled times.

BUTTONS
Calculate
Print

Calculate the usage statistics as specified.
Print the usage statistics.

STATISTICS
Work Days
Available

The number of work days in the period. Weekends and special days are
not counted unless specified.

Work Days Used The number of work days in the period when the resource was booked at
least once.
% Days Used

Work days used as a percentage of available work days.

Work Hours
Available

The number of work days in the period, multiplied by the number of hours
in a normal work day as specified in the User Preferences window for the
user. Hours on weekends and special days are not counted unless
specified.

Work Hours
Used

The total number of hours a resource was booked between the normal
beginning and end of the workday during the specified period.

% Hours Used

Work hours used as a percentage of available work hours.

Total Hours
Used

The total number of hours the resource was booked during the specified
period regardless of whether the hours were in the normal workday.
Weekends and special days are not included unless specified.

Work Day Start

The start of the normal work day as specified in the Update User
Preferences 147 window.

Work Day End

The end of the normal work day as specified in the Update User
Preferences window.
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Units of Pooled Resource Window
You use this window to choose how many units of a pooled resource 161 to add to a booking 159
or resource group 161 .

Resource

The name of the pooled resource.

Total Units

The total number of units that exist for the pooled resource.

Units to Use

The number of units you want for this booking or resource group.

Display, Update, and Control Windows

4.3

Resource Group Windows

4.3.1

Add/Update Resource Group Window
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System 162 or Resource administrators 161 can create or change a Resource Group. The Add/
Update Resource Group window is called from the Browse Resource Groups 99 window.

Resource
Group Name

A unique identifying name for the resource group up to 30 characters.

Allow all users When turned on, all users will be able to use this resource group. When
to use this
turned off only those users listed on the Users tab will be able to use the
resource group resource group
Resources in
Group
Add

A list box that displays all resources 161 currently in this resource group.
Calls the Browse Resources - Multiple Select 92 window to let you select
another resource for the resource group. Note: if one of the selected
resouces is a pooled resource 161 , you must choose how many units of the
resource are going to be part of the group. The Units of Pooled Resource
96 window will appear accept your choice.
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Delete

Removes the highlighted resource from the resource group.

USERS TAB
The list of users authorized to use this resource group. Authority to use the resource group
does give the user authority to book or view the resources of the group. So, when user uses
the group to for a schedule, the schedule will only have those resource the user has authority
to view. Authority to book or view resources is controlled in the user entry 134 or resource
entry 88 .

Calls the Browse User Multiple Select

138

window to pick the users.

Add
Delete

Deletes the selected user from the list

If the System Administrator has set up User Groups 163 , you can put all of
the users in the user group on to the list for the resource group. Calls the
A dd user group Browse User Group 140 window to select the user group.
Removes all the users of a user group from the list for the resource group
Delete user
group
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Browse Resource Groups Window
The Browse Resource Groups window lets you select, create, change or delete resource
groups 161 . It is accessed by clicking Resource>Resource Groups from the main menu or from
any of the functions that require you to select a resource group. It contains a list box
displaying all existing resource groups.

Select

Selects the highlighted resource group for the calling window. Or you can
double click on the resource group you want.
Call a blank Add/Update Resource Group

Add

97

window for you to create the new

resource group.

Opens the Add/Update Resource Group

97

window with highlighted resource's

Open

information.

Delete

Deletes the highlighted resource group. Does not affect any of the
resources in the group.

Print the resource group
Print
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Browse Resource Groups - Multiple Select Window
For adding several resource groups 161 to a resource 161 , user authorization 139 , or
combination group 160 .
Resource groups are selected or deselected by clicking on them. The Select All button
selects all the resource groups and the Clear All button clears all current selections.
Click OK to process the selected resource groups.

4.3.4

Create Combination Group Window
Used to create combination group 160 , the Create Combination Group window is called by the
button. Combination groups can be used to filter resources based on different criteria,
show the combine resources of several groups, or to display schedules of individually selected
resources together.
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Name of
combination
group

The name that will show on your schedules and reports

Groups Tab

Used to create a combination group from other resource groups
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Resources m ust
be in ALL these
groups

To be included in the Combination group, a resource must be included
in all of the groups listed here. Each of the groups acts as a criteria.

Resources m ust
be in at least
ONE of these
groups.

Creates a list of all the resources that are in any of the groups.

Add

Calls the Browse Resource Groups - Multiple Select
user to select resource groups for the lists.

Delete

Deletes the highlighted resource group from the associated list.

Resources Tab

100

window for the

Used to create a combination group of user selected resources.

102

ResSched 9.9
Resources

4.3.5

List of resources selected for the combination group.

Add

Calls the Browse Resource - Multiple Select
resources.

Delete

Remove selected resource from the combination group
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window to select the

Resource Group Utilization Window
The Resource Group Utilization window is available only to Resource Administrators 161 and
System Administrators 162 holding a Corporate license 6 . It displays usage statistics for a
specified resource Group 161 .

ENTRY FIELDS AND CHECK BOXES
Group
Start Date
End Date

The resource group you want to analyze. Click the
of all resources.

button to select from a list

The first day of the period to be analyzed. Use the

button to select a date.

The end day of the period to be analyzed. Use the

button to select a date.

Include
Weekends

If the analysis should include bookings

Include
Special
Days

If the analysis should include bookings that fall on special days
box.

Use
Actual

If Actual Times 159 has been enabled in System Settings, you can check this box
to use the actual times, instead of the scheduled times.

159

that fall on a weekend, check this box.

162 ,

check this
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Times
BUTTONS
Calculate the usage statistics.
Calculate
Print both the summary and detail usage statistics.
Print

SUMMARY TAB
The concept of the resource work day or work hour is central to these statistics. A resource
work day is one resource for one day. If there are three resources in a group, then each week
day has three resource work days for that group. For pooled resources 161 , these figures are
multiplied by the number of units used or available for the resource.
Resource Work The number of work days in the period times the number of resources in the
Days Available group. Weekends and special days are not counted unless specified.
Resource Work The number of resource work days in the period when the resource was
Days Used
booked at least once.
Percent Days
Used

Resource work days used as a percentage of available resource work days.

Resource Work The number of resource work days in the period multiplied by the number of
Hours Available hours in a normal work day as specified in the Update User Preferences 147
window for the user. Hours on weekends and special days are not counted
unless specified.
Resource Work The total number of hours the resources in the group were booked between
Hours Used
the normal beginning and end of the workday during the specified period.
Percent Hours
Used

Resource work hours used as a percentage of available resource work
hours.

Total Hours
Used

The total number of hours the resources were booked during the specified
period regardless of whether the hours were in the normal workday.
Weekends and special days are not included unless specified.

Work Day
Start/End

The start and end times of the normal work day as specified in the Update
User Preferences window.

DETAIL TAB
The Detail tab displays summary usage statistics for each resource in the resource group. For
pooled resources, these figures are multiplied by the number of units used or available for the
resource.
Total Hours
Used

Total hours the resource was booked during the period

Work Hours
Used

Hours the resource was booked that fell in the work day

Count

The number of times the resource was booked in the period

% Utilization

The work hours used as a percentage of work hours available during the
period.
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4.4

Client Windows

4.4.1

Add/Update Client Window
Use the Add/Update Client window to create or view client 159 information. As well as system
162 and resource 161 administrators, general users 160 can create client records if System
Settings 141 allow it.
The Add button lets you add several clients without having to reopen the window for each one.
Simply enter the new client and click the Add button. Then repeat the process for each new
client.

GENERAL TAB
Client

A unique client name is the only information required by ResSched

Contact
Person

You can include the name of a contact person in a client organization, as well as
the phone number, mobile, e-mail, and mailing address for the client.

Color

Use
to select a color for this client. If no color is selected, the color
associated with the 'normal' booking status 162 (status level 0) is used
whenever a schedule Color Source is Client. The No Color button removes
any previously selected color. How the colors are displayed in browse
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bookings and schedules are shown.

NOTES TAB
Include any special information about the client in this free-form text section. If Notes are
present, the label of the Notes tab turns red.

4.4.2

Browse Clients Window
Use the Browse Clients window to select clients 159 for bookings 159 and other ResSched
functions. Also, you can use this window to add a new client to ResSched or change or delete
an existing client entry. The Browse Clients window is called by Client>Browse Clients from
the main menu or by the different functions that use it to select clients.

Locator

Use Locator for quickly finding a specific client. Simply type in the first few
characters of the name and press Enter or click
. The more
characters entered, the more accurate the Locator will be.
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Client

A unique name, up to 50 characters long, which ResSched uses to identify
each listed client.

Use color

Display the color associated with client

Show color
block

Use the same background and font colors as the graphical schedules,
otherwise use the background color of schedules as the font color. Only
applies if Use Color is on.

Select

Select the highlighted client

Add

Creates a new client entry.

Open

4.4.3

Opens the client record to view details or make changes.

Delete

Delete the highlighted client from ResSched.

Print 1

Prints the information about the highlighted client.

Print All

Prints the information about all clients.

Utilization by Client Window
Use the Utilization by Client window to display the resources that individual clients used in a
specified period. This window is available only to System 162 and Resource administrators 161 of
Corporate license 6 holders .

Client

Select a client from the drop list.

From

Select a start date for the period.

To

Select an end date.

Round up

Round up time used to next charge period. E.g. If the resource is charged
out by the hour, and a client uses 2½ hours in a booking the usage is
shown as 3 hours.

Actual Times

If Actual Times 159 has been enabled in System Settings, you can check this
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box to use the actual times, instead of the scheduled times.
Calculate

Calculate and display the utilization statistics.

SUMMARY TAB
The cummulative statistics for each resource the client used during the analysis period
Resource

The resource used by the client.

Used

Units of the resource used multiplied by time they were used.

Period

The time period used for billing.

Rate

The rate charged for the resource per period.

Sub Total

The amount charged for the resource.

DETAIL TAB
Shows each time the client used a resource during the analysis period and the amount the
resource was used.

4.4.4

Resource

The resource used by the client.

Units

The number of units of the resource that were used.

Start

The Start Time of the period when the resource was used.

End

The End Time of the period when the resource was used.

Used

The resulting time/resource units used for the selected period of time.

Invoice Clients Window
The Invoice Clients window is used to generate a paper bill for billing purposes. It is only
available with the Corporate Edition license. Only Resource 161 and System administrators 162
can invoice clients.
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Clients

A list of current clients. Click on the ones you want to invoice.

From

The Start Date of the period to be covered.

To

The End Date of the period to be covered.

Pay to

Name of party sending the invoice or who is to be paid by the client.

Payment
Address

Address where payment is to be sent.

Tax 1 Name and
Rate

A first tax name and rate (expressed as percentage).

Tax 2 Name and
Rate

A second tax name and rate (expressed as percentage).

Starting Invoice
#

An internal record-keeping detail.

Currency

The national currency in which payment is to be made.

Discount Rate

Discount rate that can be applied to all items on the invoice.

Include Detail

Includes information that is displayed on the Detail tab of the Utilization by
Client 106 window.

Print Preview

Check this box if you wish to see how the document will look before it is
printed.

Include clients

Produce an invoice for all selected clients even if some of them have either
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without billable
time

not used any chargeable resources.

Use Actual
Times

If Actual Times 159 has been enabled in System Settings, you can check this
box to use the actual times, instead of the scheduled times.

Select All

Selects all the clients on the list.

Clear All

Deselects all clients.

Note: Many organizations have unique or complicated invoicing requirements. If your
organization does, you may wish to use the ODBC driver 9 that is issued with the ResSched
Corporate license to generate invoices using ResSched data in other applications.

4.4.5

Delete Multiple Clients Window
The Delete Multiple Clients window is used by system 162 and resource administrators 161 to
delete one or more clients 159 from ResSched. Select clients by single clicking on them.
When you click the Delete button, you will be asked to confirm the deletion and then asked
what you want to do with the bookings for those clients. You can choose to keep the bookings,
delete them all or delete those occurring in the future.
Please note: If you delete a client, you will not be able to obtain any views or reports for this
client. If you might want to view or print the bookings for this client in the future, make the
client inactive 59 instead of deleting it.
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BUTTONS
Select all

Select all the clients for deletion.

Clear all

Deselect all previously selected clients.

Delete

Deletes selected clients.
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4.5

Category Windows

4.5.1

Add/Update Category Window

111

Use the Add/Update Category window to create new categories 159 . It is called by
Categories>Add Category from the main menu. Only System Administrators 162 and Resource
Administrators 161 can add, edit or delete categories. General users 160 can create categories if
System Settings 141 allow it, but they cannot change or delete them.

4.5.2

Color

Use
to select a color for this category. If no color is selected, the
color associated with the 'normal' booking status 162 (status level 0) is
used whenever a schedule Color Source is Category. The No Color
button removes any previously selected color. How the colors are
displayed in browse bookings and schedules are shown.

Inactive

Toggles whether the category is Inactive 160

Browse Categories Window
Use the Browse Categories window to select categories 159 for bookings 159 and other
ResSched functions. Also, you can use this window to add a new category to ResSched or
delete an existing category entry. The Browse Categories window is called by
Categories>Browse Categories from the main menu.
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Locator

Use Locator to quickly find a specific category. Simply type in the first few
characters of the name and press the Enter key of click
more characters enterd, the more accurate Locator will be.

. The

Use color

Show the color associated with each category

Show color
block

Use the same background and font colors as the graphical schedules,
otherwise use the background color of schedules as the font color. Only
applies if Use Color is on.

Select

Select the highlighted category

Add

Creates a new category entry in the Add/Update Category 111 window.

Open

Opens an existing category in the Add/Update Category window. You can
then change the name of the category.

Delete

Delete the highlighted category from ResSched.
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4.6

Schedule Windows

4.6.1

Timeline vs Vertical Display Format
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Timeline vs Vertical Display Layout
ResSched lets users choose whether they want to view graphical schedules in vertical
(resources across the top; date/time down), timeline (resources down the left of the window;
time across the top), calendar (standard monthly calendar). While the choice is largely a
matter of user preference, there are important functional differences.
The vertical format can usually provide more space for booking descriptions, but does not
display double bookings or bookings of pooled resources 161 well. The timeline format displays
these types of bookings well, but there is often less space available for text descriptions of the
booking. The calendar format is not suitable if there are large numbers of bookings on any
day.
The toolbar 25 buttons that call a schedule have a vertical, timeline, or calendar layout. The
buttons use the last selection you made using the Schedules menu in the main menu.

4.6.2

Resource Group Timeline Schedule Window
The Resource Group Timeline Schedule window displays all bookings 159 for all the resources
161 in a resource group 161 or combination group 160 for a selected day, week, month, quarter
or year in a horizontal time line. The schedule shows only those bookings that occur during the
regular work day as specified by the Begin and End entries. If a resource has more than one
booking at the same time (intentionally double booked, or a pooled resource 161 ), the second
and subsequent bookings are shown in the row below. You can view or change the complete
booking information by double clicking the box.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Color Source

Drop-down list to select whether the colors of the booking, resource,
client, or booking status are used in the display.

Display
Automatically

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
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the
Resource Group

Display button to show the schedule.

The resource group to display.
The Combo button lets you create a combination group 100 to filter
resources by criteria, or combine the resources of multiple groups or
individually selected resources in a single display.

Time Scale

Choose Day, Week, Month, Quarter or Year. Quarter and Year time
scales are only available if System Settings have been set to allow
booking occurrences to cross midnight.

Date

A date in the period you want to display. Enter the date directly or click
to call a look-up calendar for selecting the date.

Begin/End

The start and end times of the work day.

Text

The text to be shown in the booked time slots. You can choose among
showing no text, the booking name, the client's name, or the first six
letters of the booking and use the remaining space for the client's name.

Height

You can change the height of the rows.

Font

Select the font you want for the text by clicking the

button

To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another time slot. The Add/Update Booking window
will appear and display the existing booking, but with the new time and date information and
the existing resource information.

4.6.3

Resource Group Day Schedule Window
The Resource Group Day Schedule window displays all bookings 159 for all the resources 161 in
a resource group 161 or combination group 160 for a selected day in vertical format. Time slots
are listed down the window with the resources listed across. Bookings are displayed as boxes
at the intersections of the relevant time slots and resources. For those bookings that take
place during the regular work day, as set in User Preferences 69 , the length of the box is
determined by the length of the booking. Those bookings that take place outside the regular
workday occupy a single time slot labeled Before or After the regular work day starts or ends.
You can view or change the booking information by double clicking the box.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.
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Color source:

Drop-down list to select whether the colors of the booking, resource, client,
or booking status are used in the display.

Display
Automatically:

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Display button to show the schedule.

Resource Group: The resource group to be displayed. Click the Down Arrow button to select
the resource group from a table of existing resource groups.
The Combo button lets you create a combination group 100 to filter
resources by criteria, view the schedule of resources from different
resource groups, or a temporary selection of resources.
Date:

The date to be displayed. Enter the date directly or click the Calendar
button

to call a look-up calendar for selecting the date.

Begin/End:

The start and end times of a regular work day.

Interval:

The amount of time covered by a single row of the grid.

Text:

The text to be shown in the booked time slots. You can choose among
showing no text, the booking name, the client's name, or the first six
letters of the booking and use the remaining space for the client's name.

Width/Height:

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button
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To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.

WARNING: If bookings overlap, the text in the boxes may be jumbled. When you click the
overlapped area, only the booking details of the earliest booking for that area will be available.
Overlapping occurs when bookings conflict or when a booking ends and another starts within
the same time slot (e.g., one booking ends at 10:05 and another starts at 10:10, while the
time slot covers 10:00 to 10:15). Also, when two conflicting bookings end or start in the same
time slot they may appear to be two adjacent non-conflicting bookings. When precise
information on bookings is needed, click the Browse button to call the Browse Bookings
window or use a timeline format. See: Timeline vs Vertical Display Format. 113 for more
information.
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Resource Group Week Schedule Window
The Resource Group Week Schedule window displays all bookings 159 for all the resources 161
in a resource group 161 or combination group 160 for a selected week in a vertical format with
day/time running down the window and the resources running across it. Bookings are
displayed as boxes at the intersections of the relevant day/time slots and resources. The
length of the box is determined by the length of the booking. You can view or change the
complete booking information by double clicking the box.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

(image cropped for fit and visibility)
Color source:

Drop-down list to select whether the colors of the booking, resource, client,
or booking status are used in the display.

Display
Automatically:

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Display button to show the schedule.

Resource Group: The resource group to be displayed. Click the Down Arrow button to select
the resource group from a table of existing resource groups.
The Combo button lets you create a combination group 100 to show the
schedule of resources from different resource groups
Week includes:

A date in the week to be displayed. Enter the date directly or click the
Calendar button

to call a look-up calendar for selecting the date.
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Begin/End:

The start and end times of a regular work day.

Interval:

The amount of time covered by a single row of the grid.

Text:

The text to be shown in the booked time slots. You can choose among
showing no text, the booking name, the client's name, or the first six
letters of the booking and use the remaining space for the client's name.

Width/Height:

You can change the dimensions of the columns and rows.

Font:

Select the font you want for the text by clicking the

button

To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.

WARNING: If bookings overlap, the text in the boxes may be jumbled. When you click the
overlapped area, only the booking details of the earliest booking for that area will be available.
Overlapping occurs when bookings conflict or when a booking ends and another starts within
the same time slot (e.g., one booking ends at 10:05 and another starts at 10:10, while the
time slot covers 10:00 to 10:15). Also, when two conflicting bookings end or start in the same
time slot they may appear to be two adjacent non-conflicting bookings. When precise
information on bookings is needed, click the Browse button to call the Browse Bookings
window or use a timeline format. See: Timeline vs Vertical Display Format. 113 for more
information.
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Resource Group Month Schedule Window
The Resource Month Schedule window displays all bookings 159 for a resource group 161 for a
month in a standard calendar layout.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Unlike other Schedule windows, the Month Schedule windows do not use the size and position
of boxes to graphically convey the duration and start time of bookings. Instead, each booking
is allocated a single line of text and each is listed in order of start time for each day of the
calendar. The text line includes the start time and the selected Text.

Color
Source

Drop-down list to select whether the colors of the booking, resource, or booking
status are used in the display.

Display
If turned on, when this window opens the schedule will automatically be
Automatical displayed using the last settings used. When any of those settings are
ly
changed, the window will refresh the display. If turned off, you must use the
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Display button to show the schedule.
Resource
Group

Click the Down Arrow button to select the resource group whose bookings you
want to display.

Month
Includes

A date in the month to be displayed. Enter the date directly or click the

Rows/Day

The number of rows (bookings) that will be shown in a day. If there are more
bookings on a day than you selected, the last row of the day reads 'More.'

Text

The text to be shown, along with the start time, for a booking. You can choose
among showing no text, the booking name, the resource name, or mixed, which
is a combination of booking and the primary resource of the booking.

Width/
Height

You can change the dimensions of the columns and rows.

Font

Calendar button

to pick a date.

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click on it.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another day. The Add/Update Booking window will
appear and display the existing booking, but with the new date information.

4.6.6

Resource Group Flexible Period Schedule Window
The Resource Group Flexible Period Schedule window displays all bookings 159 for all the
resources 161 in a resource group 161 for a period that you select.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.
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The days are listed across the window, with the resources listed down. Bookings are displayed
as boxes at the intersections of days and resources.
To view the details of a booking, the Add/Update Booking window may be called by clicking
the colored box for a particular date.
Color
Source

Drop-down list to select whether the colors of the booking, resource, client or
booking status are used in the display

Display
Automatic
ally

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use the
Display button to show the schedule.

Resource
Group

The resource group you want to view. Click the

button to select the

resource group from a table of existing resource groups, or click the
button to create a Combination Group 160 from other resource groups or
selected resources.
Start/End
Date

The start and end dates of the period you want to view. Click the
call a look-up calendar for selecting the date.

button to

Begin/End

Beginning and ending times of the regular workday. The schedule will only
includes bookings within these times.

Text

The text to be shown in the booked time slots. You can choose among showing
no text, the booking name, the client's name, or the first six letters of the
booking and use the remaining space for the client's name.

Width/
Height

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button
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Resource Week Schedule Window
The Resource Week Schedule window displays all bookings 159 for one resource for a week in
vertical format 113 . You can view or change the complete booking information by double clicking
the box.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

The starting week day is set by the System Administrator in the Update System Settings
window.

Color
Source

Drop-down list to select whether the colors of the booking, client or booking
status are used in the display.

If turned on, when this window opens the schedule will automatically be
Display
Automatic displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use the
ally
Display button to show the schedule.
Resource

The resource 161 to be displayed. Enter the name of resource or click the Down
Arrow button to select from a table of existing resources.

Week
Includes

A date in the week you want to display.
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Begin/End

Beginning and end of the display workday.

Interval

Choosing a small time interval will allow you to see bookings for even short
periods of time.

Text

The text to be shown in the booked time slots. You can choose among showing
no text, the booking name, the client's name, or the first six letters of the
booking and use the remaining space for the client's name.

Width/
Height

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click a box representing the booking.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another time slot. The Add/Update Booking window
will appear and display the existing booking, but with the new time and date information.
Confirm by clicking the OK button.

WARNING: If bookings overlap, the text in the boxes may be jumbled. When you click the
overlapped area, only the booking details of the earliest booking for that area will be available.
Overlapping occurs when bookings conflict or when a booking ends and another starts within
the same time slot (e.g., one booking ends at 10:05 and another starts at 10:10, while the
time slot covers 10:00 to 10:15). Also, when two conflicting bookings end or start in the same
time slot they may appear to be two adjacent non-conflicting bookings. When precise
information on bookings is needed, click the Browse button to call the Browse Bookings
window or use a timeline format. See: Timeline vs Vertical Display Format. 113 for more
information.
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Resource Month Schedule Window
The Resource Month Schedule window displays all bookings 159 for one resource 161 for a
month in a standard calendar layout.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Unlike other Schedule windows, the Resource Month Schedule windows do not use the size
and position of boxes to graphically convey the duration and start time of bookings. Instead,
each booking is allocated a single line of text and each is listed in order of start time for each
day of the calendar. The text line includes the start time and the selected Text.

Color Source

Drop-down list to select whether the colors of the booking, resource, or
booking status are used in the display.

Display
Automatically

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Display button to show the schedule.
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button to resource whose bookings you want to display.

Month Includes A date in the month to be viewed. Enter the date directly or click the
Calendar button

to pick a date.

Rows/Day

The number of rows (bookings) that will be shown in a day. If there are more
bookings on a day than you selected, the last row of the day reads 'More.'

Text

The text to be shown, along with the start time, for a booking. You can
choose among showing no text, the booking name, the resource name, or
mixed, which is a combination of booking and the primary resource of the
booking.

Width/Height

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click on it.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another day. The Add/Update Booking window will
appear and display the existing booking, but with the new date information.
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Pooled Resource Availability Window
The Pooled Resource Availability window shows you how much of a pooled 161 resource has
been booked for all time slots in a selected week. For each time slot, the number of booked
units is shown both in absolute numbers and as a percentage of the total units of the
resource. When fewer than 50% of the available units are booked, the time slot is colored
blue. Yellow is used when 50 to 99% of the units are booked, and red when 100% or more
(greater than 100% means over booked) of the units are booked in the time slot.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Resource

Display
Automatically

The resource to be viewed. Enter the name of the resource or click the
button to select from a table of existing resources.
If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Week
Includes

Display button to show the schedule.

A date in the week to be displayed. Enter the date or click the
call a look-up calendar for selecting the date.

button to

Begin/End

Beginning and ending times of the regular work day.

Interval

Choosing a small time interval will allow you to see bookings for even short
periods of time.

Width/Height

You can change the dimensions of the columns and rows.

To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
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4.6.10 Client Week Schedule Window
The Client Week Schedule window displays all bookings 159 for one client for a week in the
vertical 113 format. You can view or change the complete booking information by double clicking
the box.
The starting week day is set by the System Administrator in the Update System Settings
window.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Color Source

Drop-down list to select whether the colors of the booking, client or
booking status are used in the display.

Display
Automatical
ly

If turned on, when this window opens the schedule will automatically
be displayed using the last settings used. When any of those
settings are changed, the window will refresh the display. If turned
off, you must use the

Client

Display button to show the schedule.

The client 159 to be viewed. Click the
button to select from a table
of existing clients.

Week
Includes

A date in the week to be viewed. Enter the date directly or click the

Begin/End

Beginning and end of the workday you wish to display.

button to call a look-up calendar for selecting the date
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Interval

The time interval represented by each row of the display.

Text

The text to be shown in the booked time slots. You can choose
among showing no text, the booking name, resources, or the first six
letters of the booking and use the remaining space for the resources.

Width/Height

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click a box representing the booking. You
can also drag a booking to another time slot.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.

WARNING: If bookings overlap, the text in the boxes may be jumbled. When you click the
overlapped area, only the booking details of the earliest booking for that area will be available.
Overlapping occurs when bookings conflict or when a booking ends and another starts within
the same time slot (e.g., one booking ends at 10:05 and another starts at 10:10, while the
time slot covers 10:00 to 10:15). Also, when two conflicting bookings end or start in the same
time slot they may appear to be two adjacent non-conflicting bookings. When precise
information on bookings is needed, click the Browse button to call the Browse Bookings
window or use a timeline format. See: Timeline vs Vertical Display Format. 113 for more
information.
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4.6.11 Client Month Schedule Window
The Client Month Schedule window displays all bookings
month in a standard calendar layout.

159

of one client

159

for a

The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Unlike other Schedule windows, the Month Schedule windows do not use the size and position
of boxes to graphically convey the duration and start time of bookings. Instead, each booking
is allocated a single line of text and each is listed in order of start time for each day of the
calendar. The text line includes the start time and the selected Text.

Color Source

Drop-down list to select whether the colors of the booking, resource, or

130

ResSched 9.9
booking status are used in the display.
Display
Automatically

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Display button to show the schedule.

Client

Click the Down Arrow button to select the client whose bookings you
want to display.

Month Includes

A date in the month to be displayed. Enter the date directly or click the
Calendar button

to pick a date.

Rows/Day

The number of rows (bookings) that will be shown in a day. If there are
more bookings on a day than you selected, the last row of the day reads
'More.'

Text

The text to be shown, along with the start time, for a booking. You can
choose among showing no text, the booking name, the resource name, or
mixed, which is a combination of booking and the primary resource of the
booking.

Width/Height

You can change the dimensions of the columns and rows.

Font

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click on it.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another day. The Add/Update Booking window will
appear and display the existing booking, but with the new date information.

Display, Update, and Control Windows

131

4.6.12 Client Timeline Schedule Window
The Client Timeline Schedule window displays all bookings 159 for one client 159 for a day,
week or month in a timelinel format, with the date and time listed across the window and
resources listed down. The bookings appear as horizontal bars representing the time they
occur. If the System Administrator 162 has chosen to allow bookings that cross midnight 159 , the
horizontal format can also display bookings for a quarter or year.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Color Source

Drop-down list to select whether the colors of the booking, client or
booking status are used in the display.

Display
Automaticall
y

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Client

Time Scale

Display button to show the schedule.

The client to be displayed. Click the
existing clients.

button to select from a table of

The client to be displayed. Click the
existing clients.

button to select from a table of

Date

A date in the period you want to display.

Text

The text to be shown in the booked time slots. You can choose among
showing no text, the booking name, the client's name, or the first six
letters of the booking and the resource in the remaining space.

Begin

Start of the workday. Bookings that occur before this time are not shown.

End

End of the workday. Bookings that occur after this time are not shown

Height

You can change the height of the rows shown.
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Font

Select the font you want for the text by clicking the

button

To view or change the details of a booking, double click the bar representing the booking.
To add a new booking, click the Add button or double click on the empty time slot you want.
The Add/Update Booking 76 window will appear with as much information entered as can be
determined from the time slot you selected.
You can also drag an existing booking to another time slot. The Add/Update Booking window
will appear and display the existing booking, but with the new date information. Confirm by
clicking the OK button. In this window, the start time is not automatically changed when an
existing booking is moved to another time slot.
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4.6.13 Category Timeline Schedule Window
The Category Timeline window displays all bookings 159 for one category for a specified day,
week or month. Time slots are listed across the window, with resources listed down. You can
view or change the complete booking information by double clicking the box.
The settings entered at the top of the window control the display. Initial settings are taken
from Schedule settings in the Update User Preferences 147 window. If you change the
settings, your new settings will be saved for your next session.
Click the

Display button to display the schedule.

Color Source

Drop-down list to select whether the colors of the booking, client or
booking status are used in the display.

Display
Automatically

If turned on, when this window opens the schedule will automatically be
displayed using the last settings used. When any of those settings are
changed, the window will refresh the display. If turned off, you must use
the

Category

Display button to show the schedule.

The category 159 to be displayed. Enter the name of category or click the
button to select from a table of existing categories.

Time Scale

Choose a time period from the options.

Date

A date in the period you want to display. Enter the date directly or click
the

button to call a look-up calendar for selecting the date.

Begin/End

Beginning and end of the workday you wish to view. Bookings that start
and end outside the workday are not shown

Text

The text to be shown in the booked time slots. You can choose among
showing no text, the booking name, the client's name, or the first six
letters of the booking and use the remaining space for the client's name.

Height

You can change the height of the rows.

Font

Select the font you want for the text by clicking the

button
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4.7

User Administration Windows

4.7.1

Add/Update User Window
System administrators 162 use the Add/Update User window is used to add new users 24 to
ResSched or administer access for existing users. It is called only from the Browse Users Single Select 137 window

GENERAL TAB
User Name

A unique user identifier, up to 80 characters long.

Last Name

The last name of the person, up to 20 characters.

First Name

The first name of the person, up to 20 characters.

Department

The department or organization where the user works. Up to 40
characters.

Password

The user's password is displayed as '*'s. Up to 10 characters long, it must
be entered exactly the same way twice.

Access Level

Radio buttons that assign the user's access level.

View 163
User may only view bookings and resource information for which they have
(Read
been authorized. The lowest level of access.
Only) user
Reserv e
User 161

Like a general user, a reserve user can book resources they have been
approved for, but they can only book with one status level. The status
level and associated colors are set in System Settings 141 . Reserve users
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cannot modify their bookings after they have been confirmed by a resource
or system administrator, but they can delete them.
General
User 160

Users may book resources if they have been approved to do so by a
Resource Administrator or System Administrator.

Resource

User may add or change resource, resource group, client, or category
information, including which users may book or view which resources.

161

Adm inistr
ator

System 162 User can add or change users and access rights, resources, program
Adm inistr defaults and settings. The highest level of access. System administrators
ator
do not need further authority to book or view resources, or to use groups
so authorizing tabs and check boxes are disabled.

Suspended for too
many password
failures

If users have exceeded the maximum number of password failures,
their access is suspended, and this box is checked.

Authorized to book
all resources

Authorize this general or reserve user to book any resource. When
checked, the 'Authorize to view all resources' check box as well as the
'Book resources' and 'View resources' tabs are disabled because any
entries would be redundant.

Authorized to view
all resources

This check box is enabled for general, reserve and view only user.
When checked, it disables the 'View resources' tab.

Authorized to use
Allows this general, reserve, or view only user to use all the resource
all resource groups groups. The right to use a resource group does not in any affect the
user's rights to view or book the resources in a group. When checked,
the Resource Groups tab is disabled.

NOTES TAB
Free-form text for comments on this user account.

BOOK RESOURCES TAB
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This tab lists all the resources a general or user is authorized to book. This tab mirrors the list
of users shown Who can Book tab of the Add/Update Resource window 88 .
Add

Calls the Browse Resources - Multiple Select
resources for the list.

Delete

Removes a selected resource

161

92

window to choose the

from the list.

Adds all the resources in a resource group 161 to the list.
Add resource
group
Delete
resource group

Deletes all the resources in a resource group from the list.

VIEW RESOURCES TAB
Same as the Book Resources Tab, but establishes the users right to view the bookings of the
selected resources. Applies to view only, reserve, and general users. If a user has authority
to book a resource, they have authority to view the resource's bookings without being listed
here. This tab mirrors the list of users shown Who can View tab of the Add/Update Resource
window 88 .

GROUPS TAB
The list of resource groups the user can use. The user's rights to book or view the resources
of the group are controlled by the Book Resources and View Resources tabs. So, while this
user can display a schedule of the ROOMS group, the schedule will include only those
resources in the ROOMS group that the user has authority to view.
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The
Add button calls the Browse Group Multiple Select 100 window to choose the resource
groups for the list. The
Delete button removes the selected resource group from the list.
This tab mirrors the list of users in the Users tab of the Add/Update Resource Group window
97

4.7.2

Browse Users - Single Select Window
This window is available only to System Administrators

162 .

The Browse Users - Single Select window is used to display all users 24 entered in ResSched
and to access the Add/Update Users 134 window for changing user information and access
rights. This window is called from File>Users>Add/Edit Users in the main menu.
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LIST BOX
User Name

The name (User ID) that ResSched is to use for that user.

Last/First
Names

The user's actual last and first names.

Department

The department or organization where the user works.

Access

The user's access level (System Administrator - 4; Resource Administrator 161
- 3; General User 160 - 2; Reserve User 161 - 1; View Only 163 User - 0)

Suspended

A 1 in this column indicates the user's id has been suspended because of
too many failed attempts to enter the correct password.

TABS
By User Name

All users are listed by their user name (ID) in alphabetical order.

By Last Name

All users are listed by their actual last name in alphabetical order.

By Department All users are listed by their actual last name in alphabetical order.
By Access
Level

All users are listed by their access rights, from greatest access authority
(System Administrator) to least (View Only).

BUTTONS
Add
Open

Delete

Calls the Add/Update User 134 window to add a new user.
View or change the information and access rights of a user. Clicking this
button calls the Add/Update User 134 window with the details for the
highlighted user.
Deletes the highlighted user (after confirmation).

At the bottom of the window, the current license configuration and the number and type of
user names currently entered in ResSched are shown.

4.7.3

Browse Users - Multiple Select Window
The Browse Users - Multiple Select window is used to select general 160 , reserve 161 , or view
only 163 users. It is use to authorize users for resources 161 , resource groups 161 , or to make
them part of user groups 163 . Only Resource Administrators 161 and System Administrators 162
can use this window. When called to select which users can book a resource, the list is limited
to general and reserve users. Otherwise, general, reserve, and view only users are included.
Several users can be selected at one time. You select users by clicking on each. After selecting
the desired users, click the OK button to add them to the list of users for the resource or
group.
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LIST BOX
User Name

A unique name, up to 80 characters, which ResSched uses to identify each
user.

Last Name

The last name (optional) of the user.

First Name

The first name (optional) of the user.

Department

The user's department.

BUTTONS

4.7.4

Select All

Selects all the users in the list.

Clear All

Deselects all the users that have been selected so far.

Add/Update User Group Window
The window allows system administrators 162 to create or update User Groups
is called from the Browse User Groups 140 Window.

163 .

This window

User Group

The name of a new user group or the name of an existing one. The name of a
user group (up to 15 characters) must be unique.

Users in
Group

A list box that displays all users currently in this user group.

Add User

Calls the Browse General Users - Multiple Select 138 window to let you select
another user to add to the user group.

140
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Delete User

4.7.5

Removes the highlighted user from the user group.

Browse User Groups Window
The Browse User Groups window lets system admimistrators 162 create, change, or delete
user groups 163 , and lets resource administrators 161 select user groups. It is called from
File>Users>User Groups on the main menu or from the Add/Update Resource 88 window
The window contains a list box displaying all existing user groups

163 .

Select

Selects the highlighted user group (only visible the window is being used to
select a user group).

Add

Calls the Add/Update User Group 139 window to create a new user group.

Open

Call sthe Add/Update User Group window to view or modify the highlighted
user group.

Delete

Deletes the highlighted user group.
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Settings and Preferences Windows

4.8.1

Update System Settings Window
The Update System Settings window is available only to System Administrators
The window allows them to:

141

162

1.set several options and values for administering and maintaining ResSched;
2.set the default values for User Preferences for new users;
3.reset the User Preferences of all users to the default values; and
4.establish special days 162
It is called by File>System Settings from the main menu.

GENERAL TAB

Primary
Disallow
resource
conflicts

If ResSched should not permit general users 160 to double book resources,
check this box. Resource 161 and System Administrators can still choose to
double book the resource.
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Check for
client conflicts

ResSched will alert the user any time a booking will cause a client to be
double booked. Useful when a client is an individual.

Client required Every booking must have a client entry, even if it is just 'No Client'.
for all
bookings
Lock bookings

If ResSched should lock 160 new bookings as a default, check this box.

Enable actual
times

If you wish to collect the actual times 159 a resource is used, as well as when
it is scheduled, check this box.

Allow private
bookings

This feature allows users to make bookings that only they can see.

Optimize for
many
resources

If bookings 159 will be spread over many resources 161 , check this box. If
bookings are concentrated on just a few resources, leave this box
unchecked. The precise point at which ResSched should be optimized for
many resources varies from organization to organization and over time, so
some experimenting is useful.

Cache
resource data
on startup

When this box is checked, resource data will be cached when a user starts
ResSched. Caching improves the program performance, but because the
cache is loaded on startup, changes made to the resource data by Resource
or System Administrators will not show up until ResSched is restarted.
Booking information is not never cached, however, so resource availability
and conflict checking are not affected by caching. Caching resources is
particularly useful if an organization wants to limit those users who can view
or book certain resources, or use color to designate resources.

Cache client
When this box is checked, client data will be cached. This improves the
data on startup program response rate, but changes to client data will not be visible until
ResSched is restarted. Do not use caching if you routinely add or change
client information (other than bookings) more frequently than your users
start ResSched.
Many, variable
clients

If you have large numbers of clients (> 1000) and must change the client list
too often to use the Cache Client option, check this box. This option gives
good performance browsing large client lists using the locator, but the
vertical scroll bar is less functional.

Bookings can
cross midnight

If you have booking occurrences that start on one calendar day and end on
another, such as for shift work or equipment operations, check this box.
When turned on, you will need to enter an end date as well as an end time
for each booking. If you check this box, you must specify the maximum
number of days in a single occurrence of a booking. The larger the
number of maximum days, the more work ResSched must do for conflict
checking and schedule views, so keep it to the minimum required.
With this option checked, ResSched will consider occurrences as running 24
hours a day/7 days a week from the start time on the start date until the
end time on the end date. If you just wish to book a resource during for
business hours for several days in a row, you should use repeat bookings
161 instead of this feature.

Maximum days This spin box limits how many days in advance that users can book
in advance
resources. If set to 0, there is no limit on how far in the future users can
book resources.

General and reserve users
Allow general
users to add
clients

If general users should be able to add new clients to ResSched, check this
box. Otherwise, only System and Resource Administrators can add clients.

Allow general

If general users should be able to add new categories

159

check this box.
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users to add
categories

Otherwise, only System and Resource Administrators can add categories.

Status used by
reserve user

A reserve user 161 is limited to making bookings with only one status. You
must select that status from the existing list of statuses available. Go to
the Status Colors tab to add a new status or change an existing status and
its colors.

Reserve users
can only view
their own
bookings

The reserve user can see the booking details of only their own bookings.

Reserve user
is the client

If the booking is created by a reserve user that user's user name is always
used as the client.

Display week
from

A System Administrator can choose which day of the week is defined as the
start day. Once this selection is made, all Schedule windows and printed
schedules will start with this day.

Alert

ResSched can automatically alert users to forthcoming bookings. By
selecting All from the radio buttons, all users will be alerted to any
forthcoming bookings. User Only will alert only the user who made the
booking. For either of these selections, the lead time between the alert and
the booking must be entered in minutes. Selecting None disables the alert
function.
Alerts query the database on behalf of the user at intervals that are onesixth the lead time. For example, if the lead time is set for 20 minutes, the
database will be queried for forthcoming bookings by each logged-on user
every 3.33 minutes. With large numbers of users logged on and short lead
times, these queries can be a noticeable burden on the network if you are
using the Standard Edition or Local version of the Corporate Edition. If you
do not need these alerts, it is best to leave them disabled.
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USER SETTINGS TAB

Users can set their own default and routine entries, schedule display settings and other
default settings. ResSched uses the values in System Settings as the initial settings for each
new user and lets System Administrators reset all users' preferences to common values.
Default and routine entries
Default and routine entry values are used to speed up the booking entry process for users.
When making a new booking, the default values are automatically displayed and the routine
values are available from drop-down lists. Users can accept or change any of these values
when making a booking.
Start time

The time that is initially displayed when creating a booking. Set the default
start time either near the middle of the active part of your organization's day
or close to the time when many bookings are scheduled. The default start
time is displayed in your Windows time format, but you can use any
standard time format to enter it.

Duration

The default duration is added to the start time to display a proposed end
time. If many of your bookings are for the same length of time, this feature
saves having to enter that information numerous times. Use the Hours:
Minutes format to enter the default duration or click the Down Arrow button
to select a duration from the drop-down list.

Routine
durations

A list of commonly used duration times that can be selected from drop-down
lists when booking resources. To change the list, click this button. The
current list will appear to which you can add a new duration (Add button), or
change or delete an existing routine duration. Users can add their own
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routine durations to this system wide list.
Booking

If many of your bookings are the same type, you may wish to enter a default
booking which will be automatically displayed when creating a new booking.
Enter the default booking name manually or choose from any existing
routine bookings from the drop list.

Routine
bookings

Click this button to create or edit a list of routine booking 161 names that can
be selected from a drop-down list when making a new booking. It calls the
bookingsthe list of current routine bookins you can add to or change The
current list of routine bookings will appear, to which you can add others by
clicking the Add button, or you can change or delete one of the existing
routine bookings. Users can add their own routine bookings to this systemwide list.

Client

If one client represents a significant number of bookings, you may wish to
make that client the default. Click the Down Arrow button to select a client
as the default. If you expect to make many bookings without any client,
consider selecting 'No Client' as the default client.

Resource

If one resource is being booked a significant portion of the time, you may
wish to make that resource the default. Click the Down Arrow button to
select a resource as the default. Once selected as default, a resource will be
placed in the resource list for every new booking.

Category

If one category represents a significant number of bookings, you may wish
to make that category the default. Click the Down Arrow button to select a
category as the default.

Schedule display settings
Schedule settings are the initial values used when a Schedule window is opened. ResSched
also uses some of this information to create drop-down lists for selecting start and end times
when adding bookings.
Begin work day The normal start of the work day for your organization. Bookings that occur
before this time are shown as 'Before' this time.
End work day

The normal end of the work day in your organization. Bookings that occur
after this time are shown as 'After' this time.

Interval

The amount of time you wish to cover with one time slot when using
schedules. With large intervals, schedules take less space on the screen or
paper, but booking information often overlaps. Small intervals provide better
distinction between bookings, but take up more screen and paper space.

Width

The width of each column in the schedule. Narrower columns let you fit more
resources on a page, but reduce the amount of text shown in booked time
slots.

Height

The height of each row in the schedules. Short rows let you see more time
slots, but may be difficult to read.

Text

The text to be shown in the booked time slots of schedules. You can choose
among showing no text, the booking name, the client's name, or the first
three letters of the booking, and use the remaining space for the client's
name.

Background
color

calls a
color selection window and No color restores the default Windows background
color.
Users can choose the background color of their schedules. The
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Default
Settings
Notify when
booking...

Two check boxes are available for checking whether the user should be
notified if a booking involves a weekend or is outside the normal work day.
The Weekend check box also controls whether printed week schedules
cover 5 or 7 days.

Browse Period

To use the Browse Bookings window 79 , the user must specify both a start
and end date. When the window opens the current date is shown as the
start date. This entry sets the number of days after the start date that is
shown for the end date. The user can change the proposed start and end
dates before generating the Browse.

Apply to Existing Users Button
Resets the User Preferences values of all existing users to those shown on this tab.

SPECIAL DAYS TAB
Special days are those days that you wish to be treated differently when scheduling
bookings. Religious or civic holidays and vacations are possible special days periods. Once you
identify a special days period, you will be notified of a possible conflict before bookings are
scheduled in that period. The special days list box includes start and end dates and a
description for the period.
Add

Calls the Add/Update Special Day Period 149 window for you to enter the
information for the special day period.

Open

For the selected special day period, calls the Add/Update Special Day
Period window for you to edit.

Delete

Deletes the selected special day period.

Add File

Lets you add five years of public holidays to ResSched as special days. See:
Special Days, Set 72 .

SECURITY and MAINTENANCE TAB
Use network
user name

If this login box is checked, ResSched will automatically fill in the user's
network login in the User Name field when ResSched starts up. Each
network user name must be added to ResSched's list of users before this
function will work.

Skip Password

If Use Network User Name has been turned on, this option is enabled. If
turned on, ResSched assumes that a user who is properly logged on to the
network is also the ResSched user in question and will not have to log in to
ResSched.

Save user name Each time ResSched is started, the user name of the last user to use
between
ResSched on the workstation will entered for log in. The user must still
sessions
enter the right password. This function is disabled if Use network user
name is turned on.
Login Tries

The maximum number of consecutive failed attempts to enter a password
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that ResSched will allow before suspending the user's access. If this field is
set to 0, there is no limit.

Password
Requirements
Case
sensitiv e

Users must enter the exact case of their passwords.

Mixed case

New passwords must have both upper and lower case characters.

Num bers
required

New passwords must have at least one number.

Allow view only System administrators can allow or disallow view only users from changing
users to change their passwords. Licensees with the unlimited view-only option can should
password
turn this option off if they are using a shared view only user ID.

The Reset Control File button allows technical support staff of Madrigal Soft Tools to quickly
correct certain rarely occurring conditions. Most users will never need to use this button. While
the button is harmless, we recommend you contact Madrigal tech support before using it.

LABELS TAB
You can use your own terms instead of ResSched's standard 'booking,' 'resource', 'client' and
'category.' By entering the singular and plural forms of your terms across from the ResSched
term, users will see your terms in all ResSched windows and reports. The Help system will still
use standard ResSched terms, and the standard terms must be used if you call our technical
support. Users can see the standard terms and their equivalent terms by selecting
Help>ResSched Terms from the main menu.

STATUS
COLORS TAB
The Status and Colors Tab shows the colors associated with each status level and how those
colors look in the Browse and Schedule windows and print out. The Schedule color
selections are the reverse of the foreground/background selections of the Browse windows.
There must always be one status with status number of 0 in the list.

4.8.2

Add

Add a new status to ResSched, using the Add/Update Status Colors 150
Window

Change

Change the color or name of the selected status using the Add/Update
Status Colors.

Delete

Delete the selected status from ResSched.

Update User Preferences Window
ResSched allows individual users 24 to tailor the way information is entered and displayed.
When a new user is created, the initial values for his preferences are taken from the System
Settings. This window is not available to view only users.
To speed up information entry when booking resources 161 , ResSched lets users establish
default and routine values for many of its booking entry fields. When making a new booking 159 ,
the default values are automatically displayed, and the routine values are available from dropdown lists. Users can accept or change any of these values when making a booking. Each user
can maintain his own preference values for these entries, but the initial values for a new user
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are taken from the System Settings. System Administrators 162 can also reset all these
preferences to those in System Settings.

Default start
time

This start time that is initially displayed when creating a booking. Set the
default start time either near the middle of the active part of your
organization's day or close to the time when many bookings are scheduled.
The default start time is displayed in your Windows time format, but you can
use any standard time format to enter it.

Default
duration

The default duration is added to the start time to display a proposed end
Time. If many of your bookings are for the same length of time, this feature
saves having to enter that information. Use the Hours:Minutes format to
enter the default duration or click the Down Arrow button to select a
duration from the drop-down list.

Routine
durations

You can add your own durations to list of routine durations established by
the System Administrator. Routine durations can be selected from dropdown lists when making a booking. This button lets you add or delete your
own routine durations

Default
booking

If many of your bookings have the same name, you can enter a default
booking name which will be automatically displayed when creating a new
booking. Enter the name directly or click the Down Arrow button to select a
booking name from the current list of routine bookings 161 .

Routine
bookings

You can add to the list of routine booking names created by the System
Administrator. Routine bookings can be selected from a drop-down list
when making a new booking. This button calls the A list of your currently
specified routine bookings will appear, to which you can add other bookings
by clicking the Add button, or you can change or delete one of the existing
routine bookings.

Default
resource

If one resource is being used for most bookings, you can make that
resource the default. The default resource will be added automatically to
the list of resources when you start each new booking. Click the Down
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Arrow button to select a resource as the default.

4.8.3

Default client

If one client is used for most bookings you can make that client the default.
The default client will be entered when start a new booking. Click the Down
Arrow button to select a client as the default.

Default
category

If one category is used for most of your bookings you can make that
category the default. The default category will be entered when you start a
new booking. Click the Down Arrow button to select a category as the
default.

Print In Color

Check this box if you want to print schedules in color.

Notify Me
When
Booking ...

When checked, ResSched will warn you when you try to make a booking for
a weekend or outside the normal week day. When weekend is checked,
some schedules will limit the display to days of the work week.

Browse Period

Set the default number of days to be covered in when using the Browse
Bookings window 79

Add/Update Special Day Period Window
The Add/Update Special Day Period window lets you add or change information on your
special days 162 periods. This window is called from the Update System Settings 141 window.

Description
Start Date

End Date

Up to 20 characters to identify this special days period.
The first day of the special days period. If you click the
small calendar
button beside the field, a look-up calendar 160 will appear. Select the date
you desire, then click the OK button, and the date will be automatically
entered into the field.
The last day of the special days period (often the same as the Start Date).
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Add/Update Status Colors Window
The Add/Update Status Colors window lets system administrators 162 add or change booking
statuses and their associated colors. Each status 162 must have a unique number, a name, and
a color. There must always be one status with a level 0.

Use the

button select a new color.
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Printing Related Windows

4.9.1

Automated PDF Schedule Generator
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The Automated PDF Schedule Generator (APSG) is a separate program that automatically
'prints' specified graphical and text schedules as pdf's to a specified location. It is an easy
way to make schedules available on a web server for non-ResSched users or the general
public. The APSG is only available with the Corporate Edition.
For its control windows and PDF file names, the APSG uses ResSched terms (Booking,
Resource, Client, Category) rather than the labels you may have entered in ResSched System
Settings. Your labels are used in the PDF schedules themselves, however. The PDF file name
is created from the Report Type, Entity and Period Repeat.
The APSG must be kept running to generate the pdf's.

Store Schedule PDF's in The location you want to store the schedule pdf's on your web
server.
Refresh Every

How often you want the schedules refreshed on your web server.
The range is every 1 minute to 23 hours 59 minutes.

LIST BOX
Report Type

The type of graphical or text schedule you want send to the web
server, covering a day, week or month.
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Entity

The resource, client, resource group, or category to be covered in
the schedule.

Period Repeats

How many consecutive day, week, or month schedules do you
want sent to the web server with each refresh. For example, to
generate the current and next months' schedules, you would enter
2.

Text Source

What is shown as text in booking blocks of the graphical schedules.
Has no affect on the Text schedules.

Color Source

What the colors of the booking blocks represent in the graphical
schedules. Has no affect on the Text schedules.

BUTTONS

4.9.2

Add

Calls the PDF Schedule Specification 152 window to let you add a
new pdf schedule to the list.

Change

Lets you change the highlighted pdf schedule on the list.

Delete

Deletes the highlighted pdf schedule from the list.

OK

Begin generating the specified pdf schedules.

Close

Stop generating the pdf schedules and close the program.

PDF Schedule Specification
The PDF Schedule Specification window lets you specify which pdf schedules will be will saved
on the web server by the Automated PDF Schedule Generator 151 .
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Select whether you want the schedule to cover a resource, resource group, client or category .
Then select which one you want.

4.9.3

Report
Type

The graphical or text report you want to save and the period it covers.

Period
Repeats

The Period Repeat is the number of period increments starting from the current
date that you want covered in each refresh cycle. For example, you may want
to generate day schedules for today and the next 6 days after. You would have
a period repeat of 7 for that schedule. For a monthly schedule, you may only
want to see the current month and the one after, so the period repeat would be
2.

Rows Per
Day

Some graphical schedules require you to specify how many time slots (rows)
should be shown for a day.

Text
Source

What is shown as text in booking blocks of the graphical schedules. Has no
affect on the Text schedules.

Color
Source

What the colors of the booking blocks represent in the graphical schedules. Has
no affect on the Text schedules.

Setup for Using MS Word® Window
For Corporate License 6 holders, the Setup for Using MS Word® window is used for
selecting whether or not to use MS Word® to generate text-based schedules and reports.
When MS Word® has been specified - by placing a check mark in the Use Microsoft Word for
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documents check box - it will be called whenever the user is printing a text-based document
from ResSched.

Use Microsoft Word
for documents

Click the check box if you are using Word to print your documents.

Register OCX:

This button becomes active after you click the Use Microsoft Word for
documents check box. It is used to register the ResSched/Word ocx file
before Word® can be used for ResSched documents. If the ArcoIntf.ocx
file is not already in the system folder, users will be requested to
locate and select it through a file selection window. Users will be
notified if the registration is successful. This process has to be done
only once for each workstation.

USER GLOBAL SETTINGS TAB
Language

Choose which language is to be used.

Final file format

Choose the file format in which the finished documents are to be
stored.

How will Word® open Choose how Word® will open when work is being done on reports.

Show table grid lines Refers to grid lines being displayed when the document is displayed in
Word®.
Show the document
after processing

Choose whether or not to show the document after processing.
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Print the document

You can print the document automatically without being shown the
document.

Delete the document
after it is printed

You can choose to delete the document after it is printed.

Folder for storing
documents

Users must also specify where the document files should be held. This
is especially important if a user has chosen not to delete the
documents after printing.

DOCUMENT TEMPLATES TAB
For each text-based schedule or report, a user must specify a template file and a style sheet
file. A look-up button beside each entry can be used to select the appropriate file. While there
are only 10 basic schedules and reports, most may cover more than one type of entity or
period. Before Word® is called to generate the schedule or report, a user will have already
used the relevant window to specify the entity and period to be covered.

Folder for templates

The folder that has the WORD templates and the style sheet. This is
usually the a sub folder of the folder you installed the ResSched
program files into. C:\ResSched\Corporate\Word Templates is the
default location.

Booking

Detailed information on one booking.

Browse bookings

The equivalent to the main table displayed in the Browse Bookings 79
window. Actual coverage and period are determined by the user's prior
selections in the Browse Bookings window.

Day schedule

Detailed bookings for one day in chronological order. Actual coverage
and day are determined by the user's prior selections in the Print Text
Calendars 156 window.

Week schedule

Same as Day Schedule, but covering the period of one week.

Flexible period

Summary booking information for a period determined by user.
Coverage and period are determined in the Print Text Calendars
window.

Day by resource

Detailed bookings for one day grouped by resource. Covers either all
resources or those of a group. Coverage and day are determined by
the user's prior selections in the Calendar Options window.

Resource list

A detailed list of all resources or only those in a resource group.
Coverage is determined by the user's selection in the Browse
Resources 92 window.

Client list

A detailed list of clients. Called from the Browse Clients

Resource utilization

Resource use for a period and a resource specified in the Resource
Utilization 94 window.

Group utilization

Resource group use for a period and a resource group specified in the
Resource Group Utilization 102 window.

Client invoice

Invoice for client's use of resources in a specified period.

105

window.
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After settings are entered, ResSched will call Word® whenever a user selects a text-based
report or schedule to be printed.

See: Using MS Word with ResSched

4.9.4

46

Print Text Calendars Window
The Print Text Calendars window provides you with several additional text schedules beyond
that provide by the printing from the Browse Bookings 79 window. It is called directly by
Calendar from the main menu.

Period/Format

A drop-down list that lets you select the format and period length of
your calendar. You can choose from:

Day

Bookings 159 scheduled for the start date are listed from earliest to
latest.

Day by
Resources

Each resource 161 's bookings scheduled for the start date are grouped
together and then listed from earliest to latest.

Week

A week's bookings with full details are listed from earliest to latest in
portrait orientation. Weekly calendars cover the Monday to Sunday
period that includes the start date.

Week in Day

A week's bookings, arranged by day for each resource
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Columns
Flexible
Period
Covering

The flexible period lets you set any start and end dates for the
calendar to cover. This format will not print booking notes.
Radio buttons that let you select whether to include the bookings of:
all resources; one resource; a resource group; a client 159 , or a
category. If you select One Resource, Group, Client or Category, a
separate field will appear for you to enter the name of the resource,
resource group or client.

All Resources

Include all resources entered in ResSched.

One Resource

Clicking this option will print the bookings of only one resource. A
separate Resource field is visible if this option has been selected.
Clicking the Down Arrow button calls the Browse Resources 90
window for making a selection.

Resource
Group

Clicking this option will print the bookings of only one resource group.
A separate Resource Group field is visible if this option has been
selected. Clicking the Down Arrow button calls the Browse Resource
Groups 99 window for making a selection.

Client

Clicking this option will print the bookings of only one client. A
separate Client field is visible if this option has been selected. Clicking
the Down Arrow button calls the Browse Clients 105 window for
making a selection.

Category

Clicking this option will print the bookings of only one category. A
separate Category field is visible if this option has been selected.
Clicking the Down Arrow button calls the Browse Categories 111
window for making a selection.

Start Date

When the Day option is chosen, the bookings scheduled for a date
entered here will be printed. The Week option will include this date.
The Flexible Period option begins with this date and an End Date
must also be entered. The current date is the default. If you click the
Calendar button beside the field, a look-up calendar will appear.
Double click the date you want and it will be automatically entered into
the field.

End Date

If you select 'Flexible Period', you must enter an end date for the
period the same way you enter the start date.

Include Notes

Includes any with the booking.

Include Category

Includes the category, if any, for the booking

Include Client
Detail

Includes the contact information and notes for the client with the
booking

Preview

Checking this box indicates that the calendar is to be displayed on
screen before being printed

If you have chosen to use Microsoft Word®
generated using Word®.

46

to print reports, your documents will be

Click the Print button to print the calendar. If the Preview check box has been checked, you
will be able to make choices regarding the pages to be printed, their configuration, the number
of copies to be printed, and some zoom options for previewing.
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Report Preview Window
The Report Preview window displays an image of the report or schedule you have requested.
The window also gives you options for dealing with the report. The Print Preview does not
appear if you have chosen to use MS Word ® to generate text schedules or reports, or if you
have left Preview unchecked in the Print Text Calendars 156 window.

Print

Print the schedule/report. Alternatively, you may click File>Print. You can
also select which pages to print by clicking File>Pages to Print or the
spin buttons in the Page box.

Exit

Exit without printing. Alternatively, choose File>Exit

Zoom

Click this button to obtain various views of the report before printing.

Tile Pages
Page
Width
Zoom

Displays pages tiled across the window. If you prefer to tile them down
the window, click the spin button in the Down box.
Fills the width of the window with the report.

Choose whichever view you desire from the choices of 50%, 75%, 100%,
200% and 300%

Save as pdf

Save this schedule/report as a pdf document. Alternatively, choose
File>Save as pdf.

E-mail as pdf

Save this schedule/report as a pdf document and then call the default email client.(Note: To ensure compatibility with the maximum number of
potential e-mail clients, the pdf is not automatically attached to the
message). Alternatively, choose File>Email as pdf.

You can also choose how many copies you want to print.

Definitions and Terms
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Definitions and Terms
Definitions

5.1.1

Actual Times

5
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Actual Times
The actual start and end times of a booking 159 , rather than the scheduled times.

5.1.2

Booking
Booking
Any event that you want to schedule with ResSched. A booking consists of a booking name, a
start time, an end time, at least one date and at least one resource. Bookings can be Single
(occur only once) or Repeated (occur more than once).

5.1.3

Bookings That Cross Midnight
Bookings that Cross Midnight
For most organizations, booking occurrences start and end on the same calendar day.
For organizations that run 24 hours a day or book resources for several continuous days
or weeks, the System Settings 69 must be set to allow booking occurrences to cross
midnight. ResSched treats such bookings as running 24 hours a day/7 days a week from
the start time to end time. Bookings that have several occurrences on different days (e.
g., 9:00AM to 4:00PM Monday, Tuesday, Wednesday) do not need the cross midnight
setting on. Turning this setting on will require users to enter an end date for every
booking and make some views and reports more cluttered, so it should be left off if not
needed.

5.1.4

Browse
Browse
Scroll through a list of bookings 159 , resources 161 , or groups. Depending on the function that
you are browsing, you can select, add, change or delete items from the list.

5.1.5

Category
Category
A category is a user-specified collection of bookings. The ability to create categories can
facilitate production scheduling or large event planning. After a system 162 or resource
administrator 161 has created a category, users can add new or existing bookings to the
category. Then, users can limit browsing or schedules to only those bookings associated with
that category.

5.1.6

Charge Rate
Charge Rate
The rent, charge out rate, usage fee or other fee charged for the use of the resource.
The charge rate is based on periods ranging from a minute to a day.

5.1.7

Client
Client
The person or organization for whom the resources

5.1.8

161

are being booked.

Colors
Colors
Foreground and background colors may be assigned to types of bookings, resources, clients,
and booking status. These colors are system wide and can be set only by System
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Administrators or Resource Administrators.

5.1.9

Combination Group
Combination Group
A combination group is temporary resource group made up of the resources that are either
select individually by the user or created from two or more existing resource groups. You can
use combination groups to filter bookings by multiple resource criteria, or to view schedules of
several groups at one.

5.1.10 Date
Date
Every booking must be scheduled for at least one date. When selecting a booking 159 that has
more than one date, be sure to get the right date. Otherwise, when you change the booking
information, the changes will be applied to the wrong dates.

5.1.11 Date Format
Date Format
ResSched uses the date format you have chosen in Windows Control Panel.

5.1.12 Default
Default
Initial values that are entered automatically at the start of different ResSched functions.
These initial values are usually set in the System Settings 141 or User Preferences 147 . The
values can be changed by user when they are using the different ResSched functions.

5.1.13 General Users
General Users
A user with access rights to book resources. General users must be approved for booking all
resources or just specified resources.

5.1.14 Inactive
Inactive
If a System or Resource Administrator marks a client or resource as inactive, the client or
resource is no longer available for bookings.
When a user marks a booking as inactive, the resources involved are booked for the period,
but the booking itself does not appear in any of the utilization or invoicing functions and only
in Browse Bookings 79 if requested. It does appear in graphical schedules. This is a handy
way to indicate that a resource is unavailable for a period such as for scheduled maintenance
or vacation.

5.1.15 Lock
Lock
When users make a booking, they can lock the booking so other general users cannot change
or delete it. Both Resource 161 and System administrators 162 can override a booking lock.

5.1.16 Look-up Calendar
Look-up Calendar
ResSched includes a small look-up calendar to help you enter dates quickly and accurately. The
look-up calendar is accessed by clicking the small Calendar button
beside date entry fields.
Double clicking a date or clicking the date and then clicking the OK button will enter the date in
the original date field.

Definitions and Terms

161

5.1.17 Pooled Resource
Pooled Resource
A pooled resource comprises indistinguishable units that are not separately identified. Several
units of the resource can be booked at the same time. For example, a conference center may
have many folding tables. The person who schedules the use of these tables may not be
concerned about which tables go into which meeting rooms, but would want to know that the
inventory of folding tables is not over booked at any time.

5.1.18 Primary Resource
Primary Resource
A primary resource is usually the main resource for a booking. For example, a meeting room
would normally be treated as a primary resource, while the chairs, tables and other items in
the room would be designated as other resources for the booking.

5.1.19 Private Booking
Private Booking
A private booking is one that can be viewed only by the person who made the booking.

5.1.20 Repeats
Repeats
Repeats are multiple occurrences of the same booking 159 on different days. Repeats can be
regular (there are five options for automatically scheduling regular repeats) or irregular (you
must select each repeat yourself).

5.1.21 Reserve User
Reserve User
Like General Users 160 , Reserve Users can book authorized resources but they are limited to
only one status. They can also be restricted from seeing the detail of any bookings made by
others. By limiting the reserve user to a single status, Resource Administrators can see at a
glance which reservations need to be confirmed.

5.1.22 Resource Administrator
Resource Administrator
A user with special access rights and responsibilities for determining which resources are to be
included by ResSched and who can book them.

5.1.23 Resource Groups
Resource Groups
A resource group is a list of some of the resources 161 entered in ResSched. A resource group
can be used to quickly schedule several resources for the same booking 159 or view the
schedules of a set of resources.

5.1.24 Resources
Resources
The equipment, space, people, etc. being booked. Up to 30 characters are allowed for the
name of resource, and each name must be unique.

5.1.25 Routine Bookings
Routine Bookings
A list commonly used booking names that users can pick from a drop list instead of having to
enter manually. Only System Administrators can create routine bookings that are used system
wide. Individual users can add to this list, but these additions will be available only to that
user.
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5.1.26 Schedules
Schedules
Schedules that represent bookings graphically. It most cases, the size and position of booking
boxes represents dates and times, while color and text can convey other information about the
booking.

5.1.27 Special Days
Special Days
Special days are those periods that you want scheduled differently from ordinary days.
Religious or civic holidays, vacations, and school breaks are all examples of possible special
days. When you try to schedule a booking 159 on a special day, the Booking Conflicts 86
window appears to notify you of the special day period.

5.1.28 Status
Status
Every booking 159 has a status. A status has a name, level, and color associated with it.
Status color can be shown in graphic schedules and text listings.System administrators
162 can add, change, or delete status details in System Settings 141 .

5.1.29 System Administrator
System Administrator
System Administrators have the highest user access. They can add and change users and their
access levels, as well as determining defaults and settings controlling how ResSched works.

5.1.30 Time Format
Time Format
ResSched will display time in whatever format you have chosen in Windows Control Panel.

5.1.31 Timeline vs Vertical Display Format
Timeline vs Vertical Display Layout
ResSched lets users choose whether they want to view graphical schedules in vertical
(resources across the top; date/time down), timeline (resources down the left of the window;
time across the top), calendar (standard monthly calendar). While the choice is largely a
matter of user preference, there are important functional differences.
The vertical format can usually provide more space for booking descriptions, but does not
display double bookings or bookings of pooled resources 161 well. The timeline format displays
these types of bookings well, but there is often less space available for text descriptions of the
booking. The calendar format is not suitable if there are large numbers of bookings on any
day.
The toolbar 25 buttons that call a schedule have a vertical, timeline, or calendar layout. The
buttons use the last selection you made using the Schedules menu in the main menu.

5.1.32 Update Access Users
Update Access Users and View Only Users
ResSched is licensed according to the number of update access users using it.
An update access user is any person who can change any information in ResSched. Each
update access user has his or her own user ID and password. The term 'update access user' in
license and ordering documentation refers to the number of user IDs with update access in
total, not the number using it at any one moment (concurrent users).
View only users, as the name implies, can only see and print the information in ResSched.
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Organizations have the option of purchasing a license for an unlimited number of view only
users for a small fee.

5.1.33 User Groups
User Groups
A list of general 160 , reserve 161 or view only 163 users. User groups are used by Resource and
System administrators to give or remove authority to book specific resources for several users
at one time.

5.1.34 View-only User
View only user
A user who is only allowed to view or print information in ResSched.

164

ResSched 9.9

Index
-%% days used 94, 102
% hours used 94, 102

-** symbol

51

-224 hour operations

141, 159

-AAccept conflicts 54
Access level of Users 74, 134, 137
Access rights for resources 74
Actual Times 76
Definition 159
Enable entering actual times as w ell as scheduled.
Use in utilization 94, 102
Add
Booking(s) 49, 50, 76, 79
Categories 57, 111
Client(s) 58, 104, 105
Documents to a Booking 52, 84
Files/URLs to a Booking 52
Pooled Resource 62
Resource Group(s) 64, 97, 99
Resource(s) 60, 62, 88
Resources to a Resource Group 60
Routine Booking(s) 70, 83
Routine Duration(s) 70
User Group(s) 75, 139, 140
User(s) 74, 134, 137
Add/Update Booking Status Colors 150
Add/Update Booking w indow
49, 76
Add/Update Category w indow
111
Add/Update Client w indow
104
Add/Update Resource Group w indow
97
Add/Update Resource w indow
88
Add/Update Special Day Period w indow
149
Add/Update User Group w indow
139
Add/Update Users w indow
134
Alerts 141
Set 69
Associated File 84
Authorized users to book/view resources 88
Automated PDF Schedule Generator 151
Availability of Pooled Resource 126

-BBackup
Set hours betw een internal backup 141
Backup Data 33
Begin Work Day 141, 147
Booking Conflict w indow
54, 147
Booking(s) 76, 79, 83, 159
Add 49, 76, 79
Add Document Files or URL's to 52

141

Add Documents to 84
Add repeat 50
Add Routine 70
Brow se 52, 79
Brow se Alphabetically by Name 81
Change 50, 76, 79
Change repeat 51
Conflicts 54, 86, 162
Default 141
Definitiion 159
Delete 51, 76, 79, 83
E-mail 50, 76
Inactive 160
Lock 54, 76, 141, 160
Log 85
Make private 55
Maximum days in advance 141
Print 44
Print single 52
Private 161
Purge Old 83
Repeat 76, 161
Routine 55, 83, 161
Status 76, 150
Stop Other Users From Changing 54
That go past midnight 159
That run continuously over several days 159
View
79
View graphical schedules 53
View transactions 85
Brow se 79, 81, 90, 99, 105, 111, 137, 138, 140
Booking(s) 52
Categories 57
Definition 159
Resource(s) 61
Routine Booking(s) 83
Brow se Bookings Alphabetically w indow
Booking(s) 81
Brow se Bookings w indow
Booking(s) 79
Brow se Categories Window
Categories 111
Brow se Clients Window
Client(s) 105
Brow se Resource Groups - Multiple Select Window
Brow se Resource Groups w indow
Resource Group(s) 99
Brow se Resources - Multiple Select w indow
92
Brow se Resources - Single Select w indow
Resource(s) 90
Brow se User Groups w indow
139
User Group(s) 140
Brow se Users - Multiple Select w indow
User(s) 138
Brow se Users - Single Select w indow
User(s) 137

100

-CCalendar 119, 124, 129
Calendar Look Up 160
Calendar Options w indow

156

Copyright 1997-2013, MadrigalSoft Tools Inc.

Index
Calendars
Print 44
Cannot Connect to Server message 11
Categories 111
Add 57, 111
Brow se 57, 111
Brow se Bookings of a Category 52
Change 111
Definition 159
Delete 57
Set Default 70
Timeline Schedule 133
Category Timeline Schedule w indow
133
Change
Booking(s) 49, 50, 76, 79
Categories 111
Client(s) 58, 104, 105
Labels 69
Passw ord 69
Resource Group(s) 65, 97, 99
Resource(s) 61
Routine Booking(s) 83
Start and End of Work day used in schedules 72
Start and end times of w ork day for schedules 71
User Group(s) 139, 140
User Preferences 69
User(s) 74, 134, 137
Change IP Address 37
Change server settings 18
Change server time out 18
Charge out rate 62, 159
Client
Brow se Bookings of a Client 52
Client Month Schedule w indow (calendar) 129
Client Week Schedule w indow
127
Client(s) 76, 104, 105
Add 58, 104, 105
Allow general users to add 141
Brow se 105
Change 58, 104, 105
Check for conflicts 58
Create invoice for 58
Default 141
Definition 159
Delete 59
Delete Multiple 109
Inactive 160
Invoice 107
Make temporarily unavailable 59
Month Schedule (calendar) 129
Notes 104
Reserve user name used for 141
Set Default 70
Timeline Schedule 131
Utilization 59, 106
View Utilization 59
Week Schedule (vertical) 127
Color
Status 162
Colors
Associate w ith status 150
Copyright 1997-2013, MadrigalSoft Tools Inc.

category 141
Print using 69
Use w ith Routine Booking(s) 83
Column w idth used in schedules 72
Combiantion Groups 62, 66
Combination Groups 61, 100, 160
Conflict checking
Clients 58
Conflicts 162
Accepting 54
Booking(s) 86
Dealing w ith 54
Default 141
Disallow
141
View
82
Connection Failed Message 16
Converting data from older versions 21
Corporate Edition 6
Criteria 61, 160
Filter by 66

-DData
Backup 33
Converting from older versions 21
Import client and resource data 42
Use in other programs (ODBC) 41
Data sets
multiple 38
Date 160
Date format 160
Day
Resource Group Schedule (timeline)
Resource Group Schedule (vertical)
Default
Booking 70, 141
Category 70, 141
Client 70, 141
Conflicts 141
Duration 70, 141
Entries 70
Resource 70, 141
Start Time 70, 141
Default Booking 147
Default Category 147
Default Client 147
Default Duration 147
Default Resource 147
Default Start Time 147
Delete
Booking(s) 51, 76, 79, 83
Categories 57
Client(s) 59, 104, 109
Resource Group(s) 65, 99
Resource(s) 61, 90
User Group(s) 139, 140
Display schedules graphically 53
Documents 84
Add to a Booking 52
Double booking resources 54, 86

113
114

165

166

ResSched 9.9

Dow ntime 55
Duration 76
Default for bookings
Set Default 70
Duration(s)
Add Routine 70

Change 69
Layout of Schedules Vertical and Timeline
Layout used by tool bar Schedule buttons
Change 40, 73
License 4, 6, 162
Licensing ResSched 7, 34
Lock Booking(s) 54, 76, 141, 160
Log
Booking(s), View
85
Purge Booking Log 87
Log in 36, 39
Log in tries allow ed 141

141

-EE-mail
Schedules and Reports 67
E-mail Booking(s) 50, 76
Encryption 18
End of w ork day used in Scan displays 141, 147
End of w ork day used in schedules 71
End of w ork day used in schedules displays 72
Entries
Set Default 70
Examples 30
Export Data 41

-M Maintenance
schedule 55
Meta Groups 92, 100
Microsoft Word® 67
Using for reports 46
Microsoft® WORD 153
Month
Client Schedule (calendar) 129
Resource Group Schedule (calendar) 119
Resource Group Schedule (timeline) 113
Resource Schedule (calendar) 124
Multiple data sets 38

-FFee 62, 159
Files
Add to a Booking 52
Filter Resources 100
Filters 61, 66, 160
FIRST USER 16
Flexible Period
Resource Group Schedule 120
Format
Vertical or Timeline for Schedules
Format Time 162

40, 73

-NNetw ork login

39

-O-

113, 162

General Users 24, 134, 160, 163
Graphical Schedules 53, 162
Groups
Resource 90, 97, 99, 102, 161
User 74, 75, 139, 140, 163

ODBC 9
OLE Automation Error message 11
OLE Automation Errror message 46
Open Data Base Connectivity 9
Optimize for many resources 141
Ordering ResSched 7, 34
Over booking resources 86
Overbooking 54

-H-

-P-

Holidays 72, 149, 162
Host Name 16, 37

Passw ord 134
Change 69
PDF 67, 151
Percent days used in utilization 94, 102
Percent hours used in utilization 94, 102
Pooled Resource 88, 96, 126, 161
Add 62
Pooled Resource Availability w indow
Availability 126
Pop-up Calendar 160
Port 16, 37
Preferences 141, 147
Preview reports 158
Primary Resource 161
Print
Schedules and Reports as PDF's 67
Single booking 52
Print bookings 44
Print calendars 44

-G-

-IImport client and resource data 42
Inactive 160
Inactivity time out 18
Installing ResSched 14
Interval used in Scan displays 141, 147
Interval used in schedules. Change 72
Invoice 58
Invoice for Clients 107
IP Address 16, 37
IP Server Manager
Vista 18

-LLabels 69
Labels for Resources Bookings Clients Categories

141

Copyright 1997-2013, MadrigalSoft Tools Inc.

Index
Print in Color 69
Print Schedules and Reports w ith MS WORD
Print Text Calendars 156
Private Bookings 49, 55, 161
Purge
Booking Log 87
Purge old bookings 51
Purge Old Bookings w indow
83

67

-QQuarter
Resource Group Schedule (timeline)
Quick start 23

113

-RRate 62
Recurring Booking(s) 50
Reminders for upcoming bookings (alerts) 141
Rent 159
Rental fee 62
Repeat Booking(s) 50, 51, 76, 161
Report preview w indow
158
Reports
E-mail 67
Post on Web 67
Print as PDF's 67
Print in Color 69
Print w ith MS WORD 67
Reserve User
Use reserve user user name as the client automatically
141
Resource 52
Resource Month Schedule w indow
124
Resource Administrator 24, 134, 161
Resource Filters 66
Resource Group 92, 102, 113, 114, 117, 119
Add Resource(s) to a Resource Group 60
Brow se Bookings of a Resource 52
Brow se Bookings of a Resource Group 52
Flexible Period Schedule 120
Resource Group Day Schedule w indow
Day Schedule (vertical) 114
Resource Group Month Schedule Window
Month Schedule (calendar) 119
Resource Group Timeline Window
View Timeline Schedule 113
Resource Group Utilization w indow
64
Utilization 102
Resource Group Week Schedule Window
Week Schedule (vertical) 117
Resource Group(s) 90, 97, 99, 160
Add 64, 97, 99
Add Resources to 64
Brow se 99
Change 65, 97, 99
Combination Groups 66
Definition 161
Delete 65, 99
Limit to specific users 65
Select 99
Copyright 1997-2013, MadrigalSoft Tools Inc.

Select multiple resource groups 100
Temporary 100
Utilization 64
Resource Utilization w indow
94
Resource Week Schedule w indow
122
Resource(s) 88, 90
Add 60, 88, 90
Add to a Resource Group 60
Add to Resource Group 64
Authority to Book\View
134
Authorize users to book/view
88
Availability of Pooled Resource 126
Brow se 61, 90
Change 61, 88, 90
Definition 161
Delete 61, 90
Display several at a time 62
Double booking 54
Filter by Criteria 61
Inactive 160
Make temporarily unavailable 61
Month Schedule (calendar) 124
Pooled 161
Pooled units 96
Primary 161
Restrict w ho can view or book 62
schedule conflicts 54
Select multiple resources 92
Select single resource 90
Set charge out rate for 62
Set Default 70
Utilization 94
View w eek schedule (vertical) 122
Restrict w ho can book resources 62
Restrict w ho can view resources 62
Routine Booking(s) 76, 83, 141, 147, 161
Add 55, 70, 83
Brow se 83
Change 83
Use color for 83
Routine Duration(s) 76
Add 70

-SScan 147, 162
Column Width 141, 147
Interval 141, 147
Row Height 141, 147
Scenarios 30
Schedule 72, 113, 131, 133, 162
Availability of Pooled Resource 126
Category Day (timeline) 133
Category Month (timeline) 133
Category Quarter (timeline) 133
Category Week (timeline) 133
Category Year (timeline) 133
Client for Week (vertical) 127
Client Month (calendar) 129
Column Width 72
conflicts 54
Day for Client (timeline) 131

167

168

ResSched 9.9

Schedule 72, 113, 131, 133, 162
Day for Resource Group 113
Day for Resource Group (vertical) 114
Display Format 113, 162
Graphical 162
Layout Vertical or Timeline 113, 162
Month for a Resource (calendar) 124
Month for Client (timeline) 131
Month for Resource Group 113
Quarter for Client (timeline) 131
Quarter for Resource Group 113
Resource for Week (vertical) 122
Resource Group Flexible Period 120
Resource Group for a Week (vertical) 117
Resource Group Month (calendar 119
Row Height 72
Set Options 72
Text 72
Week for Client (timeline) 131
Week for Resource Group 113
Year for Client (timeline) 131
Year for Resource Group 113
Schedule conflicts 82, 86
Schedule maintenance 55
Schedule vacation 55
Schedules
Change betw een timeline and vertical layout 40, 73
E-mail 67
Post on Web 67
Print as PDF's 67
Print in Color 69
Print w ith MS WORD 67
View
53
Secure Socket Layer 18
Security settings 141
Select
Multiple resource groups at one time 100
Multiple resources at one time 92
Multiple users at one time 138
Resource Group(s) 99
User(s) 137
Server 37
Server Connection Failed message 18
Server time out 18
Set
Alerts 69
Schedule Options 72
Settings 141
System w ide 69
Special Days 141, 149, 162
Add 149
Change 149
Include in utilization 94, 102
Set 72
Show ing conflicts w ith 86
SSL 18
Standard Edition 6
Start of w ork day used in Scan displays 141, 147
Start of w ork day used in schedules 71, 72
Start ResSched 36
Start Time

Default for bookings 141
Set Default 70
Status 141, 150, 162
Subdirectory
In shorcut target property 38
Suspended User 134, 137
SYSLIC not found message 11
System Administrator 24, 134, 162
System Settings 141
Set 69
System Settings w indow
69, 141

-T Temporary Resource Groups 100
Text
Change the text source in schedules 72
Time Format 162
Time Line
Resource Group Schedule 113
Time out 18
Timeline 131, 133
Change layout used for toolbar schedule buttons
Timeline Schedule Layout 113, 162
Category 133
Client Schedule 131
Toolbar 40, 73
Trouble Shooting 11

40, 73

-UUninstall 14
Units of a Pooled Resource 161
Units of Pooled Resource w indow
96
Update Resource w indow
140
Update System Settings w indow
141
Update User Group w indow
140
Update User Preferences w indow
147
Update Users w indow
137
URLs
Add to a Booking 52
Usage fee 62, 159
User
access controls 141
User details
Change 74
User Group(s) 75, 140, 163
Add 75, 139, 140
Change 74, 139, 140
Create 75
Delete 139, 140
User Name 134, 137
User Preferences
Change 69
User(s) 24, 134, 137, 138
Access level 134, 137
Access suspended 137
Add 74, 134
Add to User Group 74
Allow to book or view a resource 62
Authority to Book/View resources 137
Authorize for all resources 134
Copyright 1997-2013, MadrigalSoft Tools Inc.

Index
User(s) 24, 134, 137, 138
Brow se 137, 138
Change 74, 134
Change Passw ord 69
General 134, 160
Resource Administrator 134, 161
Select 137
Select Multiple 138
Suspended access 134
System Administrator 134, 162
Update Access Users 162
View Only 134
View -Only 163
Utilization 94, 102
Client(s) 59, 106
Include special days 94, 102
Include w eekends 102
Resource Group 102
Resource Group(s) 64
Total time and hours used 94, 102
Use actual times 94, 102
Work days and hours available 94, 102
Work days and hours used 94, 102
Utilzation
Include w eekends 94

-VVacation
schedule 55
Vertical
Change layout of toolbar schedule buttons
Vertical Schedule Layout 113, 162
View Only User 163
View Only Users 24, 134
Vista
IP Server Manager 18

-WWeb 67
Web server 151
Week
Client Schedule (vertical) 127
Resource Group Schedule (timeline) 113
Resource Group Schedule (vertical) 117
Resource Schedule (vertical) 122
Weekends 147
Exclude from printed calendars 141, 147
Include in utilization 94, 102
Warn if trying to book on 141, 147
WORD 67
Setup for using 153
Work day start and end times for schedules 71

-YYear
Resource Group Schedule (timeline)

113

Copyright 1997-2013, MadrigalSoft Tools Inc.

40, 73

169

